mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik lm2577 und sein Stromgeiz


Autor: Hannes (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich habe eine 12V-> 50V Boost-Schaltung mit lm2577-ADJ aufgebaut.

Die Daten habe ich von der national-Site vom lm2577 -> rechts gibts ein 
applet das einem die Dimensionierung berechnet für vorgegebene Werte.

Funktionierte anfangs gut, leider dauerhaft nur auf ca. 1/3 des 
erhofften sowie errechneten Stromes!

Die Spule hat 22mOhm, ansonsten sind die Elkos Low-ESR, ... ich weiß 
nicht mehr weiter!

Aus verzweiflung habe ich den lm2577 gekillt, wie ich das gemacht habe 
... weiß ich auch nicht.

Trotzdem möchte ich die Schaltung unter neubeschaffung des ICs 
verwenden, die Frage wäre, weiß jemand, woran der Stromarmut bedingt 
ist?

Kann es sein, dass ein nachgeschaltetes Relais auf schaltseite (also 
nicht die spule) irgendwelche impulse erzeugt, die dem LM den garaus 
gemacht haben?
ist so ein normales high frequency 5V relais?

ODer kann dauerhafte Überlastung (was eigtl nur spannungsabfall zur 
folge hätte? ) von sagen wir 15 sekunden dem was anhaben?

ich vermute, dass mein gekillter lm2577 den output transistor 
abgeschossen hat, der wird einfach extrem schnell warm und die spule 
fiept.

mit dem brauch ich also nix mehr machen... soll ich andere bauteile 
wählen/ was anderes machen???

danke im voraus!

Gruß Hannes

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Die Spule hat 22mOhm, ansonsten sind die Elkos Low-ESR, ... ich weiß
> nicht mehr weiter!
Wieviele µH hat die Spule, welchen Kern, wann geht dieser in Sättigung? 
der Ohmsche Widerstand ist so ziemlich das unwichtigste Detail für dein 
Problem.

Und die Diode? Welcher Typ ist verbaut, Schottky, oder 1N4001?

Autor: Hannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oh, sorry.
150µH , 2.6A sättigungsstrom, material: ferrit.
bezeichnung: PISR-151M-04
powered by reichelt

alle anderen werte sind in der grafik selbst eingetragen worden.

danke im voraus!

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Einen Wert vermisse ich: Wieviel Strom brauchst du?

Das mit dem Poti ist gefährlich: Wenn der einen Wackelkontakt hat, 
springt die Spannung gegen unendlich. Daher sollte man das Poti so 
beschalten, dass der Schleifer den Maximalwert nur verringern kann, also 
so dass Schleifer und ungenutztes Ende verbunden sind.

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm, die Spule scheint also i.O. zu sein.
der LM2577, ist der auch "Powered by Reichelt"?
Ist das ein "echter" von national, oder einer der billigen 
China-Nachbauten, die Angelika so gerne verscherbelt?

Autor: Hannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also, wenn China nicht auch schon so dreisst ist, und das N auf ihre 
billigteile raufprägt, dann ist es zur abwechslung ein original!

Ich bräuchte 300mA, das ist laut WEBENCH machbar.
rauskommen aber nur etwa maximal 130mA...

@ Benedikt: Danke für den Tipp, mache ich sofort. allerdings verringert 
sich damit mein Widerstand von 50 auf 25 K :(
Alternativ würde ich einen 50K Widerstand zu meinem Poti 
parallelschalten, damit sind die 50K immer gesichert, selbst wenn das 
poti spinnt.Dazu käme dann einfach noch ein 25K in Reihe.
Den unteren Spannungsbereich brauche ich eh nicht ;)

Ich habe gehört, dass der OUTPUT-Transistor im LM nicht 
überspannungsgeschützt sein soll?

Gruß Hannes

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hannes wrote:
> Ich bräuchte 300mA, das ist laut WEBENCH machbar.
> rauskommen aber nur etwa maximal 130mA...

Ja, sollte gehen.
Laut dem hier:
http://schmidt-walter.eit.h-da.de/smps/aww_smps.html
ergibt sich ein Spitzenstrom von 2A. Das sollte die Spule problemlos 
verkraften.

> allerdings verringert
> sich damit mein Widerstand von 50 auf 25 K :(

Nein, der Widerstand bleibt gleich. Der Teil des Potis zwischen 
Schleifer und mit Schleifer verbundenem Anschluss wird nur von keinem 
Strom durchflossen, solange der Poti einen sauberen Kontakt hat.

> Ich habe gehört, dass der OUTPUT-Transistor im LM nicht
> überspannungsgeschützt sein soll?

Ja. Mach mal ein Foto vom Aufbau, auf dem man die Anordnung der Bauteile 
und die Verdrahtung sieht. Parasitäre Induktivitäten können nämlich 
schnell zu Überspannung führen.

Autor: Hannes (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ja hast recht. Ich hab das falsch aufgenommen und dachte, du meinst, die 
beiden äußeren zusammenzuschalten. ist mir dann in der küche aber auch 
eingefallen, dass es besser geht -> deine variante :-)

das ganze habe ich zum test auf nem steckbrett, die dicken teile mal auf 
teufel komm raus auf dünnere silberlackdraht-Enden aufgelötet. Das 
sollte aber bei < 15W keine Hürde sein, oder?

sollte ich hier prinzipiell dinge falsch machen, bitte aufklären! ich 
mache sicher mehr fehler als ich mir vorstellen kann... ist mein erster 
step-up, hatte vorher nur step-downs, linearregler und massen an 
digitaltechnik, die nichts mit analogtechnik (na sagen wir in grenzen) 
am hut haben (bitte nicht zu genau nehmen ;) )

Auf dem Oszi habe ich auf der Verbraucher-Seite kleine Spikes gesehen, 
als das Ding noch funktioniert hatte.. ich nehem an, die sind normal? 
die waren allerdings so teilweise 4-5V hoch... und das bei 500µs 
Auflösung..

Gruß Hannes

Autor: Alexander Schmidt (esko) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dir ist klar dass über das Steckbrett dann zwei Ampere fließen?
Die low-ESR Elkos sind bei Übergangswiderständen von geschätzt 
100mOhm/Verbindung auch nicht mehr so wichtig.
PS: Positiv anzumerken ist die gute Qualität des Fotos, wie man sie 
leider nicht alle Tage sieht.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hannes wrote:
> das ganze habe ich zum test auf nem steckbrett,

Der Aufbau ist, ich sag mal gewagt.

> Auf dem Oszi habe ich auf der Verbraucher-Seite kleine Spikes gesehen,
> als das Ding noch funktioniert hatte.. ich nehem an, die sind normal?

Bei dem Aufbau ist das normal.
Bau das ganze am besten mal ordentlich auf, also auf Lochraster oder 
einer geätzten Platine, mit kurzen Verbindungen an den kritischen 
Stellen.
Im Datenblatt auf Seite 14, FIGURE 4.
All die Verbindungen die schräg eingezeichnet sind, sollten auch 
wirklich Sternförmig an die entsprechenden Anschlüsse gehen und sollten 
möglichst kurz sein. Insbesondere der Kreis, Pin3, Cin, L, D, Cout, Pin3 
sollte eine möglichst kleine Fläche umspannen.

Autor: Hannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ihr habt recht, ist auch verständlich, nur war bin ich beim 1. mal nun 
mal unsicher und hatte mich deswegen gegen sofortiges Löten 
entschlossen.

Also ist der eindeutige Grund im Steckbrett zu suchen? Oder gäbe es noch 
andere potentielle störquellen?

Gruß Hannes

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hannes wrote:

> Also ist der eindeutige Grund im Steckbrett zu suchen?

Sehr wahrscheinlich.
Die Wahl der Bauteile ist zumindest ok.

Autor: Fralla (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schaltregler auf Steckbrett wird nichts (hatte ich früher auch Versucht)

Mindenstens Lochraster, und Schau das die "Schaltenden Leitungen" eine 
möglichst kleine Fläche aufspannen.

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hannes wrote:
> also, wenn China nicht auch schon so dreisst ist, und das N auf ihre
> billigteile raufprägt, dann ist es zur abwechslung ein original!

Nee, von Fälschungen hab ich bei R. noch nichts gehört, wenn sind das 
Nachbauten, die auch als solche erkennbar sind.

Ich hatte z.B. beim letzten mal "LM 2576 T-ADJ" bestellt, und "TS2576" 
bekommen.
Mit Logo von "Taiwan Semiconductor", laut Datenblatt genauso gut wie das 
Original.
Ausprobiert hab ich die Teile aber noch nicht.

Autor: Fralla (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ähnliches ist mir auch passiert, ich würde es nicht als Fälschung 
bezeichnen, aber man bekommt einfach nicht was man Bestellt -> Betrug

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fralla wrote:
> Ähnliches ist mir auch passiert, ich würde es nicht als Fälschung
> bezeichnen, aber man bekommt einfach nicht was man Bestellt -> Betrug

Betrug würd ich das auch nicht nennen... Steht ja auf jeder 
Artikel-Detailseite: "Hersteller: FREI", auf Deutsch: "Was halt grad am 
billigsten ist".

Und die Datenblätter die Reichelt zum download anbietet sind meist auch 
ein guter Hinweis:
Wenns dort zwei Versionen, eine von "NATIONAL SEMICONDUCTOR" sowie eine 
von "UNISONIC" gibt, kann man sich ja denken was am Schluss in der Tüte 
steckt.

Autor: Michael Fr. (nestandart)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wird lm2577 heiss ?
fast alle STEP-UP's darf man nicht ohne last betreiben.
ich würde mindestens 500 Ohm schalten.
und auf keinen fall aufm steckbrett.

Autor: Hannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich bereite gerade das layout auf punktstreifenraste vor.

500 OHM ? das wär ja 1/3 des nennstromes! ich meine, ja, schon richtig, 
dass niemals ohne last, blos wieviel mindestlast braucht ein lm2577 auf 
50 V output laut datasheet?

ich kann da nix finden, was ein art minimum an I_Load nahebringt... 
Zumal eine minimale last dran ist, nämlich ~62,5k Ohm.

gute nacht gruß,
Hannes

Autor: Toll (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sehe im Datenblatt auch nichts was für eine minimale Last spricht.
Alte Schaltregler konnten nicht ohne, da sie keinen PWM Betrieb kannten, 
die Spannung dann also hochlief. Moderne lassen einfach ein paar Takte 
aus.

Autor: Hannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hab mir jetzt einfach bei national samples von den teilen bestellt.
Hoffe, die kommen an und schön wärs ja noch, gleich morgen :-P

Das Layout muss nicht EMV-gerecht sein, oder? Ist doch alles weit 
unterhalb 100khz. Sicher werde ich trotzdem keine meterlangen 
leiterbahnen verwenden . Meine Schaltung würde auf 18x17 Loch passen. 
Liegt aber daran, dass ich wie oben das Bild zeigt, viele SMD-Teile 
habe, die ich auch auf den Leiterbahnen auflöte, vorher die anderen 
weg-dremel.

Hab mir das Datasheet nochmals zu Gemüte geführt. Man lässt sich leicht 
durch den Anfang etwas hinreißen:

"Included on the chip is a 3.0A NPN switch and its associated
protection circuitry, consisting of current and thermal limiting,
and undervoltage lockout"

Leider, steht dann irgendwo klein als Fußnote, dass das bei 
Step-Up-Beschaltung nicht der Fall ist. Wenn man also nicht alle 
Ostereier im Sinne von Hinweisen auf dem Sheet gefunden hat, dann wird 
man mal so richtig bestraft (ich zumindest). Aber was hat man nicht 
alles von dem Leergeld :-)

Ich melde mich, wenn ich das auf Lochraster aufgebaut habe - und sage 
euch, was der Wechsel gebracht hat!

Gruß Hannes

Autor: Mario Grafe (mario)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es wird immer wieder vergessen, das die Regler eine interne 
Leistungsbegrenzung haben- Im Datenblatt (national instruments) steht 
auf Seite 4 bei den "Absolute Maximum Ratings" -> Power dissipation 
internal limited. Die Gesamtverlustleistung welche der Baustein aushält 
hängt vom Gehäusetyp ab (s. Tabelle S. 12 Datenblatt).

Ich vermute mal dein LM2577 regelt einfach ab, weil im die 
Verlustleistung zu hoch ist.

Autor: H.Joachim Seifert (crazyhorse)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Das Layout muss nicht EMV-gerecht sein, oder? Ist doch alles weit
unterhalb 100khz."

Wichtig ist nicht nur die Schaltfrequenz...

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was die Leistungsbegrenzung angeht wäre ich etwas vorsichtig: "Due to 
timing considerations of the LM1577/LM2577 current limit circuit, output 
current cannot be internally limited when the LM1577/LM2577 is used as a 
step-up regulator. To prevent damage to the switch, its current must be 
externally limited to 6.0A."

Autor: Hannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
eben! deshalb meinte ich ja, dass es zwar ganz vorn im sheet steht, dass 
er protection hat, aber eben beim step-up -"modus" nicht..

mein lm2577 ist richtig durchgeschossen, mit dem teil kann ich 
problemlos > 5A ziehen, wenn ich das ding mit 165 Ohm belaste ( 
entspräche 300 mA auf belastungsseite)

Der wird selbst bei ner LED und nem 10k WIderstand in reihe richtig 
heiß, auch mit Kühlkörper, der 3 mal größer als der ic selbst ist.

Daher "maximum power-dissipation : selbstabregelnd" imo nur dann gültig, 
wenn man ihn nicht im step-up modus betreibt. Leider!

@H.joachim Seifert:
vollkommen richtig, aber ist die Frequenz nicht maßgeblich daran 
beteiligt? Was wäre noch zu beachten?


Gruß Hannes

Autor: Hannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So!

Ich wollte nur abschließen und sagen, dass es wirklich daran gelegen 
haben muss. Ich habe das nun auf einer Lochraster-platine aufgelötet, 
schnurrt wie ein kätzchen, liefert wie berechnet den Strom bei 50V.

Resumé: Step-up-Regler nie auf Steckbrett aufbauen! Da wär ich nie im 
Leben drauf gekommen, dass das daran liegt.

Danke für Eure Hilfe!

Gruß Hannes

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.