mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik MAX 455 - Videoswitch Probleme


Autor: Marcus M. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hier versuche den MAX455 als Videoumschalter für Composite und S-Video
zu benutzen. Bei beiden Signaquellen fängt der Baustein förmlich an zu
glühen und für einen kurzen Moment habe ich auch ein Signal am Ausgang.

Dies ist allerdings etwas schwach.

Ich habe mitlerweile auch alle Maxim Appnotes durchgeblättert, kann
aber den Fehler in der Schaltung irgendwie nicht finden.
Könnte von Euch mal bitte jemand drüberschauen?

Ist es eigentlich normal, das ein µA7905 eine Leerlaufspannung von -20V
aufweißt und im Moment der Leistungsabnahme auf -5V zurückfällt?

Autor: Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Leider hast Du nur einen Teil deiner Schaltung geposted.
Lt. Datenblatt ist am Ausgang des 455 ein 75R geschaltet.
Dient der nur zur Impedanz oder begrenzt der auch was ?

MfG  Uwe

Autor: Chris (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

am 7905 müssen immer -5 V heraus kommen, sonst ist etwas faul.

Was für einen Wert hat denn der C5? Warum hat R2 genau 1070 Ohm? Achso,
die stammen aus Figure 1, Seite 6. Pikofarad muß man raten.

Du darfst natürlich nicht den "full scale output current" von 20 mA
laut Datenblatt überschreiten, was an 50 Ohm Last leicht passieren
kann. Viel mehr als 1Vss verkraften die Eingänge nicht. Die Ausgänge
auch nicht.

Wenn's nicht geht wie in Figure 1, stimmt mit den Betriebsspannungen
oder den Eingangssignalen oder der Last am Ausgang etwas nicht.

Falls ein "Latch up" passiert, wird das IC auch sehr heiß, muß aber
nicht kaputt gehen, falls Dein Netzteil eine Strombegrenzung hat.

Gruß

Autor: Marcus Maul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

erstmal Danke für Eure Antworten:

@ Uwe, der dient eigentlich nur zur Impendant IMHO. Der ist auch
nachträglich eingefügt worden. Ich hab den bei der Zeichnung nur
vergessen nachzutragen.Sorry!

@ Chris:
Dann weiß ich ehrlich nicht mehr, was an dem Netzteil kaputt ist, den
ich hab schon alles ausgetauscht. 470µF am Eingang, 47µF am Ausgang.
Entweder bricht die Spannung sofort zusammen oder springt von -19V auf
-5V.
Bei 75 Ohm ist die Gefahr allerings nicht besonders groß.
Was ist denn bitte ein Latch up?

Sorry, kan nmir darunter nichts vorstellen.

Gruß MArcus

Autor: Jornbyte (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Marcus Maul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Johnbyte,

Danke für Deinen Link!

Autor: Marcus Maul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich steh ich mir jetzt entweder auf dem Schlauch, oder habe endlich
verstanden, wo das Problem ist.
Im Datenblatt steht, "direktly drive 75Ohm cable". LAut Messungen
sollte das Compisit Signal mit 75Ohm arbeiten. Also brauch ich gar
keine Widerstände und kann die Eingänge und den Ausgang direkt
anklemmen?

Der Widerstand zwischen Pin 19 und 20 muß Null Ohm betragen und der
Widerstand zwischen Pin 19 und Ground muß unendlich sein?

GRuß und Danke für Eure Antworten

Autor: Chris (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dein Ausgang ist niederohmig, benötigt dazu in Reihe einen
75-Ohm-Widerstand, über den man das Coax-Kabel anschließt. Am Ende des
Coax-Kabels wird wieder mit 75-Ohm abgeschlossen.
An den Eingängen ist ein 75-Ohm-Widerstand auch sinnvoll, wenn davor
ein Kabel angeschlossen ist, um korrekten Abschluß des Kabels zu
erzielen.

Beim Latch-up zünden parasitäre Transistoren auf dem chip duch
Eingangsspannungen an den Eingängen, die größer als +5V sind.

Die Verstärkung würde ich auf 1.. 2 einstellen mit den Widerständen,
wie in der Tabelle im Datenblatt.

Du kannst noch 100nF-KERAMIK-Kondensatoren vor und hinter den
Spannungsregler schalten. Die -19V müssen weg!

Gruß

Autor: Fritz Ganter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Beim Latch-up zünden parasitäre Transistoren..."

Soll bestimmt Thyristoren heissen.

Autor: Rahul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie hast du denn denn 7905 betan? Dass er eine andere Anschlussbelegung
hat als der 7805 weisst du, oder?

Autor: Marcus M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Rahul,

ja, das ist mir bekannt.
Ich habe mir eben nochmal die Datenblätter angeschaut. Kein Fehler
sichtbar arg

Soll ich denn wirklich einige defekte erwischt haben?

Gruß ... to be continued ...

Autor: Marcus M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, nun hab ich dem 7905 endlich die -19V ausgetrieben.

Der MAX455 schaltet derzeit auch zwischen den einzelnen Kanälen druch.
Leider wird er aber immernoch sehr heiß, was ich wirklich nciht
verstehen kann.

Autor: Rahul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wo lag denn der Fehler bim 7905?
Conrad hat unter der Bestell-Nummer 750115-14 einen Video-Umschalter
allerdings mit dem MAX454, und stellt auch Schaltplan und Anleitung zur
Verfügung.
Vielleicht findest Du da eine Lösung.
Gruß Rahul

Autor: Marcus M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Rahul,

den Fehler beim 7905 war eine schlechte Lötstelle an der TRafowicklung
und eine anscheinend defekte Lieferung der µA7905.
Alle 3 haben eine Leerlaufspannung von -19V. Die TSL 7905 dagegen
arbeiten einwandfrei.

Leider hats den MAXIM dabei geschrottet arg. 20,-- Eur in den Sand
gesetzt. Hoffe auf Samples... .

Danke für alles.

Meld mich nochmal, wenn alles wieder klappt.
GRuß

Autor: Marcus M. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

nachdem ich nun mit ein paar netten Leuten von Maxim geredet und Ersatz
bekommen habe, hier die funktionierende SChaltung, für die, dies
interessiert.

Zu den Fehlern:
- defekter Trafo
- defekter µA7905
- defekte Verbindung zwischen 2. Wicklung und Pin - im TRAFO!

Mit anderen Worten, Pech auf der ganzen Linie und mal wieder etwas
dazugelernt. Prüfen, prüfen, prüfen, prüfen bis zum excess.
Auch wenn alles auf den ersten Blick okay ist und die Spannungen
stimmen, kann trozdem alles im Eimer sein!

Gruß Marcus

PS: Wenns irgendwo - 19V regnet, ist definitiv alles in Fritten und zu
regeln gibts da nix mehr!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.