mikrocontroller.net

Forum: PC Hard- und Software USB -> RS232-Adapter wird als Maus erkannt


Autor: Armin S. (nimra)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich habe folgendes Problem:
Wenn ich mein Rumpus-Board per USB->RS232-Adapter anschließe, wird 
dieses als Maus erkannt und es entstehen wilde klicks. Dazu gibt es 
bereits einen Thread, dort sind zwar Lösungen beschrieben, jedoch alle 
für Windows. Ich aber benutze Linux (Kernel 2.6.29).

Thread: Beitrag "GPS wird als maus erkannt"

Vielen Dank für Eure Hilfe!

Autor: Teplotaxl X. (t3plot4x1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Xserver hat seit den paar letzten Versionen ne autmatische 
Hardwareerkennung via HAL.

Hau mal

Section "ServerFlags"
   Option "AutoAddDevices" "False"
   Option "AutoEnableDevices" "false"
EndSection

An den Anfang deiner xorg.conf.

Falls es immer noch nicht geht, mal die xorg.conf posten.

Autor: meha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Der Xserver hat seit den paar letzten Versionen ne autmatische
> Hardwareerkennung via HAL.
>
> Hau mal
Section "ServerFlags"
   Option "AutoAddDevices" "False"
   Option "AutoEnableDevices" "false"
EndSection
> An den Anfang deiner xorg.conf.
>
> Falls es immer noch nicht geht, mal die xorg.conf posten.
Ja, aber der aktuelle xorg-Server hat keine xorg.conf mehr.

Autor: Teplotaxl X. (t3plot4x1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
meha schrieb:
>> Der Xserver hat seit den paar letzten Versionen ne autmatische
>> Hardwareerkennung via HAL.
>>
>> Hau mal
>
> Section "ServerFlags"
>    Option "AutoAddDevices" "False"
>    Option "AutoEnableDevices" "false"
> EndSection
> 
>> An den Anfang deiner xorg.conf.
>>
>> Falls es immer noch nicht geht, mal die xorg.conf posten.
> Ja, aber der aktuelle xorg-Server hat keine xorg.conf mehr.

Ist nicht zwingend, da alles automatisch erkannt werden sollte. Doch ich 
habe immer noch eine xorg.conf wegen des proprietären nvidia Treibers.
Wenn keine da ist, einfach eine leere erstellen und das besagte 
reinkopieren.

Autor: meha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>> Der Xserver hat seit den paar letzten Versionen ne autmatische
>>> Hardwareerkennung via HAL.
>>>
>>> Hau mal
>
 Section "ServerFlags"
    Option "AutoAddDevices" "False"
    Option "AutoEnableDevices" "false"
 EndSection
>>> An den Anfang deiner xorg.conf.
>>>
>>> Falls es immer noch nicht geht, mal die xorg.conf posten.
>> Ja, aber der aktuelle xorg-Server hat keine xorg.conf mehr.
>
> Ist nicht zwingend, da alles automatisch erkannt werden sollte. Doch ich
> habe immer noch eine xorg.conf wegen des proprietären nvidia Treibers.
> Wenn keine da ist, einfach eine leere erstellen und das besagte
> reinkopieren.
Dass man eine haben kann weiß ich, aber ich dachte, dass wenn eine 
da
ist, es auch eine vollständige xorg.conf sein muss?

Autor: Teplotaxl X. (t3plot4x1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
meha schrieb:
> Dass man eine haben kann weiß ich, aber ich dachte, dass wenn eine
> da
> ist, es auch eine vollständige xorg.conf sein muss?
Bin mir grad nicht sicher, aber sich ne xorg.conf nach ner Vorlage zu 
erstellen, ist auch keine große Kunst.

Autor: Armin S. (nimra)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

erst mal vielen Dank für all die Beiträge. Ich habe eine xorg.conf wegen 
fglrx-Treibern, also das ist kein Problem. Ich werde die Anleitung jetzt 
ausprobieren.

P.S. Ich habe noch die Ausgabe von lsusb angehängt.

Autor: K. J. (theborg0815) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zur xorg.conf Angegebene Parameter in der Datei überschreiben die 
Autoeinstellungen deswegen kann man die noch benutzen.

Autor: Armin S. (nimra)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

der Converter wird nicht mehr als Maus erkannt, also soweit schon ein 
Erfolg, minicom erhält jedoch keine Signale. Wenn ich den Converter nun 
trenne und dann zuerst an den PC, dann an das Board anschließe 
funktioniert es einwandfrei. Schließe ich den Converter zuerst ans Board 
an, wird er wieder als Maus erkannt. Insofern ist es zwar kein Problem 
mehr, aber wenn jemand eine Lösung weiß, kann er sie gerne posten. ;)

Also vielen Dank an euch alle.

nimra

P.S. Habe noch meine xorg.conf angehängt

Autor: Teplotaxl X. (t3plot4x1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich würde vermuten, dass udev daran schuld ist.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.