mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Phasenanschnitt-Dimmer


Autor: kay (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hallo,
habe mir die schaltung wie im anhang aufgebaut,
gedimmt wird mit einem atmega8,allerdings fängt die Lampe erst bei 
ca.80% an zu leuchten also ab ca.4,5Volt.
vielleicht könnte mir einer ein bischen weiterhelfen

mfg

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> gedimmt wird mit einem atmega8,
Und wie?
Wo ist der uC angeschlossen?
Wo sind die 4,5V, was sind die 80%?
Software?

Autor: kay (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oben genannte schaltung ist nur das leistungsteil.

>Wo ist der uC angeschlossen?
am Optokoppler Pin1

>Wo sind die 4,5V
lege ich eine Spannung von 4,5Volt an beginnt die lampe zu leuchten

>, was sind die 80%?
software-PWM 80% sind ungefähr 4,5Volt


mfg

Autor: Daniel P. (daniel86)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wo legst du die Spannung von 4.5V an?

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> lege ich eine Spannung von 4,5Volt an beginnt die lampe zu leuchten
Du kannst nicht so einfach Analogwerte mit einem Optokoppler 
übertragen, das weißt du schon?

Autor: SMD-Porzellanisolator (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Reicht denn der Steuerstrom für den Triac zum zünden ?
Auge ins Datenblatt?

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

nach Datenblatt brauchst du eine Steuerspanng von -15V bis 0.

Ich rate jetzt mal: Du machst mit PWM über den Optokoppler eine 
Steuerspannung für den Phasenanschnitt. Wenn du bei 80% PWM erst 4,5 V 
hast dann passt die Frequenz deiner PWM nicht zur Zeitkonstant deines RC 
- Gliedes. Du solltest bei 12V sein.

Autor: kay (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

>Ich rate jetzt mal: Du machst mit PWM über den Optokoppler eine
>Steuerspannung für den Phasenanschnitt.
ja genau

der Mc gibt die PWM korrekt aus,das RC-Glied besteht aus R7,R12,C7,C8.
es ist kein unterschied ob ich PWM-Frequenz ändere,laut meiner 
Lcd-Anzeige
beginnt die Lampe bei 80% zu Leuchten und bei 100% volle Helligkeit.
Wiederstände,Kondensatoren habe ich alle mit denn im Schaltplan 
angebenen Werten aufgebaut.

vielleicht hat jemand noch eine idee

mfg kay

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> der Mc gibt die PWM korrekt aus
Welche Frequenz?
Ist der Optokoppler schnell genug?

Deine RC-Impedanz ist sehr hochohmig, laut DB hat der OK
bei 75 Ohm Lastwiderstand Schaltzeiten im Bereich um 3us,
bei 1k Last sind das schon 25us (etwa Faktor 10).
Die Impedanz deiner Beschaltung liegt nochmal deutlich höher,
so dass der OK
1. extrem asymetrisch überträgt (Ein-Flanke schnell, Aus-Flanke 
langsam...)
und 2. sehr langsam ist    :-o

Autor: msnider (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo kay,

ich würde die sache ganz anders angehen. zuerst musst du den µc über 
int0 synchronisieren, das schaffst du mit einem 741 und einem 
schmitttrigger. Als schaltendes element würde ich dir ein solidstate 
relais empfehlen und zwar mitmomentanschaltungseigenschaften (es gibt 
welche die schalten im nulldurchgang andere sind fähig zu fast jeder 
momentanzeit zu schalten verz. 1ms). Du brauchst die zweite variante. 
nun musst du das timersignal (8bit reicht ermal) auf möglichst genau 
20kHz takten. das counterregister dient dir dabei als zündzeitpunkt.
nun bist du inder lage etwa 200 phasenanschnittspunkte zufahren.die 
relais
haben alle einen optokoppler vorgeschaltet. also nichts kann passieren.
schau dir mal die dinger im reicheltkatalog an, die gehen nicht!, aber
die firmen die dort aufgelistet sind stellen solche typen her ,die das
können.(10-40A kein problem)

wenn dich meine methode interessiert poste nochmal und ich zeichne dir
einen schaltplan, den du als ausgangspunkt benützen kannst

gruß michel

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ohne groß die Schaltung zu analysieren sehe ich hier mindestens 2 
Probleme:
1. der Thyristor/Triac braucht genügend kräftigen Zündstom zur rechten 
Zeit
2. Dein Mikrocontroller schaltet ihn zu spät ein.

Meine Glaskugel meint: Wahrscheinlich ist der Zündimuls einfach zu 
schwächlich oder Flanken total verschliffen?

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Kay!
Schau Dir mal
http://frantisek.rysanek.sweb.cz/U2008B.htm
an. Du brauchst einen 1k-Widerstand zwischen Gate und A1 des Triacs.

Grüße
Michael

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.