mikrocontroller.net

Forum: PC Hard- und Software Festplatte vegisst Partitionen


Autor: Holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe zwei SATA-Platten von Samsung. Ich mache mittels Knoppix regelmäßig 
ein Vollbackup mittels dd_rescue.

Nur eine Festplatte ist dauern in Betrieb. Beide sind in Wechselrahmen 
und abschaltbar.

Nun macht /dev/sda Probleme. Will meinen, dass die Partitionen vergessen 
werden. Ich kann mittels grub linux als auch Windows XP auswählen. Doch 
keines der Systeme bootet. Linux (Kubuntu) landed in der Konsole und es 
wird behauptet, dass /dev/sda7 nicht mehr da ist. Windows bleibt stumpf 
hängen. Wenn dies der Fall ist, dann brauchte der PC auch schon beim 
Hochfahren länger um die SATA-Platte zu finden. Das DVD-Laufwerk findet 
er dann nicht.

Es ändert sich auch nichts. Da kann ich den PC 100x neu starten.

Soooo, dann zweite HD einschalten und Knoppix vom DVD-Brenner booten, 
mittels dd_rescue die boot-Partition kopieren (dd_rescue -v -b 1045576 
/dev/sdb1 /dev/sda1) und reboot.

Der PC funktioniert dann für einige Tage normal. Bis er dann die 
Partitionen nicht mehr finden kann. boot-Partitions-Backup und gut ist 
es. Aber auf die Dauer ist dieses sehr lästig.

Kennt jemand ein solches Verhalten?


mfg
Holger

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Festplatte defekt?

Autor: Holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>Festplatte defekt?

Jo, dass wird wohl so sein. Aber es gibt halt, wenn nicht gerade was 
vergessen wird, überhaupt keine Probleme. dd_rescue läuft fast 
wöchentlich und es werden mir nie defekte Sektoren angezeigt. Wenn die 
Platte richtig schrottig ist, sieht das anders aus.

Holger

Autor: zwieblum (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
betreib' die platte noch ein paar wochen, dann ist sie richtig 
schrottig.

Autor: Reinhard S. (rezz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Holger schrieb:

> Linux (Kubuntu) landed in der Konsole und es
> wird behauptet, dass /dev/sda7 nicht mehr da ist. Windows bleibt stumpf
> hängen. Wenn dies der Fall ist, dann brauchte der PC auch schon beim
> Hochfahren länger um die SATA-Platte zu finden. Das DVD-Laufwerk findet
> er dann nicht.

Er findet das DVD-Laufwerk auch nicht?

> Soooo, dann zweite HD einschalten und Knoppix vom DVD-Brenner booten,
> mittels dd_rescue die boot-Partition kopieren (dd_rescue -v -b 1045576
> /dev/sdb1 /dev/sda1) und reboot.

So wie ich das verstanden habe kopierst du die 1. Platte komplett auf 
die zweite. Also müsste es doch einwandfrei funktionieren wenn du die 1. 
abschaltest und nur mit der 2. startest. Oder?
>
> Der PC funktioniert dann für einige Tage normal. Bis er dann die
> Partitionen nicht mehr finden kann. boot-Partitions-Backup und gut ist
> es. Aber auf die Dauer ist dieses sehr lästig.
>
> Kennt jemand ein solches Verhalten?

Nein, ist mir bisher auch unbekannt. Ohne die 1. Platte funktioniert 
aber alles?

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Manche Distros erkennen ihre Partitionen anhand der 
Disk/Filesystem-Labels und Volume-IDs, eventuell ist das dein Problem:
nach dem dd_rescue gibts diese doppelt, und je nach Wetterlage könnten 
die hotplug-scripts einfach mal die falsche partition beim booten 
mounten?

Autor: Holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>Er findet das DVD-Laufwerk auch nicht?

Hallo,
nene, wenn der PC startet dauert es nur ewig, bis die 400GB-Platte 
erkannt wird. Wenn dies so ist, wird das DVD-Laufwerk nicht erkannt. Die 
Festplatte wird angezeigt.


>>Manche Distros erkennen ihre Partitionen anhand der
>>Disk/Filesystem-Labels und Volume-IDs,
Das habe ich ausgeschaltet. Sowohl in der menu.lst als auch in der 
/etc/fstab stehen nur die devices:

holger@dl9hda-desktop:~$ more /etc/fstab
proc            /proc           proc    defaults        0       0
/dev/sda7       /               ext3    relatime,errors=remount-ro 0 
1
/dev/sda3       /boot           ext3    relatime        0       2
/dev/sda9       /daten          ext3    relatime        0       2
/dev/sda8       /home           ext3    relatime        0       2
/dev/sda10      /mp3            ext3    relatime        0       2
/dev/sda5       /win_d          ntfs    defaults,umask=007,gid=46 0 
1
/dev/sda1       /wind_c         ntfs    defaults,umask=007,gid=46 0 
1
/dev/sda6       none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0 
0
holger@dl9hda-desktop:~$

>>dd_rescue gibts diese doppelt
Das kann nicht sein, da ich außer /dev/sda1 noch nichts zurückgespielt 
habe.

Also im Februar ist die erste 400GB-HD, die ich bis dahin verwendete 
gestorben. Aber richtig so mit Sektorfehlern und so. Dann habe ich meine 
bisher nur zum Backup verwendete HD zur neuen Standard-HD gemacht (es 
ist die 400GB Platte um die sich dieser Thread dreht) und eine 500GB-HD 
als Backup. In 1.5 Jahren habe ich übrigens nie das Backup 
zurückgespielt. Kubuntu läuft halt. Lediglich in jüngster Zeit musste 
die boot-Partition zurückgespielt werden.

Mir sind dann wohl in kürzester Zeit zwei Samsung 400GB-HDs gestorben. 
Toll!



Holger

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1.Retten was noch zu retten ist.
2.Wenn es der gleiche HD-Typ ist, könntE es auch wieder mal ein 
Serienfehler sein. Das fängt mit leichter Vergesslichkeit an und endete 
wenige Tage später mit Totalausfall der HD? Mal die Suchmaschine fragen 
nach dem genauen Typ.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Holger schrieb:

>>>Manche Distros erkennen ihre Partitionen anhand der
>>>Disk/Filesystem-Labels und Volume-IDs,
> Das habe ich ausgeschaltet.

Was auch nicht risikofrei ist. Seit Linux auch ATA Disks als /dev/sdX 
und nicht mehr als /dev/hdX einsortiert kann man sich nie sicher sein, 
ob das was heute /dev/sda hiess nicht morgen unter /dev/sdb läuft, weil 
man heute ohne und morgen mit SD-Card oder USB-Stick drin gebootet hat 
und das aus irgendwelchen Gründen vorneweg gezählt wird.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.