mikrocontroller.net

Forum: PC Hard- und Software ATX-Netzgerät als 12V-Spannungsquelle


Autor: Jupp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe eine Frage zur Nutzung eines ATX-Netzgerätes als 
12V-Spannungsquelle für ein LiPo-Akkuladegrät. (Das Netzgerät hat schon 
ein paar Jahre auf dem Buckel und sollte 250W und 10A bei 12V liefern 
können.)

Schalte ich das Netzgerät ohne Last ein, läuft es an und stellt mir 
11,8V (wie gesagt unbelastet) zur Verfügung. Beim Anschluss des 
Ladegerätes funktioniert das Laden ohne Probleme (dürfte zwischen 1A und 
2A ziehen). Ich habe daher bisher nicht gemessen, ob bzw. wie sehr die 
Spannung dabei einbricht.

Nun hört man ja, dass PC-Netzgeräte eine gewisse Grundlast benötigen, um 
12V stabil liefern zu können. Ich habe daher einen 5V-Ausgang über 2 
parallele 22R-Widerstände (je 2W) und einen 12V-Ausgang über 2 parallele 
56K-Widerstände (je 5W) an die Masse angeschlossen. Damit ziehe ich also 
auf beiden Anschlüssen über den Daumen jeweils 450 und 430mA und 
"verbrenne" ca. 2,3W und 5W. Und jetzt ergeben sich folgende Probleme:

Zum einen werden alle vier Widerstände SEHR heiß (= Anfassen unmöglich), 
was etwas verwundert, weil die entnommene Leistung nur bei ca. der 
Hälfte der Leistungsfähigkeit der Widerstände liegt. (Ist das normal?) 
Was mich aber vor allem wundert ist, dass das Netzgerät nach Anschluss 
der Widerstände nur noch ca. 10,7V an den weiteren 12V-Ausgängen zur 
Verfügung stellt. Eigentlich wollte ich mit der Grundlast ja den 
gegenteiligen Effekt erreichen.

Mein erster Verdacht war, dass die rund 7,5W als Grundlast noch zu 
niedrig sind. Deshalb habe ich probeweise zwei alte Festplatten 
drangehängt. Ohne die Widerstände ergibt sich dann eine Spannung von 
11,6V. Wenn ich die Widerstände nun zusätzlich dranklemme reduziert sich 
die Spannung wieder, diesmal aber nicht so deutlich auf 11,3V.

Weiß jemand, woran das liegt? Vielen Dank und Schönen Gruß!

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Erstmal: Die Grundlast braucht das Netzteil nur auf der Schiene, die als 
Rückkopplung für den Spannungsregler hergenommen wird.
Üblich sind die 5V oder 3.3V-Schiene.

Und dann sind 11,3V doch noch voll OK, die ATX-Spannungen sind IIRC mit 
±10% spezifiziert, 11.3 liegt da noch drinnen.

=> Aufmachen, richtigen Poti finden und die 12V nachjustieren. die 3.3 
oder 5V werden dann vermutlich zu hoch werden, aber die brauchst du ja 
nicht wirklich exakt, oder?

Ach ja, und dass deine Widerstände so heiß werden, ist normal. Die 
Energie muss weg, und das als Wärme.
Schau mal im Datenblatt nach, wie heiß die werden dürfen, ist vermutlich 
weit hinter "Autsch" auf dem Finger-Thermometer.

Autor: Michael M. (technikus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Laß die Widerstände auf der 12V-Schiene weg. Geregelt wird sowieso über 
5V oder 3,3V. Auf 12V verbrätst Du nur unnötig Leistung und ziehst die 
Spannung runter.
Leider muß man aus +5V oder +3,3V schon einige Ampere ziehen, damit man 
die 10A aus den +12V rausbekommt. Rechne mal mit 5A, also 25 W 
Verlustleistung. Das ist natürlich unwirtschaftlich und die Abwärme hat 
man auch am Hals. Wenn man auf der 12V-Schiene ordentlich Leistung 
ziehen will, kommt man um eine Modifikation der Regelung im Netzteil 
nicht rum. Sollte man allerdings nur machen, wenn man es sich zutraut, 
am offenen Netzteil zu arbeiten. Vorsicht, die Primärseite führt die 
gleichgerichtete Netzspannung, ist also lebensgefährlich.
Die c't hat da einen guten Artikel gebracht, den kannst Du Dir unter 
http://www.heise.de/kiosk/archiv/ct/2005/10/196_kiosk kaufen.

Nebenbei: Es ist normal, daß die Widerstände so heiß werden. Am besten 
mit thermischen Kontakt zum Gehäuse montieren und dieses als Kühlkörper 
mißbrauchen.

Edit:
@Ernst B*
Die alten AT-Netzteile, die ich offen hatte, hatten keine Potis. Da 
mußte man Festwiderstände tauschen/überlöten. Aber vielleicht sind die 
ATX (alle?) da ja etwas umbaufreundlicher.

Servus
Michael

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael M. schrieb:
> Geregelt wird sowieso über 5V oder 3,3V.

Das war mal. Seitdem die VCore aus den 12V erzeugt wird und nichtmehr 
aus den 5V/3,3V, werden die 12V oder die 12V + 5V geregelt, wie man auf 
den Schaltplänen in der unteren Hälfte der Seite sehen kann:
http://pitts-electronics-home.de/electron/schplsnnt.htm

Autor: Jupp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für die Antworten! Es ist gut zu wissen, dass das Verhalten 
wie beschrieben normal ist, und dass ich nur eine Schiene belasten muss.

Eine Modifikation des Netzteils wäre mir zu heikel, deshalb noch eine 
Frage zur 3,3V-Schiene: Gibt es eine Möglichkeit herauszufinden, ob das 
Netzteil über die 3,3V oder die 5V regelt? Im Zweifelsfall könnte ich 
natürlich beide belasten, aber wenn die benötigte Grundlast so hoch ist, 
würde ich mir das gerne sparen.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ganz einfach: Belaste die 12V ordentlich (z.B. mit einer 50-100W 12V 
Glühlampe), messe die Spannung und belaste dann auch die 5V bzw. 3,3V. 
Ändert sich an den 12V nahezu nichts wenn die 5V oder die 3,3V belastet 
werden, dann ist keine zusätzliche Grundlast notwendig.

Autor: Jupp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe das gestern Abend ausprobiert: Bei meinem Netzteil scheint die 
Regelung über die 5V-Schiene zu laufen.

Vielen Dank für die Antworten, das hat mir sehr weitergeholfen!

Autor: GeraldB (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei Normalbetrieb beträgt die Toleranz für die +12V-Leitung ±5% - d.h. 
die Spannung darf nicht unter 11,4V sinken. Nur bei Maximallast darf sie 
±10% betragen.

Bei ATX-Netzteilen nach altem Standard gilt folgendes:
Grundlast bei +5V -> 0,1A / +3,3V -> 0,3A / bei +12V nicht erforderlich.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.