mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Mac findet STK600 nicht


Autor: Matthias Friedrich (friedl)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe mir ein STK600 gekauft und wollte dieses Board jetzt an meim 
MAC anschließen und in betrieb nehmen. Nur leider findet mein OS X das 
Board nicht. Ich dachte ich bekomme ein /dev/tty.usbserial oder sowas?!
Kann mir jemand helfen was ich jetzt machen kann?

Vielen Dank.

Autor: Frederik Krämer (n0ll4k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich würd mal sagen das du einen passenden Treiber für die USB <-> 
Seriell Schnittstellte installieren.

Mit einstecken und loslegen kommst du hier nicht weiter. Am besten mal 
ein wenig Google bemühen, wie es so mit Treibern aussieht.

An meinem PowerBook musste ich für den mySmartUSB auch erst Treiber 
raussuchen und installieren.
War zu der Zeit auch mit der einzige Adapter der einigermaßen Problemlos 
und schnell mitm Mac zum laufen gebracht werden konnte als ich den 
gekauft habe.

Autor: Matthias Friedrich (friedl)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jo ok. ich suche einen Treiber nur für welchen Chip? Kann mir da jemand 
weiterhelfen? Unter Jungo oder so finde ich nix für den Mac :-(

Möchte so gerne das STK600 an meinem Mac zum laufen kriegen!

Danke für jede weitere anregung.

Autor: Marius Wensing (mw1987)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auch wenn ich mich mit Mac nicht auskenne...

Gibt es avrdude für den Mac? Wenn ja probier mal die aktuellste Version 
davon aus. "avrdude -P usb -c stk600 -p m2560" das müsste klappen, wenn 
libusb installiert ist und avrdude mit libusb-Support compiliert wurde.

MfG
Marius

Autor: Matthias Friedrich (friedl)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hm ich hab jetzt die variante mit der libusb probiert. leider ohne 
erfolg. Kann mir noch jemand helfen?

danke.

Autor: Marius Wensing (mw1987)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Helfen kann dir sicherlich jemand, wenn du mal Details rausrückst. Was 
hast du genau probiert und was gibt es für Fehlermeldungen?

MfG
Marius

Autor: Udo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich benutze das STK600 mit avrdude ohne Probleme.
Das STK600 wird von der offiziellen Version
noch nicht so lange unterstützt, ich habe es mir
damals aus der cvs-Version selbst übersetzt.
Aber momentan sollte die aktuelle avrdude Version
funktionieren (darauf achten, daß die libusb
gefunden wird beim Compilieren).

Ich kann Dir auch mein Binary zum probieren schicken,
falls Du einen Mac mit Intel-CPU hast.

ciao
   Udo

Autor: Matthias Friedrich (friedl)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
danke für die hilfe und unterstützung. ich werde das ganze mit der 
libusb und avrdude noch mal in ruhe durchprobieren und melde mich wenn 
ich neuigkeiten habe. (das wird aber ein paar tage dauern da jetzt 
erstmal feiern angesagt ist)

Danke erstmal ... bis die tage

PS: allen männlichen mitstrietern einen schönenen Männertag und den 
frauen nicht ganz so viel trinkleichen ;-)

Autor: Matthias Friedrich (friedl)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo da bin ich wieder.

ich habe folgendes durchgeführt:

> libusb-1.0.1 gebaut und installiert
> avrdude-5.6 gebaut mit der option LIBS=-lusb und installiert
- STK600 über USB mit dem MAC verbunden
- Sourcefile in eclipse gebaut
> avrdude -pm32 -cstk600 -Pusb -Uflash:w:AVR_Test.hex:a

# avrdude: stk500v2_recv_mk2: error in USB receive
# avrdude: stk500v2_program_enable(): bad STK600 connection status: 
Target not detected (0x00)
# avrdude: initialization failed, rc=-1
#          Double check connections and try again, or use -F to override
#          this check.
#
# avrdude done.  Thank you.

Kann mir jemand weiterhelfen?
schon wenn ich das STK600 anstecke kommt kein eintrag im dev 
verzeichnis.

habe ein Mac PP G4 OSX10.4

danke für dei hilfe.

Autor: Denis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es kommt auch kein neues device in /dev. Aber Du kannst das STK600 als 
Device im Apple System Profiler entdecken.

Ich hab btw. mein avrdude aus folgendem paket:

http://www.obdev.at/products/crosspack/download.html

Das unterstuetzt auch das stk600 per USB.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.