mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Richtige Spannungsversorgung Atmega16?


Autor: Myosotis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
Habe für meinen Atmega ne Platine gelötet zum Programmieren.
Das Flashen und Auslesen klappt einwandfrei,
während des Betriebs treten aber Probleme auf.
Z.B. Macht der Kontroller nicht immer das, was er soll.
Liest falsche Werte vom ADC, gibt ab und zu nur Grütze auf dem LCD
aus...
Kann das an der Spannungsversorgun liegen?
Hab zwischen VCC und GRD nur ein paar 100nF und einen 10uF Kondensator
gehängt (wie im Tutorial, allerdings für den Atmega8 beschrieben
war)...
Reichen die Kondensatoren aus, oder brauche ich da größere?
MfG
Myo

Autor: Chris (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

die Kondensatoren müßten soweit ausreichen, wenn sonst keine
Stromfresser mit dabei sind.

Gruß

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.