mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Verständnisfrage Diode und Co


Autor: Michael Z. (incunabulum)
Datum:
Angehängte Dateien:
  • preview image for 1.png
    1.png
    8,26 KB, 167 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Moin!

für die Ansteuerung von Spulen + Relais habe ich mir folgende Schaltung 
überlegt (Bild). Das ganze funktioniert auch wunderbar, solange ich die 
Leistungsdiode STTA weglasse. D2 existiert ebenfalls nicht. Der PCF 
(nicht zu sehen) schalten den Transi durch, LED geht an, alles gut.

Mit der STTA-Diode ist nur die LED immer an. Es liegen immer was um 4 
Volt am Ausgang (rechts oben). Nur warum? Irgendwie bin ich zu blöd, das 
zu verstehen...

Kann mich einer erhellen?

cu, Michael

Autor: Patrick Weinberger (seennoob)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja die Z Diode D2 is mal falsch gepolt (außer du willst 0,7V an Gate 
haben)sonst versteh ich nicht ganz wie das funktionieren soll, besser 
gesagt was es bewirken soll.

MFG

Autor: Michael Z. (incunabulum)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Von Links wird über einen PCF8574 +12 Volt geschaltet. Insofern hatte 
mich mir überlegt, hierüber entsprechend Überspannungen wegzufiltern. 
Ist aber eh quatsch, da hier nicht mit Spannungen zu rechnen ist. BTW - 
wie kommst du auf +0.7 V als Gatespannung?

Anyway, mein Problem ist der Teil "nach" dem Transistor. Warum leuchtet 
die LED immer, wenn der Transistor nicht leitet? Kann ja nur über D1 
gehen, aber wie? Ich versteh das nicht.

Michael

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>Von Links wird über einen PCF8574 +12 Volt geschaltet.

Der PCF kann aber nur 5V.

MfG Spess

Autor: Patrick Weinberger (seennoob)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
zu den 0,7V du hast die Diode ned in Sperrrichtung geschaltet also 
überbrückt sie den Widerstand R4.

Autor: Michael Z. (incunabulum)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Patrick: Verstanden. Das die falsch rum gezeichnet ist, war mir schon 
klar... brauch ich auch nicht.

@Spess: PCF + ULN2803, sorry.

Will noch einer zum eigentlichen Problem im Leistungsteil was schreiben? 
Warum leuchtet die LED bei installierter STTA-Diode D1, unabhängig von 
der Gatespannung?

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael Z. schrieb:

> Will noch einer zum eigentlichen Problem im Leistungsteil was schreiben?
> Warum leuchtet die LED bei installierter STTA-Diode D1, unabhängig von
> der Gatespannung?

Das kann niemand, da es sich anhand des Schaltplans nicht erklären 
lässt. Dein Aufbau ist also nicht identisch mit dem Schaltplan.

Autor: Michael Z. (incunabulum)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Benedikt, kann ich das so verstehen, dass oben gezeigte Schaltung ohne 
D2 korrekt funktionieren müsste. Tut sie dies nicht, so liegst an der 
physischen Platine etc?

Wenn ja, danke! Dann muss ich dort suchen. Kommt mir zwar spanisch vor, 
aber mal gucken..

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael Z. schrieb:
> Benedikt, kann ich das so verstehen, dass oben gezeigte Schaltung ohne
> D2 korrekt funktionieren müsste. Tut sie dies nicht, so liegst an der
> physischen Platine etc?

Ja.
Damit die LED leuchtet muss entweder der Mosfet leiten, oder Pin 2 
irgendwie mit Masse verbunden sein.
Oder aber die Diode ist nicht so angeordnet wie im Schaltplan, sondern 
geht irgendwie gegen Masse.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.