mikrocontroller.net

Forum: PC Hard- und Software 2,5" SATA Samsung nur in Herstellergerät nutzbar


Autor: Franz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Frage an die Profis / Kenner.
Habe in meinem Laptop eine 40GB SATA Samsung HM040HI. Diese ist leider 
mit der Zeit zu klein geworden, also größere zugelegt und wollte die 
kleinere extern Daten-sichern.
Nun das Problem: das Teil wird nirgends erkannt oder ist nicht 
ansprechbar. Weder über den SATA-Anschluß auf dem PC , noch über einen 
USB-zu-SATA-Wandler.
Bleibt mit nur noch der umständliche Umweg, das Teil im Originalgerät zu 
sichern.
Doch danach kann ich es wohl in die Tonne hauen oder bei der Bucht 
verhökern?
Hatte eigentlich vor, sie wo anders noch weiter zu nutzen. Doch bloß 
wie, wenn das Mistteil nirgends mehr erkannt wird.
Oder mache ich da irgendwelche prinzipiellen Fehler.
Schon damals bei der Installation des nackten Notebooks gab es massive 
Probleme, so daß ich sie im Kompatibilitätsmodus (IDE) einrichten mußte. 
Unter SATA-AHCI war Nichts zu machen (trotz korrekter F6-Vorgehensweise 
bei WIN XP-Install.u. vorhand. Treiber).
Und der Hersteller-Support (FSC/Siemens) wollte mir noch weiß machen, 
daß ich dafür ein spezielles Floppy-LW brauche um den Treiber 
einzuspielen. Jetzt weiß ich auch warum diese blödsinnige und 
unverständliche Info kam. Denn der Hersteller Samsung führt das Produkt 
offiziell gar nicht und wimmelt mit OEM-Produkt ab.
Und nun nach Garantie-/Gewährleistungsablauf meldet sich FSC auch nicht 
mehr. Geschäft ist ja bestens gelaufen.
Irgendwo hab ich mal (von dem Händler glaube ich) was von 
Low-Level-Formatierung gehört.
Leute helft mir mal auf die Sprünge, so was hab ich bis heut noch nicht 
erlebt.

Autor: Bobby (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nur zu dem "nirgends erkannt" eine Frage:
Hast Du es schon mal mit Knoppix probiert?

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also bei IDE gibt es Festplattenpasswörter, die auf LowLevel Ebene 
(Festplattenfirmware) eine Sicherung (gegen unbefugten Zugriff) der 
Daten
vornimmt. Allerdings sollte die Platte zumindest als LowLevel SATA Gerät 
erkannt werden (evtl. wie schon vorgeschlagen mal mit Linux testen).

Ist so ein FP Passwort aktiv, kann man nur "sehr mühselig" von Außen 
wieder dran. Meine Versuche mit einem IDE-USB Adapter (auch direkt am 
IDE) und einer IDE Platte haben alle nicht funktioniert. Wohl auch, weil 
ein Zugriff auf diese Sonderfunktionen von den meisten 
BIOS-Implementierungen abgefangen wird.
Über die kann man nämlich nicht nur die Passwortsicherung einstellen 
sondern auch die Festplatte LowLevel Löschen (z.B. Passwort vergessen => 
Alles Löschen => Platte wieder nutzbar).

Hat denn das BIOS eine Einstellung zum Thema Passwortschutz für die 
Festplatte? Ich kann mir nicht vorstellen, dass die Platte mit dem 
Rechner
auf LowLevel Ebene "verheiratet" wurde....

Autor: Franz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das primäre Problem liegt in der hardwaremäßigen Erkennung unter Windows 
XP Pro auf dem stationären PC.
Die 2,5" SATA-HDD hat keinen Passwortschutz o.ä., sondern ist wohl 
irgendwie herstellungsmäßig inkompatibel zu gängigen SATA-Controllern 
oder wird nur im FSC-Mainboard (NB) abwärtskompatibel (IDE-Modus) 
erkannt, oder wurde somit gegen alternative Anschlußverfahren geblockt.
Ob mit Linux andere BIOS-Erkennungen zu erreichen sind, ist wohl eher 
fragwürdig.
Denn ohne BIOS-HW-Erkennung nützt auch der Versuch mit Linux eher 
nichts. Werd ich aber noch mal nachprüfen, ob die HDD vom BIOS überhaupt 
erkannt wird.
Ist zum Mäusemelken mit dem FSC-Support, erst fragwürdige Tips und 
Ratschläge (Garantiezeit) und hinterher keine Reaktion von dem Laden.
Würde ja schon ein Hinweis reichen.

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du es den mal an ne anderen PC im IDE Modus probiert?

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also irgendwie mag ich das nicht so recht glauben. Was soll da speziell 
dran sein? Eventuell hat das Kabel eine Meise oder sowas. Korrekt 
angeschlossen (Strom und Daten) und der Controller im BIOS aktiviert ist 
aber? SATA ist SATA und da sollte im Normalfall alles kompatibel sein. 
Ich betreibe auch eine Samsung 2,5" in meinem normalen Rechner, das geht 
problemlos.

Autor: Thomas K. (muetze1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Franz schrieb:
> Die 2,5" SATA-HDD hat keinen Passwortschutz o.ä., ...

Wieso bist du dir so sicher? Ich kenne Mainboards welche standardmässig 
ein Passwort, gebildet aus der Rechnerseriennummer, den FP's gesetzt 
haben und beim Booten entsprechend der Platte mitgeteilt haben. Im BIOS 
und sonst irgendwo war davon rein gar nichts zu sehen.

Franz schrieb:
> Ob mit Linux andere BIOS-Erkennungen zu erreichen sind, ist wohl eher
> fragwürdig.

Falsch formuliert: Linux hat im Betrieb nichts mit dem BIOS zu tun, aber 
die Hardwaretreiber in Linux sprechend die Geräte und Controller Low 
Level an und führen somit eine eigene Erkennung durch - die vllt. die 
Platte trotzdem erkennt, da es ein anderer, nicht ein von FSC vllt. 
modifizierter Code ist.

Franz schrieb:
> Denn ohne BIOS-HW-Erkennung nützt auch der Versuch mit Linux eher
> nichts.

Siehe zuvor. Du kannst Linux auf deinem 4 Plattenrechner ohne Probleme 
betreiben, auch wenn du im BIOS nur die Bootplatte eingetragen/erkannt 
hast. Die BIOS HW Erkennung ist eigentlich unnütz, so lange das BIOS 
dies Gerät nicht braucht. Und die halbe Einrichtung für das OS ist auch 
zweifehlhaft (PnP OS installed, etc).

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Vermutung: SATA-1 Platte die sich die Ohren an einem SATA-2 fähigen 
Controller bricht?
Ist mir zwar bisher nur andersrum begegnet, ausschließen würde ich es 
aber nicht.

Gruß aus Berlin
Michael

Autor: Alex W. (a20q90)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich vermute die Platte wird erkannt, muss aber in der Computerverwaltung 
erst aktivirt werden! Sonst taucht nichtmal ein Laufwerksbuchstaben auf!

Hab selber eine Sata hier, und habe das gleche Phänomen gehabt! 
Angestöpselt und nix aufgetauch (wie man es eigendlich gewohnt ist). 
Danach rein in die Computerverwaltung, Platte und Partition als aktiv 
gekennzeichnet, danach formatiert und alles funzte wie es sollte...

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Alex W. schrieb:
> Ich vermute die Platte wird erkannt, muss aber in der Computerverwaltung
> erst aktivirt werden! Sonst taucht nichtmal ein Laufwerksbuchstaben auf!

er schreibt doch recht eindeutig, daß die Platte schon vom 
Controller-BIOS nicht erkannt wird. Da ist das OS noch völlig 
uninteressant.

Gruß aus Berlin
Michael

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.