mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Festspannungsregler 7805 schwingt


Autor: Schorsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nabend Leute,


ich habe eine kleine µC Schaltung fürs Auto gebaut.
Leider hab ich mit dem 7805 Probleme bei höheren Temperaturen.

Beschalten ist der 7805 mit
- 100nF, 10nF, 1µC Keramik unt 100µF elko
Am Ausgang ist ein 100nF und ein 100µF elko verbaut.

Davor ist noch ein Filter mit ner 47µH und 470µF Elko und 2 
Verpollungsdioden.

Zusätzlich sind noch an den paar ICs weitere 100nF nah an den 
Versorgungspins angebracht.

Wenns Draussen schön sonnig uns warm ist, ist es im Auto natürlich 
entsprechend wärmer. Grad an solchen Tagen neigt der 7805 zum schwingen.

An kühleren Tagen läuft die Schaltung Wochenlang ohne Probleme.

Hat jemand ähnliches Verhalten schon mal beobachtet?
Weiss einer Rat? 7805 tauschen, Aussenbeschaltung anders......

Gruss,
Georg.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Millihertz oder Megahertz?

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie hoch ist der Laststrom?

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es gibt Regler die keinen, und welche die einen Mindestlaststrom 
brauchen. Der ist, wenn benötigt, temperaturabhängig (s. Datenblatt).

Autor: Siegfried (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Posten doch bitte den Schaltplan.

Autor: Schorsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,


einen Schaltplan hab ich nicht erstellt.
Es hängt ein Atmega644 und ein SJA1000 mit etwas Aussenbeschaltung dran.

Der Laststrom bewegt sich zwischen 80mA und 100mA.

Georg.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nochmal: Wie schnell ist für dich "schwingt"?

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann würde ich als erstes den 7805 tauschen.

Es sei denn, Du hast keinen Kühlkörper am 7805. Den braucht er hier bei 
100 mA. (Das würde das Verhalten erklären)

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Es sei denn, Du hast keinen Kühlkörper am 7805. Den braucht er hier bei
>100 mA. (Das würde das Verhalten erklären)

Genau. Der geht vermutlich in die thermische Begrenzung.
Kühlkörper nützt nur was wenn auch ausreichend Belüftung
gegeben ist. Ansonsten einen Schaltregler nehmen.

Autor: Schorsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Kühlkörper ist drauf.
Zu Heiss wird der auch nicht. Ich schätze mal knapp 40°. Lässt sich noch 
anfassen.

Ich denk auch dass ich den einfach mal tausche und beobachte ob es 
wirklich daran lag. Nen Schaltregler hab ich hier auch fertig auf 
Platine. Leider passt der nicht mehr auf die Platine bzw. in das 
vorhandene Gehäuse.

Gruss,
Georg.

Autor: M. Beffa (m_beffa)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ein (neues) elektronisches Bauteil nicht das tut was es soll, liegt 
das Problem mit 99%tiger Wahrscheinlichkeit an der Nichteinhaltung 
irgend eines Betriebsparameters.

Wie ist deine Annahme dass der Regler schwingt begründet? Messung mit 
KO?

Wie ist der physikalische Aufbau? Sind die Kondensatoren nahe genug am 
Regler dran?

Könnte es sein, dass die 100uF am Ausgang eine zu grosse Kapazitive Last 
darstellt?

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie ist denn der mechanische Aufbau?
Sind wenigstens je ein Keramik-C an Ein- und Ausgang auch wirklich nahe 
an den Pins des Reglers? Oder haben diese Cs etwas 3cm lange Beine und 
sitzen am anderen Ende der Platine?

Autor: Blubb (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Appnote von den 78xx sagt dass hinter dem Regler nur ein sehr 
kleiner C sitzen soll. im Zweifelsfalle nimm nen Panasonix FC (Farnell 
hat die zb...)
mit recht kleiner Kapazität.

Autor: Blubb (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Noch was, du sagts 75°C Umgebung ....plus die 20° die der Regler nach 
deiner Aussage über Raumtemperatur ist, macht nach Adam Riese 95° am 
Regler, im Zweifelsfalle noch mehr, gut kühlen ist da wichtig!

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Die Appnote von den 78xx sagt dass hinter dem Regler nur ein sehr
>kleiner C sitzen soll.
Wortlaut aus dem Datenblatt: Optional for improved transient response.

Ich habe im Datenblatt keinerlei Hinweise gefunden, dass die kapazitive 
Last einer Beschränkung unterworfen wäre. Das entspricht auch meiner 
bisherigen Erfahrung - außer dass dies die Reaktion auf Lastsprünge 
beeinflusst. Lediglich am Eingang ist ein C nahe an den Pins dringend 
erforderlich, um Schwingneigung zu unterbinden. Über die Größe des Cs 
sind sich die Datenblätter verschiedener Firmen nicht unbedingt einig. 
Aber 100nF ... 470nF keramisch, am Besten die SMD-Ausgabe, sollten zur 
Entkopplung ausreichen.

Autor: Schorschone (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Nochmal: Wie schnell ist für dich "schwingt"?

Immernoch keine Antwort?

Isses nun eine HF-Schwingung, die alle Radios in mehreren km Umkreis 
stört, oder isses ein gemächliches flackern der Power-LED, weil die 
thermische Absicherung gemächlich vor sich hinschwingt?

Autor: Michael Lenz (hochbett)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Schorsch,

ich sehe mehrere mögliche Ursachen:
1) die schlechte Wahl der Eingangskondensatoren
2) die sonderbare "zweite" Verpolschutzdiode, die die Massen von KFZ und 
der 5V-Anwendung trennt
3) der 100nF-Kondensator ist nicht nahe genug am Ausgang (5mm Entfernung 
wären ok)
4) die fehlende Diode über dem 7805 (verhindert, daß die 
Ausgangsspannung
   deutlich kleiner als die Eingangsspannung wird)
5) thermische Überlast


Im Detail:
> ich habe eine kleine µC Schaltung fürs Auto gebaut.
> Leider hab ich mit dem 7805 Probleme bei höheren Temperaturen.
Hast Du an die
- Verpolschutzdiode (z. B. 1N4004)
- Diode über dem Spannungsregler (vom Ausgang zum Eingang geschaltet, z.
  B. 1N4004)
- Eingangsdrossel + ohmscher Widerstand (4.7 Ohm) in Reihe als
  Strombegrenzung und die
- Überspannungsschutzdiode
am Eingang des 7805 gedacht?

http://www.reichelt.de/?;ACTION=3;LA=444;GROUP=A46...

Die benötigst Du, weil die KFZ-Spannung sehr hohe Spitzen bis zu 100V 
haben kann.


> Beschalten ist der 7805 mit
> - 100nF, 10nF, 1µC Keramik unt 100µF elko
Laß die 100nF und die 100uF drin und nimm alle anderen Kondensatoren 
raus. Die Werte sind zu nah beieinander, so daß es Frequenzen gibt, bei 
denen die Kondensatoren Parallelschwingkreise (Größenordnung: 
zweistelliger MHz-Bereich) bilden.
Ein Parallelschwingkreis ist hochohmig und kann Störungen nicht 
ausfiltern.
Den 100nF-Kondensator solltest Du in unmittelbare Nähe des uC anlöten, 
maximal etwa 5mm weg.

> Am Ausgang ist ein 100nF und ein 100µF elko verbaut.
Manche Leute meinen, am Ausgang dürfe kein großer Elko beschaltet sein. 
Das stimmt aber nicht, wie im Detail auf 
http://www.elektronik-kompendium.de/ hergeleitet wurde. Die Schaltung 
neigt angeblich umso weniger zum Schwingen, je größer der Ausgangselko 
ist.
100µF und 100n an Ein- und Ausgang ist meine Standardbeschaltung.

> Davor ist noch ein Filter mit ner 47µH und 470µF Elko und 2
> Verpollungsdioden.
Die Verpolschutzdiode ist also da (siehe meine Frage oben). Doch wieso 
zwei?

Was für ein Filter? LC-Tiefpaß?
Das wäre prinzipiell ok, und 47uH ist ein gängiger Wert.
Doch weshalb nimmst Du dann zusätzlich 100uF am Eingang, wenn Du schon 
470uF hast?
f_res = 1/(2*pi*47uH*570uF) = 6 MHz.
Das dürfte weit jenseits der Resonanzfrequenz der Elkos sein. Also ok.

> Zusätzlich sind noch an den paar ICs weitere 100nF nah an den
> Versorgungspins angebracht.
Das ist in Ordnung.

> Wenns Draussen schön sonnig uns warm ist, ist es im Auto natürlich
> entsprechend wärmer. Grad an solchen Tagen neigt der 7805 zum schwingen.
Der IC geht möglicherweise in die thermische Begrenzung.
Da hilft nur eins: Eiswürfel drauflegen ;-)
Oder einen kleinen Lüfter einbauen.


Gruß,
  Michael

Autor: Schorsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

danke euch für die hilfreichen Tips und Unterstützung.

Wie schon erwähnt konnte ich das Schwingen nur am flackern der PowerLED 
am 5V Ausgang sehen. Messungen hab ich da noch keine gemacht.

Inzwischen konnte ich auch Temperatur ausschliessen. Denn heute Morgen 
hatte ich das gleiche Problem. Das Auto steht in der Tiefgarage bei 16°.

Als Filter hab ich natürlich LC drinn. Allerdings recht weit (ca. 10cm) 
von der eigentlichen Schaltung weg. Hat leider nicht mehr ins Gehäuse 
gepasst.

Ich werde die Schaltung heute noch mal ausbauen (zum Glück hab ich ja 
alles mit Steckern versehen) und prüfe die Position der Kondensatoren. 
Ich hab diese mein ich, grad am Eingang, nicht nah genug am 
Spannungsregler.

Dann teste ich noch mal ein bis zwei Wochen und werde berichten.

Danke und Gruss,
Georg.

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm, im Auto verbaut...vielleicht ist es passend, sich mal die Versorgung 
im eingebauten Zustand anzuschaun. Das Bordnetzt von PKWs ist nicht 
grade für seine Sauberkeit berühmt.

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Wie schon erwähnt konnte ich das Schwingen nur am flackern der
> PowerLED am 5V Ausgang sehen. Messungen hab ich da noch keine gemacht.

d.H. eher Schwingung im Herz/miliherz-Bereich.
Dann würde ich wirklich auf ein thermisches Problem tippen.
also, Finger ran ans IC-Gehäuse, wenn Autsch dann Kühlkörper.
Wärmeleitpaste nicht vergessen, aber auch nicht übertreiben, darf nur 
ein dünner Film zwischen IC und Kühlkörper sein.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn der 7805 ins Auto soll, hätte ich garantiert 3 Schutzdioden dran: 
Eine vor, eine hinter und eine gegen Rückfluss drüber (wie im 
Datenblatt).

Autor: Schorsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

einen u-förmigen Kühlkörper hab ich ja schon drauf.
Da der Fehler aber auch bei kühleren Temperaturen auftritt (16°).
Muss da noch was anderes sein. Überspannungsschutzdioden hab ich grad 
keine da. Müsste ich extra bestellen.

Ich schau mir das ganze mal im Fehlerfall mit nem Oszi am WE mal an.
Der Fehler scheint jetzt verhäuft auf zu tretten. Nicht mehr ein mal die 
Woche sondern 2 bis 3 mal am Tag.

Gruss,
Georg.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann überleg schon mal welche Induktivitäten Du zu dieser Zeit gerade 
abgeschaltet hast.  Zündung ? Fensterheber ? ...

Autor: JoLe64 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Reagiert der 7805 nicht auch auf Überstrom oder Unterspannung am Ausgang 
mit Abschaltung, auch wenn er noch kalt ist? Das könnte evtl. auch eine 
Schwingung produzieren.

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
7805 hat doch nix eingebaut bzgl. Überstrom oder Unterspannung, das ist 
ein "normaler" Festspannungsregler, der als kleinen Vorteil einen 
Temperaturschutz hat, wird er zu heiß schaltet er ab. Mehr war da doch 
nicht.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael schrieb:
> 7805 hat doch nix eingebaut bzgl. Überstrom

Doch, hat er. Er hat sogar eine SOA Begrenzung für den internen 
Transistor bzw. eine Foldback Strombegrenzung.
Er ist also kurzschlussfest.

Autor: Peter S. (psavr)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lass bitte das LC-Filter am Eingang weg, gut möglich das Regler dies 
nicht mag...

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter S. schrieb:
> Lass bitte das LC-Filter am Eingang weg, gut möglich das Regler dies
> nicht mag...

Es schwingt ja so langsam, dass man die Schwingungen mit unbewaffnetem 
Auge an der Power-LED erkennen kann.
Ich denke nicht, dass die Induktivität im LC-Filter vorne groß genug 
ist, um eine so langsame Schwingung zu erzeugen.

Genausowenig können fehlende/falsche/zu große Kondensatoren am Regler 
die Ursache sein.

Das ist entweder thermisch bedingt (Wärmekapazität des Kühlkörpers ist 
groß genug) oder kommt von der Schaltung hintendran, die z.B. periodisch 
ihre Versorgung kurzschliesst.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.