mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik PonyProg2000 Si-Prog


Autor: Alex G. (alex94) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich hab mir diesen Si-Prog programmer gebaut.
http://s-huehn.de/elektronik/avr-prog/avr-seriell.gif

Ich programmiere mit PonyProg2000.
In dem Setup menü wird er bei der Probe erkannt (Test Ok)
Allerdings kann ich keine µC's  damit programmieren. Ich habe de Tiny 12 
und den Atmega 32 ausprobiert. Es kommt immer der Fehler: Device missing 
or unknow Device. Ich habe aber PonyProg2000 richtig eingestellt.
Hat jemand eine Idee was falsch sein könnte?
Danke im voraus

mfg alex

Autor: Alex G. (alex94) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat keiner eine Idee woran es liegen kann?

mfg alex

Autor: Alex G. (alex94) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann es daran liegen das ich einen BC547A verwende statt einen BC547 ?

mfg alex

Autor: Johann L. (gjlayde) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alex Peterson schrieb:
> Kann es daran liegen das ich einen BC547A verwende statt einen BC547 ?

Nö, das sollte nix machen.

Versuch mal aufm PC die Flußsteuerung für die COM-Schnittstelle zu 
deaktivieren falls das nicht schon der Fall ist.

Stimmen die Pinbelegungen und Polaritäten mit dem SI-Prog von lancos 
überein? Falls nicht, muss man was an der Konfiguration von PonyProg 
drehen, irgendwo kann man das da einstellen... so lange her.
   http://www.lancos.com/siprogsch.html#baseboard

Und natürlich ohne USB<->RC232-Adapter oder so, da sollte schon ne 
richtige RS232-Schnittstelle da sein.

VCC sollte von extern kommen, wenn man die aus RS232-Pins gewinnt via 
LM2936 oder so schwächelt die trozdem.

Johann

Autor: D. S. (jasmin)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Check mal Deinen Nachbau gewissenhaft.

liegen die 5,1 Volt bei der Programmierung an ?

Autor: Alex G. (alex94) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke,
Flußsteuerung und externe Spannungsversorgung waren die Stichwörter die 
mir geholfen haben.

mfg alex

Autor: Seikuassi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe das gleiche Problem.

Wie kann ich die Flusssteuerung deaktivieren? Ich habe übrigens Windows 
XP 32 Bit.

Danke im Voraus!

Autor: Thomas Der Bastler (thomasderbastler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Systemsteuerung - System - Hardware - Gerätemanager - Anschlüsse - 
Kommunikationsanschluss - Eingeschaften - Anschlusseinstellungen

Autor: bingo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ECHTE serielle Schnittstelle oder USB-Adapter ???

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.