mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Programmiergerät


Autor: Mr. X. (headcrash)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin,
würde mich sehr freuen wenn ihr euch mal kurz meine Schaltung im Anhang 
angucken würdet. Warscheinlich ist da ein Fehler drin.

Diese Schaltung zeigt mein ATMEGA8 Programmiergerät, welches aber nciht 
funktioniert.

Ponyprog-Probe zeigt zwar OK an, aber dieser testet ja nur auf die 
Brücken am Parallelport. Wenn ich bei einem Leseversuch bei der 
Fehlermeldung (missing device-24) auf "ignore" klicke, liest er ihn auch 
aus. (alles 0xFF's) Löschen funktioniert überhaupt nicht (failed) auch 
nach klciken auf "ignore". Schreiben führt er zwar auf den ersten Blick 
durch, tut er allerdings nciht und gibt beim Validieren einen 
Fehlermedung(failed).
Hab an der Schaltung alle Punkte durchgemessen, und auch beim 
Programmieren überprüft ob bsp. der Reset bin logisch 0 bleibt.

Da ich schon öfters gelesen habe das diese Minimal-Progger Müll sind 
werde ich mir wohl doch einen ordentlichen zulegen müssen!
Wäre aber interessant zu wissen was an dieser Schaltung schief läuft!

Könnte mir vorstellen das die Siganle wie in anderen Progger-Schaltungen 
getrieben werden müssen; theorethisch müste es doch aber ohne auch 
funktionieren.

Dürfen die Massepunkte vom Netzteil und vom Mainboard sich kennen ?!
Ich meine geht ja eigneltich nicht anders...

Ich hoffe ich habe mein Problem verständlich beschrieben ;)
Danke schonmal im Vorraus



EDIT: SORRY HABE IN DER SKIZZE 330 OHM EINGEZEICHNET HABE ABER 480 OHM 
VERBAUT. Kann es sein das hier zuviel Spannung abfällt?

Autor: Mr. X. (headcrash)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
http://img192.imageshack.us/i/parallelprogrammer1.jpg/


Edit: Würd ich ja gerne, aber wennich das Bild als Anhang einfüge und 
auf absenden gehe, wird mein Beitrag zwar gepostet aber das Bild ist 
nciht im Anhang.

Autor: Thomas R. (tinman) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mr. X. schrieb:
> http://img192.imageshack.us/i/parallelprogrammer1.jpg/

poste doch hier , keiner mag die spam sites

Autor: Alex G. (alex94) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
müsste eig. funktionieren.
Bei mir ist es so ähnlich auf einem meiner pc's funktioniert der 
Programmer auf dem anderen nicht. Deswegen hab ich mir jetzt einen 
Si-Prog Programmer gebaut.

http://s-huehn.de/elektronik/avr-prog/avr-seriell.gif


mfg alex

Autor: Uwe ... (uwegw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem liegt meist nicht beim Programmer, sondern bei Parallelport 
und Betriebssystem. Unter Win9x und mit einem entsprechend alten PC 
funktioniert es meistens. Unter XP und Vista sehr selten, und meist auch 
nur mit entsprechenden Zusatztreibern. Grund: Für diesen Programmer muss 
die Software direkt auf die einzelnen Pins des Parallelports zugreifen 
können, und das ist ab XP nicht mehr so vorgesehen, da kann ein Software 
nicht mehr einfach so direkt auf die Hardware zugreifen und dabei 
Windows umgehen. Ht den Vorteil, dass ein fehlerhaftes Programm nicht so 
schnell das gesamte System abschießt, aber den Nachteil, dass solche 
einfachen Schaltungen nicht mehr funktionieren.

Autor: Alex G. (alex94) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein solcher Treiber ist z.B. giveio.

@Uwe bei mir sind es 2 pc's beide mit xp drauf. Auf dem pc's auf dem 
funktioniert ist giveio nicht installiert.

mfg alex

Autor: Christian U. (z0m3ie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie schon erwähnt funktionieren auf neuen PC´s die Paralellport und 
Seriellen Bitbanging Programmer sehr unzuverlässig bis gar nicht.
Es gibt für ein paar Euro schon USB programmer, da lohnt sich das kaum 
noch.

Schau dir mal z.b.
http://www.ullihome.de/index.php/Hauptseite#USB_AVR-Lab
an

Autor: Rik Langobar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich benutze den AVR910 von Klaus Leidinger [1] plus FT232R-USB-Chip. 
Damit bin ich sehr zufrieden. Als HV-Programmer hat sich bei mir der 
"yaap" [2] bewaehrt.

[1]http://www.klaus-leidinger.de/mp/Mikrocontroller/A...
[2]http://www.myplace.nu/avr/yaap/

P.S.: Laufen beiden unter Linux mit avrdude

Autor: Christian U. (z0m3ie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
AVR910 hat das riesen Problem das jeder neue Controller in der Firmware 
einprogrammiert werden muss ist also nicht unbedingt zukunftssicher.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.