mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik CD4511 BCD -> 7-Segment hängt irgendwie


Autor: Markus G. (mikromar)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich steuer eine 7-Segment Anzeige mit einem "hcf 4511 be" an.

Das funktioniert auch sporatisch super. Manchmal hat er einen "hänger" 
er gibt manchmal bis zur "7" alles gut aus, dann stockt er bzw. setzt 1- 
2 sek. aus und zählt dementsprechend da weiter, wo der Zähler grade ist.

Die Spannung passen alle, der Zähler davor zählt richtig und zwar Pro 
Sekunde um 1 hoch. Die Signale kommen also richtig. Irgendwo muss der 
Fehler im CD4511 liegen, kennt jemand das Problem?
Oder hat jemand definitv eine Idee woran das liegen könnte?

Mit freundlichem Gruss!

Autor: Turbotoni (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du Abblockkondensator(en) dran ?

Mfg Turbotoni

Autor: Yagan Ζ. Dongobar (yagan)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Markus,

liegen die Anschlüsse -LT(3), -BI(4), LE(5) an definierten 
Spannungspegeln?
Oder ist einer der Eingänge vielleicht offen?

Ciao, Yagan

Autor: Markus G. (mikromar)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe einen 47nF Kondensator An Vcc gegen Masse hängen. Ich hoffe das 
ist der  Kondensator den du meinst! Aber ob ich den reinhänge oder 
weglasse, das macht komischerweise keinen Unterschied!

Die Spannung an Vcc ist übrigens konstant...

Edit: LT und BL liegen beide an Vcc (5.002V) und LE häng an Masse.

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Edit: LT und BL liegen beide an Vcc (5.002V) und LE häng an Masse.

Wenn Vcc 5.000000002V ist, dann sollte es funktionieren.
SCNR ;)

Autor: Markus G. (mikromar)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
??

Autor: Markus G. (mikromar)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
holger schrieb:
>>Edit: LT und BL liegen beide an Vcc (5.002V) und LE häng an Masse.
>
> Wenn Vcc 5.000000002V ist, dann sollte es funktionieren.
> SCNR ;)

??

Autor: Andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
War ein Witz, er meint dass es sooo genau wie du die Spannung 
gemessen/aufgeschrieben hast, gar nicht sein muss. Mit anderen Worten, 
daran liegt es nicht.

Autor: H.Joachim Seifert (crazyhorse)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm, Anzeige-Dekoder sind so ungefähr das unkritischste, was man sich 
vorstellen kann. Arbeiten rein statisch, selbst, wenn sie sich 
verhaspeln würden, wäre das im nächsten Augenblick wieder korrekt und du 
hättest nichts gesehen davon.
3 Möglichkeiten gibts:
-dasTeil hat ne Macke
-deine Eingangsdaten sind doch nicht korrekt, wie du vermutest
-das einzig kritische ist der LE-Eingang. Wirklich auf Masse?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.