mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Videosignal weiterschlaufen mit OP


Autor: Patrick (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen!

Auf einer Schaltung habe ich einen Video-Eingang für ein FBAS-Signal. 
Dieses Signal brauche ich für einen Video-decoder (ADV7183). Jetzt soll 
aber an diese Schaltung gleichzeitig auch noch ein Monitor angeschlossen 
werden können, um das aktuelle Videosignal anzuzeigen.

Dafür habe ich die Schaltung im Anhang erstellt. Als OP habe ich dann 
aber den AD8061 verwendet.

Da es sich hierbei um einen Single-Supply handelt (auf dem Board habe 
ich nur single supply zur Verfügung), schneidet der mir natürlich alles 
unterhalb von gnd ab. D.h. der Sync-Impuls im Signal wird auch entfernt. 
Am Monitor bekomme ich dadurch nur ein flimmerndes Bild zustande.

Gibt es eine andere Möglichkeit, das Videosignal an den Monitor 
weiterzureichen? Oder wie bringe ich diesen Sync-Impuls irgendwie wieder 
auf mein Signal?

Danke für Eure Hilfe

MFG
Patrick

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du darfst den OP Eingang nicht direkt mit einenm Widerstand auf Masse 
legen.
Du must deinem OP eine Vorspannung mit einem Spannungsteiler geben und 
dein Signal ueber ein C einkoppeln.

Autor: Patrick (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Du meinst so wie in der angehängten Schaltung?

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Spannungsteilerwiderstände etwas hochohmiger, denn sonst ist dein 
Videoeingang mit    75 Ohm || 100 Ohm || 1 kOhm  =  41 Ohm
falsch abgeschlossen und wird zudem zu stark belastet.

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja so meine ich das. Aber dein C92 mit 0.1uF ist etwas klein. Gibt eine 
untere Grenzfrequenz von ca. 16KHz. Damit deine Bildimpulse durchkommen 
must du die untere Grenzfrequenz kleiner 50Hz ansetzen.

Autor: Patrick (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann nehme ich 100k und 10k, dann ist der Abschlusswiderstand 74,4. Oder 
sollte ich besser 1M und 100k (ergibt 74,94 Ohm) nehmen?

Danke für Deine Hilfe.

Eine weitere Frage dazu:
Normalerweise ist ja der Sync-Impuls negativ und Schwarz auf GND. Am 
Ausgang wird dann aber Sync auf GND und Schwarz dementsprechend erhöht. 
Kann das Bild dann am Monitor noch korrekt dargestellt werden?

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Dann nehme ich 100k und 10k, dann ist der Abschlusswiderstand 74,4. Oder
>sollte ich besser 1M und 100k (ergibt 74,94 Ohm) nehmen?

Erstmal ob 74.4 oder 74.94 Ohm  so genau sche... kein Hund.

Du darfst mit den Widerstaenden aber auch nicht zu weit nach oben gehen.
Stichwort: Input Bias Strom des OPs. Der Eingangsstrom des OPs darf den 
Spannungsteiler auch nich allzu hoch belasten.

>Normalerweise ist ja der Sync-Impuls negativ und Schwarz auf GND. Am
>Ausgang wird dann aber Sync auf GND und Schwarz dementsprechend erhöht.
>Kann das Bild dann am Monitor noch korrekt dargestellt werden?

Deine ueberlegungen sind schon richtig. Aber der Monitor hat eine 
Klemmschaltung an seinem Eingang die die richtigen Pegelverhaeltnisse 
wieder rekonstruktuiert.

Autor: Patrick (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK, danke für Deine Hilfe.

Wenn ich jetzt 100k und 10k nehme, dann erreiche ich mit einem 
Kondensator von 0.47uF eine untere Grenzfrequenz von ca. 40 Hz, oder?

Wenn die Werte OK sind, dann werde ich das mal auf meiner Schaltung 
aufbauen und ausprobieren.

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Werte sind schon Ok. Vielleicht den C noch auf 1uF vergroessern. 
Dann bist du auch unter 20Hz.

Autor: Patrick (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die schnelle Hilfe.

Melde mich morgen wieder mit dem Ergebnis.

MFG
Patrick

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der OP verstärkt mit Faktor 2. Soll er das?
Wenn du am +Eingang einen Offset einspeist
wird auch dieser mit der obigen Schaltung verstärkt.
Besser noch ein C in Reihe zu R9 packen.

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Wenn ich jetzt 100k und 10k nehme, dann erreiche ich mit einem
>Kondensator von 0.47uF eine untere Grenzfrequenz von ca. 40 Hz, oder?

das gilt aber wohl nur, wenn Du keinen 75Ohm hinterm C hast.
Vielleicht so: zuerst 75Ohm parallel zu Masse, dann über den 0.47µ auf 
deinen Spannungsteiler/OPV-Eingang. Damit sollte der Viedeoeingang 75Ohm 
sehen (fast), und der C sieht nur die 100k||10k
Wäre der 75Ohm hinter dem C, dann müsste der C schon recht groß werden 
(paar 100µ oder so)

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Der OP verstärkt mit Faktor 2. Soll er das?
Ja, denn mit dem Serienausgangswiderstand von 75 Ohm und dem 
Eingangswiderstand vom Monitor (auch 75 Ohm) bleibt am Monitor selber 
dann wieder nur die Hälfte dieser doppelten Spannung.
                     ____ 75 
   OP-Ausgang  -----|____|------------------------o----- Monitor
                                                  |
                                                  -
                                                 | |
                                                 | | 75
                                                 | |
                                                  -
                                                  |
   GND         -----------------------------------o-----  GND

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Der OP verstärkt mit Faktor 2. Soll er das?

Er muss sogar um den Faktor 2 verstaerken.
Der Ausgangswidersatnd R5 mit 75 Ohm und der Eingang des Monitors mit 75 
Ohm teilen die Spannung um den Faktor 2.Um das auszugleichen muss er um 
den Faktor 2 verstaerken.

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

so machen, wie es auch die analoge Studiotechnik schon früher gemacht 
hat: der Wandler bekommt einen Durchschleifausgang, also einfach eine 2. 
Buchse parallel an den Eingang.
Wenn nichts da dran hängt den 75 Ohm Abschluß dazuschalten oder einen 
Abschlußstecker auf die Ausgangsbuchse. Am Ende der Kette wird mit 75 
Ohm angeschlossen.

Bedingung ist nur, daß der Eingangswiderstand nicht zu niedrig und die 
Eingangskapazität nicht zu hoch ist.

Gruß aus Berlin
Michael

Autor: Patrick (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Michael U.
>Wenn nichts da dran hängt den 75 Ohm Abschluß dazuschalten oder einen
>Abschlußstecker auf die Ausgangsbuchse.

Wenn es hierbei um eine Bastellösung für mich zu Hause handeln würde, 
dann würde ich es wahrscheinlich so machen. Da der Kunde so einen 
zusätzlichen Abschlussstecker überhaupt nicht gebrauchen kann, brauche 
ich eine sicherere Lösung.

@Jens G.
>das gilt aber wohl nur, wenn Du keinen 75Ohm hinterm C hast.
>Vielleicht so: zuerst 75Ohm parallel zu Masse, dann über den 0.47µ auf
>deinen Spannungsteiler/OPV-Eingang. Damit sollte der Viedeoeingang 75Ohm
>sehen (fast), und der C sieht nur die 100k||10k

Genau so habe ich es auch jetzt in meiner Schaltung drin. Der 
Videoeingang sieht somit 75||100k||10k = 74.4 Ohm, und der C sieht 
100k||10k = 9,1kOhm.

Autor: Patrick (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So. Ich habs jetzt aufgebaut und getestet. Mit den Werten oben habe ich 
im Bild einen schwarzen Balken. Die Synchronisation passt also nicht 
ganz. Wenn ich dann Gegenstände durchs Bild bewege, dann springt auch 
der Balken im Bild.

Ich hab dann die Widerstände so lange verändert, bis ich auf folgende 
Werte gekommen bin:
68k (statt 100k), 15k (statt 10k). Damit erhalte ich einen 
Abschlusswiderstand von ca. 74.5 Ohm und eine Grenzfrequenz von knapp 13 
Hz. Mit diesen Werten wird das Bild korrekt am Monitor angezeigt.

Kann es sein, dass 0.3V Anhebung einfach zu wenig waren? Der Pegel liegt 
jetzt bei etwa 0.65V.

Autor: EGS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
0,65 V ist schon besser. Das Videosignal hat normalerweise einen Pegel 
von ~0,7 V.

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Kann es sein, dass 0.3V Anhebung einfach zu wenig waren? Der Pegel liegt
>jetzt bei etwa 0.65V.

So isses. Vielleicht noch ein bisschen Reserve dazu geben falls mal eine 
Quelle angeschlossen wird die ein bisschen hoeheren Pegel hat.

Autor: Patrick (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alles klar. Danke Eure Hilfe.

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du must bedenken, daß der Mittelwert des Videosignals irgendwo mitten im 
Bild-Signal ist (nicht unbedingt dort, wo die Synch-Signale sich vom 
Bildsignal abheben). Das videosignal ist nämlich vollkommen 
unsymmetrisch (nicht wie ein Audiosignal), und damit ist der Mittelwert 
auch noch variabel je nach Bildinhalt. Hinter dem Eingangskondensator 
sitz der Mittelwert auf dem Potential, den der Eingangsspannungsteiler 
bildet (ein C lädt sich ja auf den Mittelwert auf). Der Synchimpuls ist 
damit weit negativer als dieser Mittelwert, womit der 
Gleichspannungspegel ein ganzes Stückchen höher als sein muß also der 
Synch-Impuls alleine. Hättest du ein komplett weises Bild, wäre der 
Mittelwert fast auf Weispegel - das mußt Du als Reserve in Form von 
Gleichspannung bereithalten. Der C bewirkt je nach aktuellen Mittelwert 
einen entsprechenden Versatz der Videospannung (kann man sicherlich 
schön beobachten mit einem Oszi im AC-Betrieb bzw. hinter C, wie der 
allgemeine Videopegel mal etwas weiter oben, mal weiter unten 
dargestellt wird)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.