mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit Zeroplus LAP-C


Autor: Bernhard R. (barnyhh)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mir den Zeroplus LAP-C 16032 zugelegt. Mit dem Gerät bin ich in 
folgendes Problem gelaufen:

Auf meinem Laptop ("Denkbrett" IBM T23 von 2001 mit USB 
1.1-Schnittstelle, 256 M Hauptspeicher und Windows 2000 SP4) arbeitet 
dieser LA nicht so, wie er sollte:

- Die Einstellungen werden auf den LA übertragen.
- Start RUN funktioniert per Taste / per PC perfekt.
- Triggerbedingungen wirken, wie sie sollen.
- STOP per PC funktioniert ebenfalls.
- Daten werden vom LA zum PC zurückübertragen.
- Anschließend erscheint allerdings nicht das erwartete Signal, 
sondern eine Null-Linie über den Meßzeitraum.

Computer ausgetauscht gegen einen Tower mit Windows XP, 2 GB 
Hauptspeicher, USB 2.0 Schnittstelle:

- Die Einstellungen werden auf den LA übertragen.
- Start RUN funktioniert per Taste / per PC perfekt.
- Triggerbedingungen wirken, wie sie sollen.
- STOP per PC funktioniert ebenfalls.
- Daten werden vom LA zum PC zurückübertragen.

- Anschließend erscheint genau das erwartete Signal über den 
Meßzeitraum.

Mein erster Verdacht:
Der Laptop liefert nicht genügend "Saft" an die USB-Schnittstelle.

Also am Laptop einen HUB mit Stromversorgung die HUB-getriebenen Geräte 
angeschlossen (die Stromversorgung kann 5V / 4A liefern).

Ergebnis:
Der Fehler erscheint so wie oben bereits beschrieben.

Als nächste Aktion werde ich den HUB am Tower zwischenschalten und 
schauen, was dabei rauskommt. Ich erwarte eigentlich, daß alles normal 
arbeitet.

Wenn ich die FAQ's im Handbuch dieses LA ansehe, dann denke ich 
allerdings,
daß die USB-Anbindung doch recht "wackelig" aussieht - ist nur so ein 
Bauchgefühl.

Meine Fragen zum Abschluß:

- Welche Probleme sind mit diesem LA bekannt?
- Wie sehen die Erfahrungen mit diesem LA und USB 1.1 aus?
- Was kann ich noch probieren?

Ich denke, hier brauche ich jetzt nicht nur Brain"Storming" sondern 
Brain"Orkaning"!

Vielen Dank für jede Hilfe!

Bernhard

Autor: Bernhard R. (barnyhh)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ergänzung:

Der oben erwähnte HUB ist ein USB 2.0 High Speed Hub (USB 1.1 
kompatibel). Betrieb des LA am Tower über den HUB läuft problemlos.

Backup / Restore des Laptop per USB-Platte geben ebenfalls keine 
Probleme. Grundsätzlich sollte die Laptop-Hardware also im Bereich USB 
sauber arbeiten.

Ich werde mal sehen, daß ich einen USB 1.1 HUB auftreibe; auf diese 
Weise kann ich zunächst einmal testen, ob der LA die 12 Mbit/sec nicht 
mag oder andere Probleme hat.

Bernhard

Autor: Bernhard R. (barnyhh)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ergebnis:

Am Tower tut der LAP-C auch per USB 1.1 Hub.
Am Laptop arbeitet er mit USB 1.1 Hub ebenfalls nicht.

Der Einsatz einer No-Name USB2 PCMCIA Karte am Laptop brachte dann den 
Erfolg:
Der LAP-C Logikanalyzer arbeitet am USB2-Anschluß des Laptop.

Ich brauche also keine großen Geräte durch meine "Hütte" schleifen.

Bernhard

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.