mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Codegröße WinAVR


Autor: Klaus R. (klaus2)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

mit WinAVR + AVRStudio wurd mir vor der Neuinstallation immer ein %-Wert 
angezeigt, wieviel RAM / ROM belegt sind. Bzw es gab ne Warnung, wenn 
ich 8kb für nen Tiny45 compiliert habe...aus irgend einem Grund kommt 
das nicht mehr? Wie steuert man die Ausgabe?

Danke, Klaus.

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Klaus R. schrieb:
> mit WinAVR + AVRStudio wurd mir vor der Neuinstallation immer ein %-Wert
> angezeigt, wieviel RAM / ROM belegt sind. Bzw es gab ne Warnung, wenn
> ich 8kb für nen Tiny45 compiliert habe...aus irgend einem Grund kommt
> das nicht mehr?

Man muß beim WINAVR installieren unbedingt anklicken, daß er die 
Umgebungsvariable setzen soll!
Man kann danach den Pfadeintrag sofort wieder löschen, er legt ihn noch 
irgendwo geheim ab, wo ihn dann das AVRStudio findet.

Dieser geheime Eintrag bleibt erhalten bis in alle Ewigkeit auch nach 
einer Deinstallation.
Es kann also Probleme geben, wenn Du den WINAVR später in einem anderen 
Pfad installierst.

Da ich aber WINAVR in einem anderen Verzeichnis anlegen wollte, hab ich 
ein Backup eingespielt von vor der Installation des WINAVR/AVRStudio.


Peter

Autor: Klaus R. (klaus2)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...ehhhhm, und das hilft mir jetzt genau wie weiter? :)

Was hat das mit der "Codesize" Warnung zu tun? Wie kann ich die genaue 
Codegrösse sonst per Hand bestimmen? Ich wusste es mal, aber...

Danke!

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Klaus R. schrieb:
> ...ehhhhm, und das hilft mir jetzt genau wie weiter? :)

Ganz einfach, er findet den Pfad zu den Tools zur Speicheranzeige nicht.
Der manuelle Eintrag des Pfades zum Compiler reicht nicht.


Peter

Autor: Klaus R. (klaus2)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK. Verstanden. Wusste nicht, dass das ein eigenes Tool ist.

Man kann es aber auch "per Hand" aus der .data oder sonstwo ableiten, 
nur habe ich das aufgrund der "bequemen %-Anzeige" vergessen...

Kann ich den Pfad denn noch nachträglich ändern/anpassen? Habe auch 
NICHT unter C:\Winavr installiert...

Danke, Klaus.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.