mikrocontroller.net

Forum: HF, Funk und Felder Torantrieb Funkempfänger ohne Funktion


Autor: Dirk B. (derdirk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe folgendes Problem, unser alter Garagentorantrieb reagiert nicht 
mehr auf die Funkvernbedienung :(
Der Garagentorantrieb an sich funktioniert über den Schlüsselschalter 
einwandfrei, Batterien in der Funkvernbedienung sind gewechselt und auch 
eine 2. Funkvernbedienung zeigt keine Funktion.

Deshalb denke ich das der HF Empfänger im Torantrieb defekt ist.
Ich habe Ihn einmal ausgebaut/abgezogen ( Stecksystem )... und wollte 
jetzt mal Euren Rat wissen wie ich den Funkempfänger auf Funktion testen 
kann... nicht das der Fehler irgendwo auf der Steuerplatine des 
Torantriebs steckt und gar nicht im HF-Empfänger Modul.

Hier sind mal 2. Bilder zum HF-Empfänger Modul:

Seitenansicht mit Schaubild:
http://s2.imgimg.de/uploads/hfempfngerseitec6500d05jpg.jpg

Ansicht von unten auf den Stecksockel:
http://s2.imgimg.de/uploads/hfempfngeruntenc1c1c39ejpg.jpg

Ich wollte jetzt eigentlich so vorgehen:

Ich schließe mein 12V Netzteil an... Plus auf Pin 2, und Masse auf Pin 
4.

Nur verstehe ich jetzt nicht was mir die Transistor-Schaltung die rechts 
abgebildet ist sagen soll ?!?!?!
oder was ein "Quasi offner Kollektor NPN Transistor" ist.

Deshalb meine Frage:
Was müßte ich jetzt an PIN 1 oder 3 passieren wenn ich auf die 
Funkvernbedienung drücke ???
Stellt die Schaltung vielleicht einen "einfachen Schalter" dar ???

das wenn der HF-Empfänger ein Signal von der Funkvernbedienung 
bekommt... eine Verbindung zwischen PIN 1 & PIN 3 hergestellt wird ???

Könnte ich das mit einem Durchgangstester Prüfen ???

oder liege ich mit meinem Ansatz ganz falsch ???


würde mich über Antworten freuen ;) DANKE !!!


ciao Dirk

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich würde folgendermaßen vorgehen:
- 12V ... 18V an Pin 2 gegen GND an Pin 4 anklemmen
- Einen Widerstand, z.B. 1k, zwischen Pin 1 und Pin 2 anschließen, ev. 
gleich in Reihe mit einer LED (Polung beachten).
- an Pin 1 gegen GND Pin 4 messen (bzw. die LED beobachten) und den 
Sender betätigen.

Du erwähnst immer den Pin 3. Ich sehe den ohne Funktion. So wie die 
bisher nicht erwähnten Pins auch.

>Nur verstehe ich jetzt nicht was mir die Transistor-Schaltung die rechts
>abgebildet ist sagen soll ?!?!?!
>oder was ein "Quasi offner Kollektor NPN Transistor" ist.

Es ist letztendlich ein unbeschalteter Kollektorausgang eines 
Transistors - hier eben als Komplementärdarlington ausgeführt. Das 
braucht dich aber (für den Test) nicht besonders interessiern.
Einen solchen Open-Kollektorausgang kann man dazu verwenden, dass man 
eine Last (ein Relais, eine LED mit R oder was auch immer gegen Plus 
schalten kann. Dabei kann dieses Plus 12V sein, möglicherweise auch 
deutlich mehr (leider ist die Grenze nicht angegeben, aber bis 30V hätte 
ich keine Bedenken) oder eben auch nur 5V - je nach Notwendigkeit dieser 
Last. Solange der maximale Strom von 50mA nicht überschritten wird.

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag:
Zum Testen des Torantriebs kannst du auch bei abgezogenem HF-Modul die 
Pins 1 und 4 auf der Steuerplatine mit einem (isolierten) Draht brücken. 
Dann muss der Torantrieb anlaufen, so wie von der Fernbedienung gewohnt.
Damit hast du schon besser eingegrenzt.

Bitte beachte dabei, dass freiliegende Leitungen Netzspannung führen 
können!

Autor: Dirk B. (derdirk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke schonmal für Deine Antwort ;)

ich bin für diesen Unterfangen denkbar schlecht ausgestattet... außer 
einem 12 V Netzteil, Multimeter und ein paar Kroko-Klemmen habe ich 
nichts zur Verfügung !!!

das PIN 3 eine Funktion hat habe ich daraus geschlossen das auf der 
Unterseite ( Stecksockel )... an den PIN's 1-4 Lötzinn zu sehen ist, die 
restlichen Kontakte sind hohl.

Jetzt habe ich mal das Gehäuse etwas Gewaltsam geöffnet ( ist aber noch 
intakt )... und siehe da es sind wirklich alle 4 PIN's verdrahtet.

Im inneren befinden sich 2 Platinen... wobei eine auf der anderen 
"Huckepack" gesteckt ist... aber die Steckpfostenleiste.

hier mal ein Bild der beiden Teile:
http://s2.imgimg.de/uploads/zweiteiled442a45ajpg.jpg

> Zum Testen des Torantriebs kannst du auch bei abgezogenem HF-Modul die
> Pins 1 und 4 auf der Steuerplatine mit einem (isolierten) Draht brücken.
> Dann muss der Torantrieb anlaufen, so wie von der Fernbedienung gewohnt.
> Damit hast du schon besser eingegrenzt.

hat Dein Testszenario jetzt noch bestand wo sicher ist das PIN 3 auch 
etwas "bewirkt" ???


ciao Dirk

Autor: Dirk B. (derdirk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe gerade noch das Handbuch des Torantriebs gefunden... leider 
sind keine Schaltpläne drin.

Aber ein Bild der Hauptplatine ist zu sehen:
http://s2.imgimg.de/uploads/steuerungtorantrieb705...

hier mal eine Nahaufnahme des hinteren Teils ( HF-Stecksockel, 
Schlüsselschalter Anschluß )
http://s2.imgimg.de/uploads/hauptplatinezoom549dc261jpg.jpg

vielleicht läßt die etwas Rüchschlüsse zu ( wenn man mehr Ahnung hat wie 
ich )... ganz rechts im Runden Sockel steckt der HF Empfänger, gleich 
Links daneben sind die 2 Drähte vom Schlüsselschalter, der draußen an 
der Garage angebracht ist, angeschlossen.

Deshalb dachte ich halt ob die Schaltung innerhalb des HF-Empfängers 
nicht einfach PIN 1 & 3 miteinander auf Funkbefehlt zusammenführt... so 
wie es der Schlüsselschalter ja auch macht, der "brückt" ja auch den Weg 
zwischen den beiden Anschlußklemmen oder ???

Kann das vielleicht sein ???


ciao Dirk

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

welchen Grund gibt es eigentlich, die aufgedruckte Beschaltung erstmal 
prinzipiell anzuzweifeln?

Der Hersteller aknn auch an alle anderen Anschlüsse ranlöten, was er 
will. Messpunkte, Prüfanschlüsse für die Fertigung, eben was er will.

Wie der Nutzer das Ding zu Verwenden hat, ist auf dem Anschlußplan 
angegeben...

Hast Du denn dem Vorschlag von HildeK folgend mal Pin 1 und 4 an der 
Fassung mal gebrückt?

Entweder Du kennst Dich damit aus, dann kommst Du allein klar oder Du 
fragst.

Fragen, um die Antworten ohnehin zu ignorieren, ist für beide Seiten 
unproduktiv.
Hier ist nicht die kostenlose Hotline des Herstellers sondern ein Forum, 
wo Leute ihre Freizeit opfern.

Gruß aus Berlin
Michael

Autor: Dirk B. (derdirk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael U. schrieb:
> Hallo,
Hallo Michael,

> welchen Grund gibt es eigentlich, die aufgedruckte Beschaltung erstmal
> prinzipiell anzuzweifeln?
HildeK meinte ja das PIN 3 nicht beschalten ist, jetzt war er es ja aber 
doch... das hat mich verwirrt und ich wollte nochmal nachfragen ob das 
"Testszenario" dann auch noch Bestand hat wenn dieser 3. PIN belegt ist. 
Da ich noch keine Antwort erhalten hatte habe ich abgewartet.

> Der Hersteller aknn auch an alle anderen Anschlüsse ranlöten, was er
> will. Messpunkte, Prüfanschlüsse für die Fertigung, eben was er will.
>
> Wie der Nutzer das Ding zu Verwenden hat, ist auf dem Anschlußplan
> angegeben...
alles klar werde ich in Zukunft berücksichtigen.

> Hast Du denn dem Vorschlag von HildeK folgend mal Pin 1 und 4 an der
> Fassung mal gebrückt?
würde ich gerne, ich finde aber keinen Draht der im Sockel halten will, 
sind alle zu dünn ( Torantrieb ist ja an der Decke montiert, überkopf ).
Ich versuchs gleich nochmal beim Nachbarn ob der vielleicht aushelfen 
kann.

Oder kann ich den dünnen Draht gefahrlos beim Überbrücken in der Hand 
halten ???

Was ich jetzt probiert habe ist der erste Vorschlag von HildeK:
>an Pin 1 gegen GND Pin 4 messen (bzw. die LED beobachten) und den
>Sender betätigen.
das Multimeter zeigt nichts an, bleibt bei 0,00 V

was müßte hier gemessen werden ??? die Eingangsspannung die 
weitergeschalten worden ist oder ???


ciao Dirk

P.S. habt bitte etwas Nachsicht mit mir... ich kenne mich wirklich nicht 
sonderlich gut aus und möchte auf keinen Fall den Torantrieb durch meine 
Unwissenheit ganz kaputt machen.

Autor: quarkler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Ist das SOMMER-Torantrieb, wenn ja, dann bekommst du dort noch Ersatz 
für deinen Funkempfänger, falls nicht, bietet SOMMER auch eine 
Alternative für solch einen Fall an.
http://www.sommer-torantriebe.de/dynasite.cfm?dssi...


Gruss, quarkler

Autor: HildeK (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
>HildeK meinte ja das PIN 3 nicht beschalten ist, jetzt war er es ja aber
>doch... das hat mich verwirrt und ich wollte nochmal nachfragen ob das
>"Testszenario" dann auch noch Bestand hat wenn dieser 3. PIN belegt ist.
>Da ich noch keine Antwort erhalten hatte habe ich abgewartet.

Sorry, war gestern Abend dann anderweitig beschäftigt :-)
Dass Pin 3 belegt ist, konnte ich aus dem Anschlußschema nicht erkennen. 
Wenn du aber die Buchse auf dem Platinenfoto anschaust, an die letztlich 
diese runde Fassung angschlossen ist, dann sehe ich da auch nur drei 
weiterführende Leiterbahnen. Siehe Anhang - die roten Punkte.


>Oder kann ich den dünnen Draht gefahrlos beim Überbrücken in der Hand
>halten ???
Nimm isolierten Draht, dann sollte das sicher kein Problem sein. Ich 
hätte jetzt so an ein kleines Stück aus einem alten Netzkabel gedacht. 
Du solltest ja auch nur kurz diese Pins brücken, dann müsste der 
Torantrieb anlaufen, so wie wenn er per Fernbedienung auch reagierte. 
Dies wäre an der Buchse zu tun, in der normalerweise der Empfänger 
gesteckt ist.
Läuft er nicht an, so ist der Defekt vermutlich nicht im Empfänger.

>Was ich jetzt probiert habe ist der erste Vorschlag von HildeK:
>>an Pin 1 gegen GND Pin 4 messen (bzw. die LED beobachten) und den
>>Sender betätigen.
>das Multimeter zeigt nichts an, bleibt bei 0,00 V
Ich schrieb ja:
>- Einen Widerstand, z.B. 1k, zwischen Pin 1 und Pin 2 anschließen,
ohne diesen Widerstand wirst du immer 0V messen an Pin 1 messen.
Also, nochmals zur Verdeutlichung:
Du nimmst den Empfänger und klemmst die 12V Versorgung an die Stifte 1 
und 4 an. Dann wird ein Widerstand 1kOhm zwischen Pin 1 und Pin 2 
angschlossen.
Nun klemmst du deinen Spannungsmesser zwischen Pin 1 und Pin 4 an.
Wenn du jetzt den Sender bedienst, dann sollte dein Spannungsmesser sich 
rühren - entweder von 0 auf 12V gehen oder , wahrscheinlicher, 
umgekehrt.
Tut sich da nichts, dann wäre der Empfänger defekt.

Eine der beiden Versuche sollten aber schon eine Funktion zeigen.

Autor: Dirk B. (derdirk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für Deine Rückmeldung HildeK,

>Sorry, war gestern Abend dann anderweitig beschäftigt :-)
Absolut kein Problem... ich freue mich das DU mir so kompetent 
weiterhilfst ;) Danke nochmal.

da ich immer noch keinen geeigneten Draht aufgetrieben habe werde ich 
jetzt nochmal die Messung am HF-Sender mit Widerstand probieren ( habe 
noch einen alten Lautstärke Regler/Poti rumliegen, den stelle ich auf 1 
KOhm ).

HildeK schrieb:
> Du nimmst den Empfänger und klemmst die 12V Versorgung an die Stifte 1
> und 4 an.

Wirklich an PIN 1 ??? PIN 2 ist doch Plus !!!
Ist das ein Tippfehler von Dir ???

gestern meintest du auch

> - 12V ... 18V an Pin 2 gegen GND an Pin 4 anklemmen
> - Einen Widerstand, z.B. 1k, zwischen Pin 1 und Pin 2 anschließen, ev.
> - an Pin 1 gegen GND Pin 4 messen (bzw. die LED beobachten) und den
>Sender betätigen.

Bitte nochmal kurze Rückmeldung... Danke !!!


ciao Dirk

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>HildeK schrieb:
>> Du nimmst den Empfänger und klemmst die 12V Versorgung an die Stifte 1
>> und 4 an.

>Wirklich an PIN 1 ??? PIN 2 ist doch Plus !!!
>Ist das ein Tippfehler von Dir ???
Sorry - Typo!
Natürlich ist Puls der PIN 2! Bei der ewigen Hin- und Herschalterei 
zwischen Bild und Text ...
Ich muss mich doch noch 'nen zweiten Monitor zulegen :-)

Autor: Dirk B. (derdirk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
HildeK schrieb:
> Sorry - Typo!
macht nix ;)

so jetzt habe ich alles richtig angeschlossen.

Ergebnis: Meine Eingangsspannung liegt immer/konstant an zwischen PIN 1 
& 4 egal ob ich die Fernbedienung drücke oder nicht :(

müßte jetzt also bedeuten das der HF-Empfänger wirklich defekt ist, 
spätestens Morgen besorge ich mir nochmal einen isolierten Draht und 
mache die "Gegenprobe" am Torantrieb.

ok nochmal vielen Dank ALLEN beteiligten ;)


ciao Dirk

Autor: Sepp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Muß es denn wirklich am Empfangsteil liegen?

Könnte es nicht auch sein, daß ganz einfach der Funkempfang gestört ist? 
Weil beide Funkfernbedienungen nicht funktionieren. Könnte es sein daß 
sich eines der Mäuseklaviere mit denen sich der Öffnungskode einstellen 
läßt, verstellt hat. Ein ähnliches Problem hatten wir bei unserer 
Tiefgargeneinfahrt, (> 100 Stellplätze). Servicetechniker tauschte 
Empfänger, hatte keinen Erfolg. Glücklicherweise ließ sich das Problem 
durch eine veränderte Antennenmontage lösen, sonst hätten wir eine neue 
Funköffnung anschaffen können, weil auf den "Allgemeinfrequenzen" halt 
alle senden dürfen......


MFG

Sepp

Autor: Dirk B. (derdirk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sepp schrieb:
>Könnte es sein daß > sich eines der Mäuseklaviere mit denen sich der 
>Öffnungskode einstellen läßt, verstellt hat.

Hallo Sepp, dieses von Dir beschrieben Fehlerbild habe ich gleich als 
erstes überprüft die 10 Schalterchen sind an den beiden Sendern und am 
Empfänger gleich eingestellt.

wäre auch zu einfach gewesen ;)


ciao Dirk

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.