mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik problem mit dem mega 128


Autor: mpf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi ihr alle,

hab durch suchen euer forum hier entdeckt und mir so gedacht, ihr könnt
mir vielleicht helfen...
mein "problem" ist, dass ich versuche auf meinem mega128 ein
lauflicht zum laufen zu bringen... soweit so gut. wenn ich das ganze
hintereinander weg schreibe ohne unterprogrammaufruf läuft es richtig
gut. wenn ich aber die wartezeit über eine subroutine laufen lassen
will, spinnt er rum und scheint seine Rücksprungadresse nicht zu finden
(er springt wieder auf 0000h). es kann eigentlich nur am stack liegen,
den habe ich aber initialisiert und auf einen freien bereich gelegt.
jetzt das ganz eigenartige: im simulator läuft es ohne probleme - er
springt dorthin zurück wohin er soll.

kann mir irgendjemand sagen was das problem ist?

mfg michael

Autor: Volkmar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du die Mega103-Kompatibilitätsfuse gelöscht?

Volkmar

Autor: mpf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nein hatte ich noch nich...
funktioniert, danke

mfg michael

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.