mikrocontroller.net

Forum: Gesperrte Threads Fritzbox registriert DHCP-HostName nicht


Autor: Raphael S. (raphaels)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

nachdem ich einen kleinen Webserver mit uip programmiert habe,
will ich nun auch DHCP benutzen.

Ich habe den Code auch schon drinnen, es läuft alles prächtig,
ich bekomme meine IP-Adresse usw...

Bei der Fritzbox (und vielen anderen) gibt es aber eine "Tabelle",
in der die Netzwerkgeräte mit Namen aufgelistet sind, inklusive
deren IP-Adresse und MAC-Adresse.
Und in diese Liste möchte ich mich nun gerne "eintragen"...

Also habe ich in den DHCP-options die Option 12 "Host-Name"
gewählt, einen String angegeben, so wie es sich halt gehört.

Nachdem ich so nicht registriert wurde, hab ich auch noch die
Option 61 "Client-Identifier" (inkl. MAC-Addr) und
81 "Client Fully Qualified Domain Name" (inkl. Flags usw, und
der Domain, im meinem Fall die gleiche wie in "Host-Name")
hinzugefügt.

Leider werde ich immernoch nicht registriert...

Ich habe auch schon den DHCP-Vorgang von einem PC, der ans
Netzwerk angeschlossen ist, "beobachtet", ich sehe keinen wirklichen
Unterschied in den Paketen, aber der PC wird in die Liste aufgenommen...

Was brauche ich noch alles an Optionen? Was mache ich falsch?

Ich würde mich über eine hilfreiche Antwort freuen
Raphael

: Gesperrt durch Moderator
Autor: Lutz F. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

du musst die die Option 61 "Client-Identifier" auf deine
verwendete MAC-Adr (im ASCII-Format z.B. "00:23:34:AC:34:23") setzen.
Dann funktioniert es bei mir mit der Fritzbox. Ich verstehe das auch 
nicht, weil ja die MAC-Adresse im Protokoll schon enthalten ist.
Der Name wird von der FRitzbox jedoch erst dann angezeigt.

Lutz

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hältst Du es für wahrscheinlich, daß Raphael fast zwei Jahre lang auf 
Deine Antwort gewartet hat?

Autor: Simon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lol :D

Dieser Beitrag ist gesperrt und kann nicht beantwortet werden.