mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik RDS-Decoder Signal zu schwach?


Autor: bastler (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo
Ich habe aus einer HIFI Anlage den Radio Tuner aufgebaut. Der Tuner hat 
ein Tuner Chip LA1844, PLL Chip LC72121 und RDS Decoder BU1924F verbaut.

Den Tuner betreibe ich mit einem PIC 18F2680, mein Prototyp auf 
Lochraster aufgebaut funktioniert. ( Empfangsfrequenz kann programmiert 
werden..).

Mit dem RDS Decoder hab ich jedoch Probleme. Ich kann die Daten 
empfangen und einlesen. Jedoch nimmt das RDS Signal ab, sobald Musik 
empfangen wird :S. Der "QUAL" Ausgang am BU1924F ist nicht konstant 
HIGH, sondern hat immer wieder kleine LOW Phasen. Bei Musik treten 
mehrere LOW Phasen auf....

Liegt der Fehler im Tuner?

Im Anhang der Quellcode vom PIC... (CCS C Compiler)

Autor: bastler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
????

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

mein Decoder mit dem TDA7330 hat da auch etwas andere Ansichten als das 
Datenblatt vermuten läßt. Ich habe es dann ignoriert.

Prinzipiell kann natürlich die Modulation speziell des oberen 
Stereoseitenbandes in das RDS Signal reinstören, sollte es nicht.
Ob OptiMode und ähnliche Unsäglichkeiten heutiger Radiosendungen es 
trotzdem schaffen, habe ich nicht geprüft.

Gruß aus Berlin
Michael

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
vielleicht stört auch einfach nur der PIC da rein ???? evtl. PIC und 
Tuner besser voneinander entkoppeln.

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

da hatte ich bei meinem Testaufbau auf einem Steckbrett mit Tunermodul, 
RDS-Decoder, NF-Prozessor, Mega16 und MC34063A für die Kontrastspannung 
eines Grafikdisplays komischerweise keine Probleme.

Störungen hat dagegen dann ein 12V Schaltnetzteil erzeugt, allerdings im 
hörbaren Bereich. Ein anderer Typ war dann ruhig.
RDS wurde recht zuverlässig decodiert, solange der Empfang nicht zu 
schlecht wurde. Auch in Berlin im Altbau ist eine Wurfantenne am 
Basteltisch nicht unbedingt ideal. Das Quality-Signal machte trotzdem 
was es wollte.

Gruß aus Berlin
Michael

Autor: bastler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PIC stört nicht, der Tuner ist in einem seperatem gehäuse 
(Abschirmblech).
Ich kann nur ca. alle 2-3 Sekunden eine korrekte Gruppe einlesen.. Und 
bei Musik manchmal nur alle 5 Sekunden.

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Spannung des RDS-Decoders sauber? Erzeugt die der Tuner selbst?
Ist das alles im Stück in der Büchse oder ist der RDS-Decoder extern 
angeschlossen? Die größe des Ankoppel-C war beim TDA7330 jedenfalls 
relativ kritisch.

Empfang selbst ist ok?

Gruß aus Berlin
Michael

Autor: bastler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der RDS Decoder ist im Tuner.
Die Versorgunsspannung des RDS Decoder wird getrennt, extern 
eingespiesen (Spannungsregler 5V).
Die Signalstärke vermute ich ist stark genug... (Kein Rauschen etc..)

Autor: bastler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Niemand eine Idee?
sorry wenn ich stresse, aber hab schon viel zeit dafür geopfert :(

Autor: Abdul K. (ehydra) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du die Probleme bei allen Sendern? Ich gehe jetzt einfach mal davon 
aus, das der 1940 dem 7330 entspricht.

Prinzipiell kämen in Betracht:
- falscher Pegel, eventuell zu hoch
- 19kHz-Oberwellen bzw. 57kHz-Signal stören Dekoder (Es gibt einen 
gravierenden Unterschied, ob der 57kHz-Träger da ist oder nicht, da der 
Dekoder dann komplett intern die Demodulation umschalten muß. Wenn er 
sich nicht dauerhaft entscheiden kann, gibts Wurst).
- Quarzfrequenz brauch nur leicht falsch sein und es geht nicht richtig.

Soweit ich mich erinnere, dekodiert der 7330 bei nur leichten Störungen 
noch korrekt, zeigt dann aber abundzu 'schlechte Qualität' an.


Gruß -
Abdul

Autor: bastler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm vielen Dank für die Antwort.

Das Problem tritt bei allen Sendern auf.
Kann ich die Signalstärke des RDS Signals irgendwie messen? (Osz, 
Spektrumanalyzer etc. verfügbar :) ).
Doch da das RDS Signal bei Musik schwächer wird, deutet für mich eher 
auf ein anderes Problem als die Signalstärke :S??

Autor: bastler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
???

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht sind die ZF-Filter generell etwas zu schmal dafür? Vielleicht 
kannste die mal gegen 300kHz-Dinger tauschen (ansonsten mit ähnlichen 
Daten wie die originalen). Die Trennschärfe wird zwar nicht so super 
sein, aber mal so als Test.
Ich habe so den Verdacht, daß durch den Frequenzhub der Musik die 
Filterbandbreite immer mal überschritten wird (müsste sich aber als 
Kratzen anhören)

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

er schreibt ja, das es eine komplette Tunerbaugruppe ist incl. RDS.
Da würde ich das eher weniger vermuten.

Schlechter bei Qualität heißt ja auch nicht schwächer sondern die 
Fehlererkennung der inernen Taktrückgewinnung mault.
Das kann genauso gut bei stärker durch Übersteuerung passieren.

Ist trotzdem bei einer kompletten Baugruppe alles etwas 
unwahrscheinlich.

Was ist mit einem ganz normalen Fehler? Tauber Elko auf dem Modul in der 
Betriebsspannung usw.

Ist denn sicher, daß das Tunermodul in der Originalanlage noch 
fehlerfrei lief? Nicht, daß man jetzt am falschen Ende sucht.

Gruß aus Berlin
Michael

Autor: Abdul K. (ehydra) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bastler schrieb:
> Hmm vielen Dank für die Antwort.
>
> Das Problem tritt bei allen Sendern auf.
> Kann ich die Signalstärke des RDS Signals irgendwie messen? (Osz,
> Spektrumanalyzer etc. verfügbar :) ).
> Doch da das RDS Signal bei Musik schwächer wird, deutet für mich eher
> auf ein anderes Problem als die Signalstärke :S??

Na wenn du sogar einen SA hast, dann schau dir doch das MPX-Signal mal 
genau an. Wie es sein sollte, kann man sich in einer AppNote bei 
www.silabs.com ansehen.

Rauschfreie stabile Versorgungsspannung ist natürlich notwendig. Die 
Masseführung muß auch einwandfrei sein. Probiers erstmal mit einer 
Schaltung, die komplett mit einer Batterie versorgt wird. Nicht das z.B. 
der USB-RS232 Adapter reinpfeift.

Im DB des Chips sollte sich der optimale Pegel finden lassen.

Falls das Teil mal auf den Boden gefallen ist, dann würde ich auf das 
Quarz tippen. Diese RDS-Demodulatoren sind extrem frequenzempfindlich. 
Hat der Quarz ne Macke, ist so ein Fehlverhalten sehr wahrscheinlich.


Gruß -
Abdul

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.