mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Wie schaltet diese Schaltung bei 0 Volt durch?


Autor: Orikson (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich zerbreche mir grad den Kopf wie ich folgendes realisieren kann:

Ich habe einen unipolaren Hallsensor (Reichelt: TLE 4905L), einen 
Transistor als Treiber und eine Konstantstromquelle mit LM317 für den 
Power LED (300mA). Wenn am Hallsensor ein Magnet anliegt gibt der eine 
Spannung von 0 Volt aus und genau dann soll die LED leuchten!

Jetzt habe ich mir folgende Schaltung ausgedacht:
http://pic.leech.it/pic.php?id=af2b7c15bild1.png

Allerdings läuft das so nicht, ich hätte da auch schon eine Vermutung 
woran das liegen könnte, wüsste aber nicht wie es anders gehen würde. 
Gibt's da ne einfache Variante (die Schaltung soll recht kompakt 
bleiben) oder komm ich um viel Aufwand nicht rum?

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Allerdings läuft das so nicht.

Was passiert denn? Wie hoch ist Vss?
R1 zwischen Basis und Emitter des Transistors schalten.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich weiß ja nicht, was genau du vor hast, aber ich kann mir vorstellen, 
dass ein Reed-Kontakt in Reiehe zur LED (und der Stromversorgung) deine 
ganze Schaltung gut ersetzen könnte?

Autor: Roland Praml (pram)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du musst einen PNP-Transistor nehmen denke ich.

Gruß
Roland

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gezeichnet ist pnp.
Betriebsspannung muß auf jeden Fall höher als Ufled + 4V sein.

Autor: Orikson (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Natürlich wieder die Hälfte der Infos vergessen, liegt wohl an den 4 
Stunden schlaf ...

Betriebsspannung sind 12 Volt, die LED verträgt ~3.4V. PNP Transi ist es 
ja eigentlich?! R1 wird für den Hallsensor benötigt da der n "open 
collector" is.

So wie die Schaltung jetz ist passiert gar nichts. Ich habe es zuerst 
aber falsch aufgebaut, also die Last (LED und LM317 KSQ) auf die falsche 
Seite vom Transi gehängt. Da gings, wenn auch nicht 100%. Mit Magnet war 
die LED aus, ohne hat sie leicht geleuchtet.

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Open Collector funktioniert auch "durch" den Transistor durch.
Wenn alles richtig angeschlossen ist und die 12 Volt genügend belastbar 
sind sollte es funktionieren.

Autor: Roland Praml (pram)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oh mann und ich kenn nicht mal mehr den Unterschied zwischen NPN/PNP....
Mein Beitrag war natürlich quatsch. Eigentlich bin ich auch der Meinung, 
dass es funktionieren soll.

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schon mal versucht vom Kollektor des Transitors zur Masse nen Widerstand 
zu schalten (so nen Kiloohm)?

Autor: Orikson (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Einen Reedsensor hab ich eigentlich wieder recht schnell verworfen, da 
ich befürchte dass die durch Erschütterungen und Vibrationen recht 
schnell den Geist aufgeben und nicht sensibel genug sind. Der Hallsensor 
"spürt" schon nen Magneten aus 1 - 1,5 cm.

Habe grade mal R1 rausgeschmissen und R3 durch nen 1k Ohm ersetzt. Jetz 
macht er immerhin schon mal das was er soll, nur verkehrt. Also wenn ich 
einen Magneten an den Sensor ran halte leuchtet die LED (12 Volt liegen 
am Ausgang vom PNP-Transi an), wenn kein Magnet in der Nähe ist bleibt 
sie dunkel (0 Volt).

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mal den Magneten rumdrehen? (Süd-/ Nordpol)

Autor: Orikson (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann passiert gar nichts, so als ob kein Magnet da wäre. Die Frage ist 
aber eh sinnlos, weil wenn es ohne Magnetfeld schon nicht leuchtet es 
mit Magnetfeld auch nicht passt. Die jetzige Ausgabe müsste also gedreht 
sein...

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also wenn ich dich richtig verstanden habe, soll die LED leuchten, wenn 
kein Magnet dran ist? Dann einfach npn-Transistor nehmen (C an Vcc), und 
R3 am besten raus (einfache Verbindung). Das gibt zwar einen mehr oder 
weniger leichten Spannungsabfall am Q1 (weil Spannungsfolger), sollte 
aber vielleicht kein Problem sein.

Autor: Orikson (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Jens: Öhm, ja das wars, jetz geht es!

Dann hab ich die PNP Wahl wohl nem Denkfehler zuzuschreiben...

Danke für die Hilfe

Autor: Roland Praml (pram)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
man kann den NPN evtl auch in die GND-Leitung tun, dann ist das mit dem 
Spannungsabfall nicht so tragisch.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.