mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik uC und AVRISPmkII Problem


Autor: matzunami (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe einen AT90USB467, denn ich mittels AVR Studio und AVRISPmkII 
Programmer programmieren wollte. Wenn ich dies versuche kommt leider 
eine Fehlermeldung (siehe Anhang). Ich habe das Board insgesammt 2 mal 
und das andere funktioniert einmandfrei. Ich habe (soweit mir möglich, 
d.h. mit einem Multimeter) einige sachen nachgemessen, und keine 
unterschiede zu dem funktionierenden Board festgestellt. Der einzigste 
unterschied besteht darin, dass das Board, welches geht, einen externen 
Quarz besitzt. Diesen hab ich allerdings auch erst über den Programmer 
eingestellt. Ich bin gerade ein bischen am verzweifeln und komm nicht 
weiter. Vielleicht hat ja hier einer ne idee. Kann ich irgendwie testen 
ob der uC an sich ok ist?

MfG
matzunami

Autor: Andi ... (xaos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mach doch einfach mal das, was in der error mesage steht ;)

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Diese Fehlermeldung hat wahrscheinlich schon jeder Atmel Programmierer 
mindestens einmal gesehen. Hilfreicher wäre z.B. deine ISP-Frequenz.

MfG Spess

Autor: matzunami (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab schon jede SPI Frequenz durchprobiert. Und
Werksseitig war (bei dem anderen uC jedenfalls) der interne 8MHz 
aktiviert, mit dem durch 8 Teiler, womit eine SPI Frequenz von 250MHz 
passen müsste. hat bei dem anderen ja auch gepasst.

Autor: matzunami (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
250kHz meinte ich

Autor: matzunami (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gibt's noch andere möglichkeiten, außer SPI Frequenz verstellen? Gibt es 
eine möglichkeit zu prüfen ob der uC in Ordnung ist? VCC und GND liegt 
überall ordnungsgemäß an.

Autor: matzunami (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Keiner noch ne Idee, wenns nicht an der Frequenz liegt und an der 
Beschaltung?

Autor: Das Nichts (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In der Fehlermeldung steht-> kleiner als 1/4 der Taktfrequenz.

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

matzunami schrieb:
> 250kHz meinte ich

Nein!. Weniger als 1/4 sagt Atmel und dummerweise zeigen die AVR bei 
ziemlich genau 1/4 ein sehr unberechenbares Verhalten, wie ich selbst 
schon erfahren mußte...

Es kommt u,U. keine Fehlermeldung vom Studio, dafür werden dann aber 
z.B. Fuses völlig unberechenbar geloscht oder gesetzt.

Jede Frequenz probieren ist aber unötig.
Bei werkneuen sind 125kHz oder was da in der nähe liegt, richtig,
bei hoch getakteten in einer fertigen Schaltung kann mehr als 1MHz 
problematisch sein, wenn die Sachen, die mit am ISP hängen, die Flanken 
versauen.

Gruß aus Berlin
Michael

Autor: matzunami (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja vielen Dank... aber wie ich schon sagte, habe ich JEDE Frequenz schon 
durchprobiert und es hat sich nix geändert

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.