mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik UART LIN-Transceiver Problem


Autor: Roman (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey Leute,

ich versuche über einen Uart einen LIN Transceiver anzsteuern.
Aber des mit dem Break-field klappt leider nicht. Habe schon in anderen 
Berichten gelesen, dass dazu die Baudrate halbiert werden sollte.
Ich habe da mal geschrieben:

#include <avr/io.h>
#include <string.h> // Für "strcmp"
#include <stdlib.h> // Für "itoa"
#include <util/delay.h>
#define  TAKT      16000000UL
#define UART_BAUDRATE  4800
#define UART_BAUDRATE1 9600
int i=0;

// Berechnung der Konfigurationsparameter
#define UART_SETTING  ((TAKT/16L/UART_BAUDRATE)-1)
#define UART_SETTING1  ((TAKT/16L/UART_BAUDRATE1)-1)


void setup_uart()
{

  /* Empfänger und Sender einschalten */
  UCSR1B =(1<<RXEN1) | (1<<TXEN1);

  /* Asynchron, 8N1 */
  UCSR1C = (1<<UCSZ11)|(1<<UCSZ10);
}


void uart_send( uint8_t zeichen )
{
while( ! (UCSR1A & ( 1<<UDRE1 ) ) );  // Warte, bis Puffer frei ist
  UDR1 = zeichen;               // jetzt das Byte ins UDR schreiben
}


void uart_putstring(char *str)
{
  unsigned char i;

  for (i=0;i<255;i++) /* Maximal 255 Zeichen ausgeben ... */
  {
    if (str[i] != 0)
      uart_send(str[i]);
    else
      break; // Ende des Strings erreicht
  }
}

char uart_getchar()
{
  // Ist schon ein Zeichen im Buffer?
  if (bit_is_set(UCSR1A, RXC))
    return UDR1;
  else
    return -1;
}

void uart_readline(char *str)
{
  char c;
  unsigned char index;

  index = 0;

  while (1)
  {
    c = uart_getchar();
    if (c != -1)
    {
      if (c == 13) /* ASCII: NewLine */
      {
        /* Ende der Zeile erreicht,
           also String abschließen */
        str[index] = 0;

        /* Funktion beenden */
        return;
      }
      else /* Normales Zeichen, anhängen an die Zeichenkette */
      {
        str[index] = c;
        index++;
      }
    }
  }
}

int main(void)

{
  int i=0;
      setup_uart();
  for(;;)
  {

  if (i==3000);
  {

  UBRR1H = (char) (UART_SETTING >> 8);
  UBRR1L = (char) (UART_SETTING);
    uart_send(0x00);


while( ! (UCSR1A & ( 1<<TXC1 ) ) );
  UBRR1H = (char) (UART_SETTING1 >> 8);
  UBRR1L = (char) (UART_SETTING1);
    uart_send(0x55);
//  uart_send(0x02);

    i=0;
    }
    i++;

  }

  return 0;
}

So wie hier funktioniert es eigentlich. Kommentiere ich folgende Zeile 
aber nicht aus.
//  uart_send(0x02);

werden alle informationen mit der Baudrate gesendet. Ist die Zeile 
auskommentiert werd die 0x00 mit Budrate und 0x55 mit Baudrate1 
gesendet.

Kann mir bitte jemand sagen woran das liegt??

Vielen lieben Dank!

Gruß Roman

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.