mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik FET "stirbt" nach einer Weile - warum?


Autor: Daniel B. (scheinleistung)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

Ich lasse einen EMitter mit 0,7A blinken und das über diesen FET:

http://www.fairchildsemi.com/ds/FD/FDN337N.pdf

das Gate ist über 100Ohm an den Port Pin des Atmel uC angeschlossen (auf 
dem STK500 Board). Betrieb an 5V. Pull Down Widerstand 12k.

Das Problem ist dass der FET nach einer Weile den Geist aufzugeben 
scheint: er schaltet plötzlich nicht mehr ab sondern leuchtet dauerhaft 
schwach und blinkt darüber auch nur mit halber Kraft. Austauschen des 
FETs löst das Problem für eine Weile.  Hat jemand eine Idee was ich 
falsch mache? Ist der FET schlecht gewählt? Die Ansteuerung falsch?

: Verschoben durch Admin
Autor: Bernhard Mayer (bernhard84)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi.

Ansteuerung und FET schaun gut aus und dürften keine Fehler machen.

Was ist das für ein Aufbau? Kannst du vielleicht mal den konpletten 
schaltplan posten? Könnte da irgendwas anderes reinkommen? vielleicht 
irgendwo ne überspannung?

Bernhard

Autor: L. R. (badinode)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Warum der Widerstand R7?
Warum hast du Drain und Source kurzgeschlossen?

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im Bild sehe ich keinen Pulldown.

PS: Wenn der FET dauerhaft leuchtet würde ich mir wirklich ernsthaft 
Sorgen machen. Auch wenn's nur schwach ist ;-).

Autor: Daniel B. (scheinleistung)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist schon die ganze Beschaltung, das Gate ist nun an den Pin PB2 des 
STK500 Experimentier Boards angeschlossen! Der Pull-Down der in der 
Zeichnung fehlt ist ebenfalls am Gate angeschlossen (12k Ohm).

@L. R.  R7 ist der Vorwiderstand damit der Port nicht überlastet wird 
wenn das Gate umgeladen wird!

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Widerstandswerte habe ich mir nicht angeschaut. Es könnte aber sein, 
dass es an den parasitären Kapazitäten des Mosfets liegt.
Um den Mosfet zum Schalten anzusteuern, sollte eine Gegentaktschaltung 
(auch Totem-pole genannt, oder so) verwendet werden. So können die 
Kapazitäten entladen werden und das Gate is nicht dauernd 
durchgeschalten.

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wird der Transistor warm?

Wenn R5 wirklich nur 1 Ohm hat sehe ich dort das Problem. Lieber mit 
höherem Widerstand an höherer Betriebsspannung betreiben.

Autor: L. R. (badinode)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ D. Berg: Danke.

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zu meinem vorigen Eintrag:
Wenn der PullDown 12k hat würde das ev. eine langes Tau ergeben.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  D. Berg (scheinleistung)

>Das Problem ist dass der FET nach einer Weile den Geist aufzugeben
>scheint:

Möglicherweise ist dein Port nicht als Ausgang, sondern als Eingang 
konfiguriert. Dann schaltest du nur den Pull-Up des AVRs ein und aus. 
Dadurch wird der FET aber nicht schnell und vollständig geschaltet. Er 
arbeitet im Linearbetrieb, wird heiss und brennt irgendwann durch.

MFG
Falk

Autor: Daniel B. (scheinleistung)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gute Idee aber das stimmt doch oder (alle als Ausgänge):
//Initialisierung

PORTB  = 0b11111111;
DDRB  = 0b11111111;

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo D.,

vielleicht sinkt der Spannungsabfall über der LED, wenn sie beim Betrieb 
warm wird? Dann muß der FET einen größeren Strom schalten.

Die Versorgungsspannung sollte deutlich größer als 4,2V und der 
Strombegrenzungswiderstand deutlich größer als 1 Ohm sein. Sonst 
schwankt der Strom zu stark.

Miß mal mit deinem Oszi, ob Ugs sauber und schnell von 0V nach 5V und 
zurück springt.

Wird der FET warm?

Kai

Autor: Michael Wittmann (miwitt001)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte mal mit einem sehr ähnlichen Aufbau das selbe Problem. Hin und 
wieder ist ein MOSFET gestorben (BUZ10).
Das Gate eines MOSFETs ist empfindlich gegen eine zu hohe Spannung. 
Meiner ist einfach aus dem Grund ab und zu kaputt gegangen, weil der 
Aufbau relativ fliegend war und ich wohl aus Versehen ab und zu das Gate 
berührt habe -> ESD -> kaputt.
Lösung des Problems: Ein hochohmiger Widerstand zwischen Gate und Masse, 
der eventuelle Entladungen am MOSFET vorbei nach Masse abläd. So aus dem 
Gedächtnis waren 50 kOhm OK. Dann war Ruhe.
Evtl ist es ja bei dir das selbe.

mfg Michael

Autor: Daniel B. (scheinleistung)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Kai
Warm wird er nicht!

@Michael
Den Versacht habe ich langsam auch!

Autor: Peter R. (pnu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gerade die Tatsache, dass der FET ohne Wärmeentwicklung draufgeht, lässt 
auf Überspannung schließen. Eine Messung am defekten MOSFET würde dann 
aber leitende Verbindung zwischen Gate und S (oder D) anzeigen.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Gerade die Tatsache, dass der FET ohne Wärmeentwicklung draufgeht, lässt
>auf Überspannung schließen.

Nicht unbegdingt. Denke an einen Wackler der von Zeit zu Zeit die 
Anschlüsse der LED nur kurzzeitig kurzschließt. In Verbindung mit einem 
guten Entkoppelkondensator an der 4.2V Versorgungsspannung wird dann der 
FET jedes Mal ein bißchen gegrillt, bis er irgendwann futsch ist.

Kai

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.