mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATMEL Evaluation Board v2.0.1 - Problembehebung


Autor: Daniel Jäger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Mein Problem ist folgendes:
Ich habe das Atmel Board fertig zusammengebaut, samt Addon-Board.

Soweit so gut.
Das Board kriegt Strom über ne 9V-Blockbatterie, die Netz-LEDs beider 
Boards sowie die Hintergrundbeleuchtung des LCDs leuchten.

Ein einfaches Testprogramm was ich geschrieben hab (das mitgelieferte 
hat garnicht funktioniert) hat auch beim Board funktioniert.

Jetzt bekomme ich aber keine Ausgabe auf dem LCD oder über die serielle 
Schnittstelle geliefert.

Der ATmega32 lässt sich über PonyProg2000 garnicht ansprechen, der 
ATmega8 funktioniert, aber eben nur bedingt und nicht mit dem 
Addon-Board.

Jetzt hab ich auf dem ATmega8 das Addon-Testprogramm von Pollin drauf, 
und der Buzzer funktioniert endlich (hat er beim Standard-Test nicht 
gemacht), aber ausser den LEDs auf dem normalen Board tut und regt sich 
nichts, wobei eigentlich alle Elemente durchgetestet werden sollten.

Ein Multimeter hab ich zur Hand, und alle Bauteile wie Dioden etc. sind 
richtig gepolt und funktionieren.

Was kann ich noch überprüfen, und wo sind Fehlerquellen die dazu passen 
könnten?

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

vernünftige Stromversorgung nehmen...
Nichts ist so ärgerlich wie stundenlang den Fehler zu suchen um dann 
festzustellen, daß ein 9V-Block viel schneller leer ist als man meint.

5V + 1,5V für einen 7805 sind 6,5V +  vermutlich 2x 0,7V eines 
Brückengleichrichters auf dem Board sind 7,9V Mindestspannung.

Die LED-Beleuchtung allein zieht normalerweise schon mehr als für einen 
9V-Block gut ist.

Gruß aus Berlin
Michael

Autor: Daniel Jäger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe jetzt ein Netzteil dran, aber mehr tut sich leider bis jetzt auch 
nicht.

Autor: Daniel Jäger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist es relevant, dass ich die Jumper nicht aufgelötet habe?
(also nur die, die einfach nur Verlängerungen für die einzelnen Pins 
sind, wo man normalerweise Kabel etc. reinsteckt...

Autor: Stefan B. (stefan) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann sein. Manche Jumper müssen mit Brücken gesteckt sein, um bestimmte 
Funktionen der darüber zugänglichen Bauteile zu ermöglichen.

Beispiel: Senden über RS232 geht nur bei gestecktem Jumper JP1
http://www.pollin.de/shop/downloads/D810038B.PDF

Autor: Daniel Jäger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da hast du mich falsch verstanden, die Jumper sind natürlich drauf.
Nur die Jumper nicht, vom Addon-Board, welche die einzelnen I/O-Port 
verlängern, damit man Kabel anschließen kann.

Dabei war übrigens ein 1m Kabel, aber wohin gehört das? ^^

Autor: Martin M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
ich hab mal eine frage, wie kann das Board mit einer herkömmlichen 
9V-Blockbatterie betrieben werden, wenn in dem Datenblatt des Boards 9V~ 
Wechselstrom benötigt werden, aber eine Batterie eine Gleichstromquelle 
ist?

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich betreibe meines auch mit Saft aus einem 12V-Wechselspannung-Akku
(gerade zum Patent angemeldet).

Ein Gleichpsannungsakku würde aber auch gehen, weil auf dem Board
ein Brückengleichrichter ist. Der macht aus Wechselspannung
Gleichspannung, aus Gleichspannung ebenfalls.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.