mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik OpAmp problem CA3140


Autor: Grobi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi, kleines problem, ich möchte eine eingangsspannung 0-1,5V verstärken 
um ca. faktor 5, habe dazu einen ca3140 als nicht invertierenden 
Verstärker genommen, nur es wird nix verstärkt, die eingangsspannung 
kommt unverändert am ausgang wieder raus also spannungsfolgermäßig. 
Betrieben wird das ganze mit 5V so das auch nich mehr als 5V am ausgang 
rausgehen können.

Grobi

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> um ca. faktor 5,

Genauer gesagt um Faktor 6 bei deiner Widerstandswahl

> ca3140

Geiler Chip von RCA, uralt, konnte schon 0.5V unter GND messen, bei 
mehreren Teraohm Eingangswiderstand.

>  nur es wird nix verstärkt

Pin 5 abklemmen.

> Betrieben wird das ganze mit 5V so das auch nich mehr als 5V am ausgang
rausgehen können

Nicht über 3V, um genau zu sein,

Wirf halt mal einen Blick in die Datenblätter der Teile, die du 
verbaust.
CA3140 war damals richtig teuer und edel.

Autor: Grobi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
> Genauer gesagt um Faktor 6 bei deiner Widerstandswahl
ok 1 + R2/R1  = 1 + (47k / 10k)

> Pin 5 abklemmen.
Pin 1, 5 und 8 sind nich verbunden

> Nicht über 3V, um genau zu sein
hast recht, mehr als 2,9V sind nich rauszubekommen

wenn ich meinem Multimeter glauben darf kommen am OpOut ca. 1,5V raus 
wenn ich am nicht invertierendem Eingang 1,1V anliegen habe (maximum 
input). Wenn nix anliegt schwankt der OpOut zwischen 0,4V und 2,9V.

Im Anhang nochmal die schaltung wie ich sie auf nem breadboard aufgebaut 
hab.

Grobi

Autor: Grobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...könnte sich das bitte jemand nochmal angucken, ich kriegs einfach 
nich hin...

thx Grobi

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Grobi,

>Wenn nix anliegt schwankt der OpOut zwischen 0,4V und 2,9V.

Dann verstärkst du vielleicht Brummen, weil dein OPamp dann extrem 
hochohmig ist am Eingang und allen Brumm aus der Umgebung auffängt. Wenn 
du die linke Seite von R3 mit Signalmasse verbindest, müßte der Brumm am 
Ausgang des OPamp verschwinden. Abhilfe: Einen geeigneten Widerstand von 
der linken Seite von R3 nach Masse schalten, je nachdem, was dein Sensor 
zuläßt, vielleicht 10...100kOhm.

Kai Klaas

Autor: Grobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke Kai, den Widerstand vor R3 werd ich mal ausprobieren.
Hatte irgendwo auch was gelesen das durch unterschiedliche impendanz? 
des In+ und In- Signals ein Strom im opamp ensteht der eine offset 
Spannung erzeugt, aber das sollte eigentlich durch den 10k R3 nach der 
Rechnung (R1*R2) / (R1+R2) behoben werden, aber für all das keine 
gewähr.

Grobi

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Grobi,

>Hatte irgendwo auch was gelesen das durch unterschiedliche impendanz?
>des In+ und In- Signals ein Strom im opamp ensteht der eine offset
>Spannung erzeugt, aber das sollte eigentlich durch den 10k R3 nach der
>Rechnung (R1*R2) / (R1+R2) behoben werden, aber für all das keine
>gewähr.

Was du meinst, ist wahrscheinlich die Eingangsruhestrom-Kompensation?
Das funktiioert so: Die Eingangsruheströme eines OPamp, die über die 
Beschaltungswiderstände fließen, erzeugen dort Spannungsabfälle, die 
eine zusätzliche Offsetspannung bewirken können. Deswegen wählt man die 
Widerstände so, wie du es gesagt hast. Diese Maßnahme wird aber 
praktisch nur bei bipolaren Opamp verwendet, bei denen die 
Eingangsruheströme ganz enorm sein können. Bei dem CA3140 sind die 
Eingangsströme aber so gering, daß eine solche Kompensation nicht von 
Nöten ist.

Übrigens, der zusätzlich empfohlene Widerstand links von R3 wird vom 
Ausgangswiderstand des "Sensors" sowieso kurzgeschlossen, wenn er 
angeschlossen ist. Was ist denn dein "Sensor"?

Kai Klaas

Autor: Grobi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
... der "Sensor" ist eine Ultraschallkapsel mit nem nachgeschaltetem 
ca3140 als invertierender Verstärker der das signal um faktor 100 
verstärkt (R1 = 1K, R2 = 100K) und durch ne diode dann nur den positiven 
anteil rausgibt, daher kommen die 1,nochwas Volt. Leider bringt ein 
höherer R2 in der empfängerschaltung keine weitere Verstärkung, hab nen 
390k ausprobiert und Signal bleibt bei den 1,nochwas Volt.

Grobi

Autor: Christian Funke (funke)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du mit nem Oszilloskop oder mit nem Multimeter gemessen?

Autor: Grobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Multimeter, besitze leider kein oszi und diese 
soundkarten-software-oszis wollen mit meiner soundkarte nich.

Grobi

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> US_empf_nger.jpg


DIE Schaltung kann nun aber ohne negative Versorgungsspannung niemals 
funktionieren.

Wie kommt ihr immer auf solchen hirnrissigen Quatsch?
Gerade bei der Diode sollte doch mal irgendeinem Trottel auffallen, wo 
denn die nagativen Volts überhaupt herkommen sollen, die sie dann nach 
GND ableiten soll.

Leute, KAUFT doch mal ein Elektronik-Grundlagenbuch (Hohe Schule der 
Elektronik?), ist das denn so schwer ?


Und eine Verstärkung um 100 bei zumindest 40kHz ereicht schon die GBW 
von des CA3140, ist also auch gnadenlos grob überzogener Einsatz des 
OpAmps. Kein Wunder, daß mehr nicht mehr bringt. RECHNET eigentlich bei 
euch nie jemand nach? Ist nachrechnen aus der Mode in der 
Nintendogeneration?

Autor: Beckenbauer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Trottel hin oder her, die Schaltung wirkt praktisch als 
Halbwellengleichrichter. Und Störungen werden dann mit dem Multimeter 
als Gleichspannung fehlgedeutet. "Des ist doch ganz klaaaarr!"

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> und durch ne diode dann nur den positiven
> anteil rausgibt, daher kommen die 1,nochwas Volt.
Warum muss nur jeder versuchen, das Rad selber neu zu erfinden?
Stell dir doch zu Anfang die Frage: Wie machen das andere?

Koppeln die eine US-Kapsel auch so abartig niederohmig (1k) an?

Reicht das "Gain Bandwidth Product" dieses Opamps überhaupt aus?

Das mit der Diode ist, wie wenn du einen Porsche nimmst, und dann sagst: 
Huch, das ist mir zu schnell, ich zieh die Handbremse an  :-/

> ... die Schaltung wirkt praktisch als Halbwellengleichrichter.
Der OpAmp kann am Ausgang keine negative Rail und damit auch keine 0V 
ausgeben. Irgendwie hat MaWin schon Recht...

Autor: Beckenbauer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>> ... die Schaltung wirkt praktisch als Halbwellengleichrichter.
>Der OpAmp kann am Ausgang keine negative Rail und damit auch keine 0V
>ausgeben. Irgendwie hat MaWin schon Recht...
Ja und? Ist's dann kein Halbwellengleichrichter? Oder geilen Dich jetzt 
die paar mV an, an die der Opamp ran kommt, aber eben nicht NULL VOLT? 
Sag' was und red' nicht so viel!

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Mawin,

>Gerade bei der Diode sollte doch mal irgendeinem Trottel auffallen, wo
>denn die nagativen Volts überhaupt herkommen sollen, die sie dann nach
>GND ableiten soll.

Naja, wenn es sich um einen Piezo handelt, dann können da schon negative 
Spannungen am Ausgang erscheinen...

>Und eine Verstärkung um 100 bei zumindest 40kHz ereicht schon die GBW
>von des CA3140, ist also auch gnadenlos grob überzogener Einsatz des
>OpAmps. Kein Wunder, daß mehr nicht mehr bringt. RECHNET eigentlich bei
>euch nie jemand nach? Ist nachrechnen aus der Mode in der
>Nintendogeneration?

Warum regst du dich denn so auf? Ist doch ganz klar, daß Grobi ein 
blutiger Anfänger ist. Was soll ein Anfänger denn rechnen? Der 
experimentiert und sammelt Erfahrungen. Er macht genau das, was man 
"Lernen" nennt.

Laß ihn doch einfach. Gib ihm ein paar Tipps, aber bezeichne ihn nicht 
als Trottel. Das hat er sicher nicht verdient. Er hat es als Anfänger 
schon schwer genug.

Kopf hoch, Grobi!

Kai Klaas

Autor: Grobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
..also die schaltung stammt teilweise aus 
http://user.cs.tu-berlin.de/~dragoon/upload/Entfer... 
Seite 20
ohne den dort vorhandenen schmitt trigger, spannungsteiler und die 
entkopplung also sooo an den haaren herbeigezogen kann sie ja wohl nicht 
sein.
Na klar bin ich ein anfänger, sonst würd ich ja nich so viele dumme 
fragen stellen ;-) aber wenn man sich mal die beispiel schaltungen, die 
es zu opamps invertierend, nicht invertierender verstärker im internet 
gibt anguckt, sehen die eigentlich genauso aus wie meine.
Also im prinzip erzeuge ich ja mit dem empfänger eine positive 
sinusförmige spannung, wieso funktioniert das dabei aber nicht in der 2. 
verstärkerstufe? Die müsste doch einfach nur die positive sinusspannung 
verstärken, genauso wie es die erste stufe macht.
Das konnte irgendwie noch keiner richtig erklären.
Oder liegts wirklich am multimeter?
Ich werde den ausgang einfach mal an den adc eines anderen avrs hängen 
und schauen was er misst.

Grobi

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Grobi,

>Na klar bin ich ein anfänger, sonst würd ich ja nich so viele dumme
>fragen stellen ;-) aber wenn man sich mal die beispiel schaltungen, die
>es zu opamps invertierend, nicht invertierender verstärker im internet
>gibt anguckt, sehen die eigentlich genauso aus wie meine.

Schau auf Seite 51 von deinem Link, dann wirst du sehen, daß dort eine 
+15V/-15V-Spannungsversorgung für die OPamps verwendet wird! Du 
versuchst das mit einer +5V/0V-Spannungsversorgung, was so nicht 
funktionieren wird.

Kai Klaas

Autor: Grobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oh mist, du hast recht, das hab ich irgendwie übersehen, dachte die 
+-15V wären nur für den schmidttrigger aber das ist ja alles 1 ic dieser 
TL084N.
Aaargggh!!!! Ok dann geh ich mir mal n eimer -5V besorgen.
Danke!!!!

Grobi

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> dann geh ich mir mal n eimer -5V besorgen.

Lieber eine besser dem Problem angemessene Schaltung,
den die in deinem DOC ist wie von Laien für Laien
und taugt nicht viel.
Man richtet nicht gleich, in dem man den Ausgang in die Strombegrenzung 
treibt durch Kurzschluss.
Man verstärkt nicht alle Freqzenzen (und damit das Rauschen und 
Brummen)gleich, wenn man eine US-Signal haben will.
Man braucht nicht 4 OpAmps um den Sendeimpuls zu erzeugen.

Such dir eine neue Schaltung.

Autor: Grobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja mach ich auch, mein letzter versuch mit -5V anstatt gnd an den ca3140 
anzulegen endet damit das ich durchgehend 3V am ausgang habe, also funzt 
noch weniger als vorher.

Grobi

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Grobi,

>ja mach ich auch, mein letzter versuch mit -5V anstatt gnd an den ca3140
>anzulegen endet damit das ich durchgehend 3V am ausgang habe, also funzt
>noch weniger als vorher.

In dieser Schaltung

http://www.mikrocontroller.net/attachment/57335/US...

nur Pin 4 von CA3140 an -5V legen! Pin 3 und der untere Anschluß vom 
US-Empfänger bleiben an Masse! Dann solltest du wenigstens ein Signal 
sehen, obwohl die Schaltung eher unpraktisch ist. Hänge auch diese 
dämliche Diode am Ausgang ab, die macht nun überhaupt keinen Sinn!

Kai Klaas

Autor: Beckenbauer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Man könnte aber auch empfehlen, dass er seinen Pin 3 über einen 
Spannungsteiler + Kondensator auf halbe Versorgungsspannung hängen soll. 
Muss man aber nicht.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.