mikrocontroller.net

Forum: Platinen Eagle: Value-Wert ;-) definieren


Autor: Sebastian Wille (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich habe mir in der Eagle-Bibliothek ein neues Bauteil, einen
SMD-Kondensator, definiert.

Im Symbol habe ich ">NAME" definiert, da kommt mit dem Prefix "C"
jetzt immer im Schaltplan "C1", "C2" usw., also alles bestens.

Dann habe ich noch ">VALUE" definiert und im Device Value auf ON
gestellt. Nun hätte ich gerne, daß da im Schaltplan immer automatisch
"1µ" für ">VALUE" dasteht. Aber es kommt immer garnichts für
">VALUE". Wo kann ich da meinen Text eintragen?!?

Vielen Dank!

Sebastian

Autor: Bernd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Value" ENTER, Bauteil anklicken Wert, eintragen ...

mfg
Bernd

Autor: Sebastian Wille (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Bernd,

geht zwar im Bibliothek-Edits bei Device, gilt aber nur für ON oder OFF
nicht aber für z.B. "1µ".

Value 1µ oder so geht auch nicht!

In der Hilfe steht, man kann den Wert nur bei Symbol definieren, da
geht aber wiederum VALUE --> Enter nicht!

Wie könnte es noch gehen?

Danke!

Sebastian

Autor: Manfred Glahe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Sebastian Wille,

es ist auch nicht sinnvoll in der *.LBR schon einen Wert einzutragen
(sondern nur einen Platzhalter vorzusehen) denn der wird (außer es sind
gerademal 1µF) ja doch noch geändert.
Wenn dort aber schon ein Wert eingetrage ist, so kann im  *SCH leicht
das Ändern vergessen werden. Ein C ohne einen Kapazitätseintrag dagen
ist nicht so schnell zu übersehen.

MfG  Manfred Glahe

Autor: Sebastian Wille (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Manfred,

OK, da hast Du natürlich recht.

Aber trotzdem: Wenn Du einen Kondensator aus rc1.lbr nimmst, hat der
immer schon 1µF dranstehen. Ob das nun gut ist oder nicht - irgendwie
muß das doch zu schaffen sein?!?

Wo genau kann ich einen Platzhalter plazieren?

Danke!

Sebastian

Autor: Arnd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn du beim Device den Value = off stellst, wird der Wert auf jedenfall
 mit übernommen. Ansonsten mußt du in der .eaglerc (die im Verzeichnis
C:\Eigene Dateien bzw. im Homeverzeichnis liegt) einen Wert der
irgendwie (hab gerade hier kein Eagle installiert) SCH...VALUE = 0 auf
1 setzen. EInfach mal die Datei durchsuchen. wenn der Wert auf 1 ist,
wird immer der Valuename im Schaltplan übernommen.

Ich habe übrigens in einer Lib alle Widerstandswerte definiert, und muß
jetzt nicht immer überlegen, welche Werte ich benutzen kann.

MFG Arnd

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.