mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Flip Flop Frage


Autor: tpgw (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich habe eine Frage zu nem Flip Flop.
Und zwar hab ich die Schaltung im Anhang nachgebaut und jetzt habe ich 
das Problem, dass die Schaltung nicht ganz funktionieren will.

Gedacht ist, dass der ganz linke Transistor einen Abnehmer betreibt, bis 
über den 10k Widerstand kurzzeitig +12V anliegen. Dann sollte der 
Abnehmer keinen Strom bekommenm bis die Betriebsspannung resetet wird.

Ich hoffe hier kann mir jemand helfen.

g
t

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> dass die Schaltung nicht ganz funktionieren will.
Und was will nicht ganz funktionieren?

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ich hoffe hier kann mir jemand helfen.

Sicher.

Aber wo liegt dein Problem mit der Schaltung.

Gruss Helmi

Autor: tpgw (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zunächst liegt Spannung am Emitter des Transistors ganz links an, wenn 
ich aber die 12V an den 10k Wiederstand anlege, dann kippt die Stufe 
nicht, es liegt also immer noch Spannung an.

g
t

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie sieht denn dein Aufbau aus? Lochraster, Steckbrett?
Sind die Transistoren richtig eingebaut?

> es liegt also immer noch Spannung an.
Wo liegt dann welche Spannung an?
Wenn du die 10V an den Widerstand R6 anlegst, müssen am Kollektor von Q1 
0V sein. Tut sich da was?

Autor: tpgw (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Das ganze ist auf Lochraster gebaut.
Wenn ich die 10V anlege, dann ist der Kollektor in der Tat bei 0V.
Kann es sein, dass der Kondensator mit 1uF ein bisschen zu groß ist?

g
t

Autor: Klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Forum: Analogelektronik und Schaltungstechnik
> Flip Flop Frage

Hat schon mal jemand ein analoges Flop Flop gesehen?

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Wenn ich die 10V anlege, dann ist der Kollektor in der Tat bei 0V.
Hast du auf deiner 12V-Versorgung einen Rippel?
Dann würde der Q2 über den Kondensator sofort wieder umgeschaltet.

> Hat schon mal jemand ein analoges Flop Flop gesehen?
Im tiefsten Inneren ist alles analog :-o

Autor: Peter R. (pnu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann überlege mal die Funktion in Einzelschritten.

Zuerst die Schaltung ohne R5/C1 und D1,C6:
Q1 und Q2 bilden ein Flip Flop, bei dem Q1 oder Q2 leiten kann.

R5/C1 sind nur nach dem Einschalten wirksam, sorgen dafür, dass beim 
Einschalten Q2 leitend wird (Vorzugsstellung des FF).

Solange R5/C1 aktiv ist, kann Q1 leitend gemacht werden, durch R6/D1, 
ohne dass Q2 leitend wird. (Das FF hat sozusagen eine Sperrzeit, in dem 
es nicht kippen kann).

Nach dieser Sperrrzeit ist ein Kippen des FF möglich, ausgelöst über 
D1/R6 .(Das FF kann aus der Vorzugsstellung weggekippt werden)

ein Rückkippen ist nur durch Ein/Ausschalten der Betriebsspannung 
möglich.

Welcher dieser eingeklammerten Vorgänge geht nun nicht??

Dann kann man Weiteres überlegen.

Autor: tpgw (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Also, Ich hab jetzt mal den 1uf gegen einen 470nF ausgetauscht, keine 
Besserung.

Dann hab ich die Spannungsquelle durch eine ersetzt, die auch wirklich 
12V bringt, auch nichts passiert.

Zum Schluss hab ich noch an den Transistor einen 1k R und ein LED 
drangehängt, damit ich auch sehen kann, wann Spannung anliegt. Sobald 
ich die Stromversorgung einschalte leuchtet die LED und schaltet auch 
nicht aus, wenn ich Spannung an R6 anlege. Nur einmal ist die LED 
ausgegangen, nämlich als ich 12V an die Basis von Q1 angelegt habe:)

Hat vllt. jemand ungefähre Spannungswerte die bei 12V an den versch. 
Transistorausgängen anliegen sollte?

g
t

Autor: Peter R. (pnu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...an den Transistor.. (Welchen ????)

Wenn Spannung an R6 angelegt wird, und die Wartezeit durch C1,R5 vorbei 
ist, muss diese Spannung Q1 leitend machen und Q2 sperren.
Da aber über R4 ein Strom fließt, der Q3 offen hält, leuchtet die an Q3 
hängende Diode weiterhin. (Q2 sperrt zwar, aber ihm liegt R4 parallel)

Mach mal R4 größer, er muss so groß sein, dass die Spannung am Teiler 
R4/R1 so klein wird, dass Q3 sperrt.

oder anders: die Schaltung wird erst bei etwa 5V so arbeiten, wie man 
sich es vorstellt, erst wenn R4 etwa 56kOhm überschreitet, wird die 
Schaltung auch bei 12V richtig arbeiten

Autor: tpgw (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Ich verneige mich vor dem Meister:)
Großes Danke!
Ich hab den Widerstand auf 100k erhäht, und jetzt geht die Sache!!


g
t

Autor: Peter R. (pnu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nochmals ein Hinweis:
An die Basis von Q2 sollte noch eine "Angstdiode" geschaltet werden.
Beim Ausschalten der 12V kann es durch den aufgeladnene C1 zu negativer 
Spannung von bis zu 12V kommen. Eine Diode mit K an der Basis und A an 
der Masse verhindert das. Bei 5V Betriebsspannung, wofür die Schaltung 
ursprünglich ausgelegt war, ist diese Angstdiode nicht notwendig, da die 
BC üblicherweise bis zu 7V negative Spannung an der Basis vertragen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.