mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Schaltregler LM3150 - Schaltung funktioniert nicht.


Autor: Daniel B. (scheinleistung)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

Ich möchte über den LM3150 Simple Switcher 
(http://www.farnell.com/datasheets/84978.pdf) eine Spannung von 6-9V auf 
4,2V regeln. Ich habe die Schaltung sorgfältig nach dem Datenblatt 
durchgerechnet und entworfen, muss jetzt aber beim ersten Test 
enttäuscht feststellen das gar nichts funktioniert. Die Ausgangsspannung 
ist lediglich 0,1V (mit dem Multimeter gemessen) und die Stromaufnahme 
ohne dass überhaupt eine Last dranhängt beträgt 100mA.

Anbei mein Aufbau, hat jemand eine Idee woran das ganze scheitert? Ich 
bin momentan ratlos, habe aber auch kein Oszi um das ganze 
durchzutesten.

Werte:

Uin = 6 bis 9VV
Uout = 4,2V
Iout = bis 7A
fsw = 400kHz
L = 1,5uH
Cin = 10uF
Cout = 2x 220uF paralle mit je 100mOhm ESR


Top:
http://web155.mis06.de/top.jpg

Bottom:
http://web155.mis06.de/bottom.jpg

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ohne Schaltplan wirds wohl nichts mit Wirkleistung.

Autor: Daniel B. (scheinleistung)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe direkt das Board gezeichnet nach dem Schaltplan aus dem 
Datenblatt, siehe Anhang, und den berechneten Werten.

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
da auf dem Bord nicht nur der Regler sitzt:
reduzier das Board schrittweise rückwärts bis zum nackigen Regler.

Autor: Daniel B. (scheinleistung)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
@gast:
Das Board ist nackig bis auf den LM3150 und seine Komponenten! Es sitzt 
also nur der Schaltregler darauf. Vom Rest weis ich dass es 
funktioniert!

Anbei die Beschaltung mit den Werten!

Warum wird hier eigentlich zwischen PGND und SGND unterschieden? Ich 
habe beide mit GND verbunden...

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ohne auf das Datenblatt geachtet zu haben,

> Das Board ist nackig bis auf den LM3150 und seine Komponenten!

Grundlast?

Autor: frankman (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Enable Pin offen???

Autor: Daniel B. (scheinleistung)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ frankman
Enable ist offen ja! und wenn man ihn auf gnd zieht schaltet er komplett 
ab, das funktioniert also.

@gast
Was ist eine Grundlast?

Autor: frankman (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1,5yH ist schon recht knapp
Bei 30% ripple würd ich 2yH nehmen! (Würth WE Inductor Selector)

Meinst Du, das Deine C´s ausreichend sind? evtl. mehrere keramische C´s 
in Reihe?

Vielleicht hast du die Feedback-Widerstände falsch bestückt? Checken!

Autor: Daniel B. (scheinleistung)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@frankman
Die Induktivität sollte laut datenblatt hier ausreichen ich werde aber 
eine größere testen. Ich check mal die Feedbackwiderstände.

Autor: Daniel B. (scheinleistung)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@frankman
Feedback widerstände und auch alle anderen sind okay. Was sonst könnte 
verursachen dass hinten fast GAR nichts herauskommt??

Autor: BMK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm, beim rechten MOSFET sieht das auf dem Bild so aus,
als wären PINS 1-4 miteinander verbunden, was aber nicht
sein darf, da PIN 4 das Gate ist. Optische Täuschung ?

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>  Optische Täuschung ?
Nö, da sitzt ne schöne Lötzinnbrücke.

Autor: Daniel B. (scheinleistung)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja das war eine Brücke... Hab sie nicht gesehen ohne Lupe. Jetzt scheint 
auf den ersten Blick alles zu funktionieren. Vielen Dank!

Autor: LM3150fan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...wobei ich die Eingangskapazität (speziell bei geplanten 7A 
Ausgangsstrom) auch für reichlich klein halte. EMV/CE musst Du nicht 
prüfen/einhalten? Könnte bei den leitungsgebundenen Aussendungen bei dem 
Ripple von 3,5A schöne Probleme geben!

Und Du bist Dir sicher, dass das mit 7A und SO8-FETs hinhaut? Kommt 
natürlich darauf an, was man für Sperrschichttemperaturen in Kauf nehmen 
kann/will. Ich habe bei meinen Stromversorgungen mit dem 3150er DPAKs 
mit diesen hübschen SMD-Kühlkörpern von Fischer vorgesehen, aber die 
Schaltung befindet sich auch in einem hermetisch geschlossenen Gehäuse 
und ich muss wg. der Nachbarschaft zu einem LCD auf die 
Oberflächentemperaturen achten...

Autor: LM3150fan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...wo ist überhaupt Dein 10µ Eingangskondensator? Der gehört doch direkt 
an die Mosfets!

Autor: Daniel B. (scheinleistung)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@LM3150fan
Also laut Datenblattformel kam ich auf 10uF Cin, habe mir aber auch 
schon überlegt das noch zu erhöhen. Der tatsächliche mex. Strom liegt 
zwar in der Praxis nicht bei 7A sondern max 5A aber sicher ist sicher.

Die FETs sollten die 5A maximalen Strom abkönnen, sind angegeben mit 11A 
Dauerlast, rdson sind 11mOhm und im ersten Praxistest gestern bei 3A 
Last erwärmte sich nichts (okay es waren 27°C Gehäusetemp.)

Musst Du den LM3150 wirklich kühlen? Bei 3A Last erwärmt er sich bei mir 
überhaupt nicht und ich glaube nicht dass sich da bei 5A noch viel 
ändert...

Autor: LM3150fan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...den LM muss man normalerweise nicht kühlen (ausser man hat FETs mit 
extremer Gatekapazität, aber daan heizen auch eher die FETs wegen der 
langsamen Schaltflanken. Deine FETs im SO8-Gehäuse haben einen ziemlich 
hohen Wärmewiderstand, daher bin ich skeptisch wie das bei 7A aussieht, 
aber wenn Du gar keine 7A hast...
(Bis 5A solltest Du Dir vielleicht auch mal den TPS5450 von TI ansehen, 
es sei denn Du bestehst auf den FET an Stelle der Freilaufdiode.)

Wundere Dich nicht, wenn bei höheren Strömen die Spule das heißeste Teil 
in der Schaltung wird: die HCAs mit ihrer Flach-Cu-Wicklung sind zwar 
sehr gut, aber bei mir erreichen die trotzdem um die 70° (genau wie die 
FETs ohne Kühlkörper - bei mir übrigens IRFR1018EPBF mit 7-8mOhm).

Autor: Daniel B. (scheinleistung)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@LM3150fan

Danke für den Erfahrungsaustausch! Hier mein aktueller Stand (ich 
arbeite mich langsam hoch ;-)) Bei 4A Last erhitzt sich die Spule auf 
42°C. Die Fets bleiben auch relativ "kalt" mit 37°C. Scheint also okay 
zu sein. Die Spannung ist super konstant. Die großen Masseflächen leiten 
die Wärme gut ab, die ganze Schaltung besteht aus einem Sandwich zweier 
Platinen zwischen denen 5mm Luft ist (deshalb die sehr flache Spule) das 
ganze ist also relativ luftig und die Schaltung befindet sich in einem 
"Masse-Sandwich".
Als letztes folgt noch der 5A Dauertest...

Wie dimensionierst Du denn Deinen Cin? Ich habe jetzt von 1x 10uF 
(Gehäuse 1210) auf 2x 10uF erhöht, im Datenblatt haben Sie auch das 
doppelte des berechneten Wertes genommen. Außerdem Spendieren die dann 
noch das 10-fache als Elko: also hier 100uF. Wie ist hier Deine 
Erfahrung?

Autor: Stefan Wimmer (wswbln)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
....sooo, jetzt wieder vom heimischen PC mit ordentlichem Login ;)

> Wie dimensionierst Du denn Deinen Cin?

...einfach nach Physik und Datenblatt plus Angst- und 
Sicherheitszuschläge:

Die Physik sagt in Deinem Fall mit dU = C * dI/dt umgestellt nach dU und 
mit I=3,5A (primärer Stromripple = halber Ausgangsstrom), max. 
dt=Ua/Ue*1/f = 1,75µs und C=10µF, dass Dein Spannungsripple schon ohne 
die Berücksichtigung des aus dem Kondensatordatenblatt zu entnehmenden 
ESRs bei gut 610mV liegen wird - 10% von Ue!. Das bedeutet dann auch, 
dass deine Schaltfrequenz und deren Harmonische ohne weitere 
Filtermassnahmen im Spektrum der leitungsgebundenen Aussendungen auf den 
Zuleitungen garaniert gut zu sehen sein wird. Je nach einzuhaltendem 
Grenzwert kann das viel "Freude" bereiten.

Autor: Daniel B. (scheinleistung)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aber nach dieser Formel würde der Rippel dann mit vergrößertem Cin (es 
sei laut Datenblatt z.B. optimal bei errechneten 10uF:  2x 10uF 
keramisch +100uF elko) nicht kleiner sondern noch größer oder verstehe 
ich da etwas falsch?!

Autor: Stefan Wimmer (wswbln)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ups, schau mal in eine Formelsammlung, dann siehst Du gleich meinen (von 
Dir richtig erkannten) Fehler!  ;)




















(dU und dI vertauscht - die Zahlen stimmen aber)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.