mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik USB-Gerät mit PIC 18F2550 (Nachbildung COM-Port) wird nach Neustart des PC nicht mehr erkannt


Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Tag,
ich habe ein USB-Gerät mit dem PIC 18F2550 entwickelt, das auf dem PC 
einen virtuellen COM-Port simuliert. Hierzu habe ich die usb_cdc.h des 
CCS-PIC-C-Compilers benutzt. Ein Exemplar der Schaltung funktioniert 
einwandfrei wie gewünscht, das zweite dagegen, welches an einem anderen 
PC betrieben wird, wird nach dem Abschalten und Neustarten des PCs nur 
noch als "unbekanntes Gerät" erkannt. Dem kann nur durch einen 
Hardware-Reset des PIC abgeholfen werden. Nach dem Reset erscheint das 
Gerät sofort als "USB-to-UART" (oder so ähnlich) im Gerätemanager und 
erfüllt die gewünschte Funktion. Als Treiber verwende ich den mit dem 
Compiler gelieferten "cdc_ntxp.inf".
Der Fehler tritt nur nach vollständigem Abschalten und Neustarten des 
PCs auf, also nur dann, wenn die USB-Spannung auf 0 V war. Nach einem 
Neustart ohne Abschalten tritt das Problem nicht auf.
Ich hoffe das Problem ist bekannt und jemand weiß eine Lösung. Danke.

Grüße
Michael

Autor: Guido Körber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hört sich nach einem Brown-Out Problem an, also dass der Controller 
nicht ganz stromlos wird und keinen ordentlichen Reset macht.

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
das war tatsächlich die Ursache. Danke.

Grüße
Michael

Autor: stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich glaube ich habe das gleiche Problem, da ich die Schaltung aber nur 
blind nachgebaut habe, habe ich nun keine Ahnung was ich verändern 
könnte.

Ich habe folgende Schaltung nachgebaut:
http://img1.bildupload.com/17f4bb08da9025d0d0c3e37...

Damit lässt sich der nand-Speicher der xbox360 auslesen.
Das funktioniert auch soweit, jedoch reagiert der "USB-Flasher" nach 
etwa einer halben Stunde nicht mehr. Ich muss ihn dann komplett für ca. 
1min trennen, dann geht er wieder.

Den Resonator habe ich gegen einen Quarz mit 12Mhz getauscht mit je 30n 
gegen gnd.

Ich würde mich über Hilfe sehr freuen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.