mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LED Pulsung mittels TTL Signal


Autor: xe yui (larsicom)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo alle zusammen,
ich habe an der Uni folgendes Problem: Wir haben ein Rechteck TTL-Signal 
max. 8 Hz und eine Pulsdauer von 15-100 µs. Damit soll dann ein 
LED-Array gepulst werden. Wir wissen schon, dass wir bis 40V mit den 
LED´s im Pulsbetrieb gehen können. Also Stomquelle dient ein regelbares 
Labornetzteil. Nun zu meinem Problem, da ich fast keine Ahnung von 
Mikroelektronik habe, bin ich etwas sehr mit dem Bau für die 
Pulssteuerung überfordert.
Mein bisheriger Aufbau sieht wiefolgt aus: TTL-Signal auf einen 100R 
Widerstand von dort auf einen BC 639 an B und die Stromquelle an C, 
sowie über einen 100K Widerstand an B und der Ausgang zum LED-Array an 
E. Den GND von TTL habe ich nirgends angeschlossen und die GND von der 
Stromquelle und LED-Array habe ich zusammengeschaltet (also kein GND hat 
direkten Kontakt zum Transitor). Getestet habe ich es mit einer LED lief 
problemlos eine Stunde bei 40V, 8 Hz und 15µs. Sobald ich aber mehr als 
eine LED anschließe leuchtet da nichts mehr.
ABER WIESO?
Hoffe es kann mir einer von euch helfen.

Vielen Dank schonmal im Voraus.

Grüße Lars

Autor: Andreas K. (derandi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zeichne doch erst mal nen Plan, ich lass mir ja auch nicht gerne aus nem 
Playboy vorlesen.

Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
--------------------o------- viele Volt
                    |
                    |
                   \|/
                   ---
                    |
                    |
                   \|/
                   ---
                    |
                  .....
                    |
                   \|/
                   ---
                    |
                  |/C                   U_TTL - 0,6V
TTL_Signal -------|    npn         RE= --------------
                  |\E                      I_LED
                    |
                    |
                   RE
                    |
--------------------o-------- GND

Autor: xe yui (larsicom)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Andreas, hallo Matthias,
ja iss verständlich, also anbei mal mein Schaltplanversuch.
Bezüglich der Formel würde dass bedeuten, dass ich einen 3R Widerstand 
benötigen würde ((5V-0,6V)/1,5A). Ist das realistisch?

Danke

Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>anbei mal mein Schaltplanversuch.

Deine Schaltung würde wahrscheinlich die LED grillen


>Bezüglich der Formel würde dass bedeuten, dass ich einen 3R Widerstand
>benötigen würde ((5V-0,6V)/1,5A). Ist das realistisch?

Wenn du 1,5A haben willst, dann ja. Bedenke allerdings, dass die 
Speisespannung (viele Volt) diesen Strom liefern muss! Da der gepulst 
ist, würde ich einen Elko mit vorsehen.
Das TTL-Signal muss in diesem Fall 1,5A/Stromverstärkung bereitstellen 
können! So PI mal Daumen, je nach Transistor, in der Größenordnung 20mA.
Weiterhin musst du die Verlustleistung beim Transistor beachten.


Ptot = { viele_Volt - UFluss_alle_LEDs - (5V-0,6V) + 0,6V/Stromv. } * 
I_LED

Autor: xe yui (larsicom)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ach so was Total vergessen hatte, also die Schaltung soll im 
eigentlichen Betrieb 72 LED´s versorgen, dabei sind 3 jeweils in Reihe 
geschalten und 24 Paare dann parallel. Das Teil insgesamt wird mit 1,5 A 
betrieben, daher sollte jede einzelne LED nicht mehr als 0,07A 
abbekommen.

> Deine Schaltung würde wahrscheinlich die LED grillen

Nein also die LED´s halten bei kurzen Pulsdauern die Spannung 40 V aus. 
Im Test haben wir eine mit 40 V betrieben läuft jetzt schon mehrere 
Stunden. Im eigentlichen Betrieb wird dann eine LED nur noch mit etwa 13 
V versorgt.

> Das TTL-Signal muss in diesem Fall 1,5A/Stromverstärkung bereitstellen
> können!

Ich glaube ich weiß jetzt wo der Fehler liegt. Wenn ich dich richtig 
verstehe, beziehen die LED´s bei meiner "Schaltung" irgen Strom von 
TTL-Signal. Die Versorgung soll aber über das Netzteil erfolgen...

ich deute das dann mal so, meine Schaltung ist Sch..ße

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.