mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Kondensator & Spannungswandler werden heiß


Autor: Thomas Burkhart (escamoteur)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich nehme gerade eine Platine meines Mischpultes in Betrieb. Nun habe 
ich das Problem, dass mein Spannungswandler IC4 für 12V auf +/-5V sowie 
der Kondensator C8 nach kurzer Zeit extrem heiß werden.

Die Stromversorgung liefert auch die +/-5V läuft aber im Moment noch 
ohne Last, kann das ein Problem sein. Auf dem 12V Eingang fließt ein 
Strom von 1mA wenn ich das richtig gemessen habe.

Irgend eine Idee woran das liegen könnte?

Gruß
Tom

Autor: MeinerEiner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auf dem Schaltplan ist jetzt leider nicht so gut sichtbar, welche Linien 
sich kreuzen bzw. direkt berühren...

Autor: Georg A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Erstmal wird das ein Messfehler sein. 12*0.001A=0.012W. Da kann 
eigentlich nichts fühlbar heiss werden... So spontan sehe ich auch 
keinen Grund dafür, dass gerade C8 heiss werden soll. Der hängt an 
beiden Seiten auf HF-technisch "kaltem" Potential (12V und über C12). 
Isser kaputt?

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das bezweifle ich mal, daß nur 1mA bei 12V fließen. Das sind nämlich nur 
12mW - davon wird nix heiß ...

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Thomas,

hast du gesehen, daß die beiden Induktivitäten auf einen gemeinsamen 
Kern gewickelt sind?

Hast du im Datenblatt das Kapitel über Latchup gelesen? Ich könnte mir 
vorstellen, daß du Latch-up hast und der Regler heiß wird, und C8 nur, 
weil er von diesem passiv aufgeheizt wird.

Kai Klaas

Autor: Harald Hermenau (mirona)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist es richtig, daß die Induktivitäten zwei einzelne BE sind?
Wenn ja, dann kann es nicht gehen. Wenn Du Dir die Applikationsschaltung 
genau anschaust, wirst Du sehen, daß da eine Induktivität mit ZWEI 
Wicklungen eingesetz wird.
Bei einzelnen Induktivitäten kann sich die erste nicht "entladen" und 
baut deshalb eine so große Spannung auf, die den IC und auch den 
Eingangskondensator "zerwärmen" kann (zu große Verluste infolge 
Überspannung!).

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> ich nehme gerade eine Platine meines Mischpultes in Betrieb.
Was ist C8 (Bauform/Spannungsfestigkeit/Material)?
Mach doch mal ein Bild von dem Regler...
Ineressant wäre auch das Layout...

Autor: Thomas Burkhart (escamoteur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich denke das mit den zwei Spulen erklärt schon das Problem, ich hab das 
diskret mit zwei Spulen aufgebaut, hab das nicht für wichtig gehalten.

Vielen Dank

Tom

Autor: Thomas Burkhart (escamoteur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Weiß von euch jemand, wo man solche Spulen bekommt?

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei welchem Distributor man die hier kaufen kann, weiß ich auf Anhieb 
auch nicht, aber von Colitronics gibt es SMD-Doppelspulen auf Ringkern, 
die hin und wieder für diesen Zweck empfohlen werden. Z.B. CTX10 / 
CTX20.

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag: Coiltronics gehört zu Cooper Bussmann. Vertrieb hierzulande 
z.B. Farnell, Digi-Key.
http://www.cooperbussmann.com/pdf/6658ecec-cca9-49...

Autor: Thomas Burkhart (escamoteur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dank Dir!

Autor: Fritz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die getrennten Spulen sind nicht das Problem, die Schaltung benötigt 
nicht zwingend gekoppelte. Die würde nur die Spannungsregelung der 
negativen Ausgangsspannung verbessern.

Autor: TrippleX (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hätte eine Frage dazu.
Für Schaltregler nehme ich gerne die Amidon Eisenpulver Kerne,
könnte man zum Beispiel solch einen Kern einfach doppelt Wickeln?
Würde mich jetzt mal Interessieren, ich kenne mich mit Spulen leider
nicht gut aus.

Autor: Thomas Burkhart (escamoteur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Fritz: Was ist denn dann das Problem?

Autor: Thomas Burkhart (escamoteur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab jetzt die Doppelspule für viel Geld bei Digi-Key bestellt.
Hoffe, dass das das Problem löst.
Gruß
Tom

Autor: Vermittler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> @Fritz: Was ist denn dann das Problem?

da du  dich ja weigerst die Fragen von

> Lothar Miller (lkmiller):
> Was ist C8 (Bauform/Spannungsfestigkeit/Material)?
> Mach doch mal ein Bild von dem Regler...
> Ineressant wäre auch das Layout...

zu beantworten, kann dir das keiner mit Sicherheit sagen.

Autor: Thomas Burkhart (escamoteur)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Also:

C8 ist der hier

http://www.reichelt.de/?;ACTION=3;LA=5000;GROUP=B3...

Layout? Das ganze ist derzeit auf ner Lochrasterplatine. Ungefähr wie im 
Anhang.

Was meint Ihr mit Bild von dem Regler?

Gruß
Tom

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Layout? Das ganze ist derzeit auf ner Lochrasterplatine.
> Ungefähr wie im Anhang.
Huch, Schluck  :-/
Lies mal: 
http://www.lothar-miller.de/s9y/categories/40-Layo...
Und kontrollier den Stromfluss in deiner Schaltung...

EDIT:
> Was meint Ihr mit Bild von dem Regler?
Ein Foto deines Lochrasteraufbaus...

Autor: Vermittler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Was meint Ihr mit Bild von dem Regler?

Lothar wollte damit wohl sehen, was für Bauteile (Bauform, Bauart) du 
genommen hast.
Aber ich denke das mit dem Bild hat sich erledigt...
Wenn du das so aufgebaut hast wie in dem angehängten Layout und dann 
noch auf Lochraster, ist es schon klar warum das nicht funktioniert.

Gerade bei Schaltreglern ist das Layout immens wichtig zur einwandfreien 
Funktion der Schaltung. Daneben natürlich auch die Auswahl der Bauteile 
z.B. Kondensatoren mit niedrigem ESR, Spulen die für 
Schaltregleranwendungen konzipiert sind usw.

Schade, in dem Datenblatt zu dem Regler ist kein Beispiellayout 
angegeben, aber schau dir doch mal andere Regler von Linear an, in den 
Datenblättern sind meistens Layoutbeispiele.

Autor: Thomas Burkhart (escamoteur)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hmmm,

Hab geradse noch mal nachgemessen, da fließen doch 290mA und das obwohl 
keine Last dranhängt. Keine Ahnung was ich das letzte Mal gemessen habe

Ja, ich weiß, dass das Layout wichtig ist, aber dass die Schaltung heiß 
wird, macht das denn Sinn?? Die Ausgangsspannung produziert er ja 
wunderbar.

Ist die Erklärung von Harald bezüglich der doppelt gewickelten Spule 
denn wirklich Unsinn??

Ich hab trotzdem mal zwei Bilder hier

Autor: Anselm 68 (anselm68)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Einen Schaltregler auf Lochraster finde ich mutig.
Und dann hast du die Bauteile auch schön ordentlich "gespreizt" verbaut.
Schaltregler erfordern ein spezielles Layout damit sie stabil laufen 
können.

Ratlos Anselm

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Anselm 68 schrieb:
> Einen Schaltregler auf Lochraster finde ich mutig.

Warum? Wenn man das Layout ordentlich macht sehe ich da kein Problem.

Bei diesem Aufbau sind die Bauteile allerdings alle etwas stark verteilt 
und die Leiterbahnen nicht wirklich optimal angeordnet.

Autor: Thomas Burkhart (escamoteur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ähm, aber kann dass zu dem Stromfluss und der Überhitzung führen??

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dein C8 wird vielleicht nur wegen der unmittelbaren Nähe zum IC 
mitgeheizt. Sonst kann ich mir nicht vorstellen, daß er selbstheizend 
ist.
Ansonsten vermute ich mal, daß die Induktivitäten in die Sättigung 
geraten. Die 100µH-Dinger, die Du da verbaut hast, sind möglicherweise 
noch nicht mal für 100mA spezifiziert.

Autor: Thomas Burkhart (escamoteur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sie Spulen sind die hier

http://www.reichelt.de/?;ACTION=3;LA=5000;GROUP=B5...

Bis 370mA

Und derzeit liegt ja gar keine Last dran. Was kann man dagegen tun, dass 
die Spulen in die Übersättigung gehen?

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn du irgendwelche Streuinduktivitäten hast, (und die hast du bei 
diesem Aufbau!) dann kann dies die Regelung durcheinander bringen, was 
wiederum die Spulen in die Sättigung treiben könnte.
Die Spule ist denke ich für 0,6A auch nicht ganz ausgelegt, da dürfte 
sie schon deutlich in der Sättigung sein.

Autor: Thomas Burkhart (escamoteur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie kommst Du jetzt auf 0,6A??

Wieso fließt da überhaupt Strom ohne dass ein Vebraucher dranhängt?

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die 0,6A sind die Strombegrenzung von dem IC. Um zunächst mal die 
Kondensatoren zu laden, dreht das IC vermutlich voll auf. Dann fließt 
dieser Strom.
Häng Ipgm mal an GND, dann begrenzt das IC bei etwa 0,34A.

Autor: Thomas Burkhart (escamoteur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und wieso zieht der dann weiter Strom, wenn die Kondesatoren schon 
geladen sind?

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Weil eventuell die Regelung durcheinander kommt und daher unter 
ungünstigen Bedingungen arbeitet (eventuell schwingt die Regelung auch, 
und arbeitet abwechselnd auf 100% (wo ein Großteil der Energie dann in 
den Spulen oder dem IC verheizt werden) oder auf 0%. Aber das sind nur 
Vermutungen.
Genaueres könnte man sagen wenn du mit einem Oszilloskop die Spannungen 
messen könntest.

Autor: Thomas Burkhart (escamoteur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm, Oszi hab ich leider nicht.

D.h. am besten auf die angegebenen Spulen warten und schauen obs dann 
geht.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, und die ganze Schaltung dann am besten neu aufbauen, nach den Regeln 
die auf der Seite von Lothar stehen.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Thomas,

ich möchte dich nochmal an den Latch-up erinnern. Bei einem so 
ungünstigen Layout mit undefinierten Überschwingern und Resonanzen 
könnte auch ein atypischer Latch-up in Frage kommen.

Ein anderer Grund für die Fehlfunktion kann die Abwesenheit einer Last 
sein! Bestimmte Switcher benötigen eine Grundlast, ohne die sie sich 
merkwürdig verhalten. Auch wenn das Datenblatt manchmal etwas anderes 
sagt.

Es könnte auch sein, daß der Regler schon geschrottet ist. Solche 
Schaltungen testest du am besten, indem du mehrere identische aufbaust. 
Sonst, weißt du nie, was der Grund für irgendein merkwürdiges Verhalten 
ist.

Kai Klaas

Autor: Georg A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Man könnte ja erstmal Pin 5 von der Schaltung trennen. Wenn dann kein 
Strom mehr fliesst, weiss man wenigstens, dass der Chip intern nicht 
kaputt ist.

Wenn man Pin 1 von Vout trennt und über einen Widerstand direkt an Vin 
hängt, sollte eigentlich auch kein Strom mehr fliessen, wenn der Chip 
noch richtig tickt.

Der Lochrasteraufbau hat leider überhaupt keinen vernünftigen 
GND-Zusammenhang. Da sieht wahrscheinlich jeder Pin was anderes. GND von 
C10, Pin 4, D3 und C11 sollte so eng/dick wie möglich miteinander 
verbunden sein.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.