mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Sensorschalter /Anfänger probleme .


Autor: X30Stormy (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo .
Leider komme ich nicht weiter .
Ich wollte mit dem schalter eigentlich nur den PC einschalten (5v).
Und auch eine smd led leiste (12v) einschalten . Nur fehlt mir die 
erfahrung mit den Bauteilen . Währe für jede hilfe Dankbar . Conrad 
bestellnummer :700344 . Was für ein relais muss ich nehmen und geht auch 
ein Optokoppler ?
Welche Wiederstände . Leichte Skizze fürn Anfänger währen gut .

Danke

Autor: Klaus O. (kelomat)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Du hast doch deine Skizze schon selbst hinzugefügt....

Zwischen +Ub und Gnd gibst du deine Versorgungsspannung drauf.
Am ausgang (N-Out) kommt das Schaltsignal raus. (Das ist dann GND 
Potenzial)

Das Relais wählst du nach der Versorgungsspannung und wenn du eines mit 
zwei oder mehr Kontakten nimmst, kannst du pro Kontakt natürlich 
verschiedene Spannungen schalten.

z.B. Kontakt 1 5V vom PC
Kontakt 2 12V von der Led leiste usw.

Autor: X30Stormy (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich 12v oder 5v Versorgungsspannung habe was für Wiederstände 
brauche ich ? Und dann habe ich ja auch noch eine Diode drin was brauch 
ich dort ?
Schon den Conrad leer gekauft und keine der Schaltungen geht . Ist ja 
nicht mein erster Lötversuch aber ich komme einfach nicht weiter .

Autor: Klaus O. (kelomat)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Laut Conrad: Mit seinem Stromverbrauch von  5 µA bei 4,75 - 7 V/DC ist 
er für Batterieanwendungen vorzüglich geeignet. Höhere 
Versorgungsspannungen sind mit einem Vorwiderstand RV bis zu 30 V 
möglich, wobei der Betriebsstrom auf 1 mA begrenzt werden sollte.

Daraus lese ich:
5V ohne Vorwiderstand möglich. Bei 12V brauchst du einen Vorwiderstand.

Die diode ist dann notwendig wenn du ein Relais direkt schalten willst. 
Die ist zum Schutz der elektronik, da sonst beim Abschalten des Relais 
hohe Spannungen auftreten und die Elektronik töten.

warum willst du eigentlich nen Optokoppler einbauen?
nimm doch ein Releais direkt, dann hast du deine LED-Leiste auch gleich 
vom PC potenzialfrei.

Autor: X30Stormy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mich wohl falsch ausgedrückt . Es sind zwei von einander 
getrennte Sachen . 1. Nur PC 2. LED Leiste für Schränke usw. Das klicken 
wäre ohne Relais weg . Beim PC währe es mir egal aber bei der LED ist es 
unschön da der Schalter in eine Schrankseite oder Tür intrigiert wird 
und für Kunden sein soll (bin Möbeltischler). Teste es jetzt nochmal mit 
5V ohne Widerstand . Danke für eure Geduld . Vielleicht mach ich mal ein 
Bild von der Steckplatine für ein besseres Verständnis .

Autor: Klaus O. (kelomat)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hier findest du auf seite 2 die Widerstandswerte für die Versorgung.
http://www2.produktinfo.conrad.com/datenblaetter/7...

um deine LED Leiste einzuschalten wirst du aber noch ein 
"Stromstossrelais" (oder was elektronisches mit gleicher funktion) 
brauchen.

Du hast da ja eigentlich nur einen Taster. Wenn du mit dem Finger 
drauftippst würde das ding dann Leuchten. Finger weg - Licht aus.
Für den PC ist das kein Problem, denn der wird normalerweise ja über 
Taster geschalten.

Autor: X30Stormy (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Geht das so ?

Autor: Klaus O. (kelomat)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja das geht!
Du musst nur den Rv drinnen lassen (12V)
Die Diode kannst du weglassen.
Das einzige was abzuklären wäre: Wieviel Strom nehmen die Leds auf und 
wieviel Strom kann dein Taster schalten.


ABER: Das ist ein Taster d.h. Ist der Finger weg - ist das Licht wieder 
aus.

Der Taster gibt nur solange strom, solange er betätigt wird.

Das problem könntest du mit einem FlipFlop IC und einem Transistor 
lösen.

Ein FlipFlop ändert seinen zustand bei jedem Impuls
Taster drücken -> FlipFlop ein
Taster nochmal drücken -> FlipFlop ist wieder aus

Der Transistor ist einfach nur um den (hohen) Strom der Leds zu schalten 
den der FlipFlop IC (warscheinlich) nicht schafft.

Gibt es dieses Teil nicht auch als Schalter?
wäre viel einfacher.

Autor: Klaus O. (kelomat)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab den Sensor als Schalter bei Conrad gefunden: Best. Nr. 700358

Dahinter einen Transistor und das ganze funzt!

Autor: X30Stormy (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Mit den Wiederstands werten habe ich verstanden . Bei 5v hat hat der 
einfache Aufbau nicht funktioniert . Ich teste dann noch mal 12v .
Kann ich den Schalter bei 5v zerstören wenn ich - und out vertausche ?
Irgendetwas habe ich übersehen .Bei dem Bild habe ich davor 12v auf 5v 
vieleicht liegt auch dort der Fehler .

Der Schalter war um die Hälfte billiger 11 € statt 25 € und mit den 
Mehraufwand währe ich immer noch billiger .

Autor: X30Stormy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe gerade gelesen (P-MOS -open-drain (max. 9V/1mA nur für 
Logikanwendungen) . Was sind bitte Logikanwendungen . Aber ich befürchte 
das Geld ist flöten gegangen .Das würde meine Probleme erklären .
Ich habe statt MTO.1 N-NR  einen P-NR gekauft . Wenn mir einer erklären 
kann was das ist könnte ich es vieleicht für spätere Projekte verwenden 
.

Autor: Klaus O. (kelomat)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Es gibt 2 Varianten:

P-Mos: Dein Susgang vom Schalter wird positiv
N-Mos: Dein Ausgang wird Negativ

Deine Steckbrett-Schaltung ist für N-Mos ausgelegt.

Deine Fehler in der Schaltung:

1. Wenn ich das auf dem Bild richtig gesehen habe, macht deine Diode 
einen Kurzschluss! Warum hast du die überhaupt drinnen?

2. Eine LED braucht IMMER einen Vorwiderstand.

Da du diese Schaltung mit der P-Mos variante gebaut hast, hast du 
warscheinlich glück gehabt und nichts getötet....

Wenn du mit 12V versorgungsspannung auf deinen Schalter ohne 
Vorwiderstand drauf bist könnte der tot sein?

Logikanwendungen:
http://de.wikipedia.org/wiki/Elektronik#Digitalelektronik
und: http://de.wikipedia.org/wiki/Elektronik#Logik_der_...

Autor: X30Stormy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich gebe zu das ich alles ausprobiert habe Leider geht mein Relais nicht 
auf das Steckbrett ! Also wenn ich dich richtig verstanden habe ist out 
bei mir positiv also muss ich auf das Relais minus geben und der 
Schalter gibt plus aus ohne diode bei 5V aufs Relais . Meine letzte 
Versuchsspannung war 7,5v.
Mach gleich einen test und ein Bild !

Autor: Klaus O. (kelomat)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Für eine LED im Ausgang brauchst du die Schutzdiode nicht!

Wenn du ein Relais ansteuern willst musst du die Diode drinnenlassen!
Die Schutzdiode wird in Sperr-richtung eingebaut. d.h.
am Relais + kommt der - der Diode und am Relais - der + der Diode

Autor: Klaus O. (kelomat)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Probier mal diese Schaltung

Autor: Klaus O. (kelomat)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Jetzt hab ich gerade gesehen: > P-MOS -open-drain (max. 9V/1mA nur für 
Logikanwendungen)
Das wird mit der Led auch nicht klappen

Das musst du dann so machen (siehe schaltplan)

Autor: X30Stormy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du bist mein Held ! Jetzt geht der schalter . Nun muss ich das noch mit 
dem Relais schaffen ! Und mich doch etwas mehr belesen . Ich will ja 12v 
schalten und das geht mit den P-Mos ja nicht. Den PC anschalten müsste 
ja klappen !

Autor: Klaus O. (kelomat)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welche Schaltung hast du jetzt gemacht?

Die 12V müssten ja genauso zu schalten sein.
Du musst nur einen Vorwiderstand RV (lt. Beschreibung) einbauen
Mit dem transistor schaltest du die Led-Leiste (für die brauchst du dann 
keinen externen Vorwiderstand die ist ja für 12V ausgelegt und hat den 
schon eingebaut....)

Wenn du ein Relais schalten willst, bitte nicht auf die Schutzdiode 
vergessen!

Autor: X30Stormy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Leider ist deine meldung dazwischen gerutscht .schaltung 1 geht 
Schaltung 2 kann ich nicht probieren fehlen mir Bauteile .

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.