mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Takttreiber mit Pegelschalter - Verwirrung!


Autor: Andreas (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo und guten Tag,

ich habe folgendes Problem in einer Schaltung (siehe Bild im Anhang).

Die Schaltung habe ich von einem Eval-Board übernommen. Dort ist sie für 
0V und 5V (TTL IN) ausgelegt. Dieses TTL Signal soll im Prinzip auf -9V 
(TTL HIGH) und +5V (TTL LOW) umgesetzt werden, sofern ich die Schaltung 
richtig interpretiere.

Nun habe ich blauäugiger Weise diese Schaltung auf meiner Platine 
übernommen, ohne zu berücksichtigen, dass ich keine TTL Pegel am EIngang 
habe sondern folgende:
LOW => -9V
MID => 0V
HIGH => +8,8V

Wenn ich nun meinen uC an diese Stufe anschließe (R16 bestückt), wird 
der doppelte OV sehr sehr heiß und die Schaltung zieht 50mA mehr Strom. 
Wenn ich den R16 wieder rausnehme, fließen 50mA weniger und der OV 
verrichtet brav seine Arbeit, nämlich generiert die Potentiale +5V und 
-9V, auf die das Signal umgesetzt werden soll. Dabei scheint es ersten 
Messungen nach egal zu sein, auf welchem Potential sich der EIngang 
befindet.

Ich habe die Wahl zwischen einem Eingangssignal (IN) zwischen 0V => 
8,8V, zwischen -9V => 0V, oder auch zwischen -9V => 8,8V.

Wie kann ich die Schaltung anpassen, damit sie das Eingangssignal 
(wahlweise bestehend aus den drei Eingangspotentialen) auf die von den 
OVs erzeugten Potentiale umsetzt?

Ich würde die Schaltung sehr gerne Simulieren, nur leider fehlt mir das 
passende Tool dazu, gibt es da etwas einfaches und schnelles, wo die 
üblichen Bauelemente wie Dioden, Schottkys und Kondensatoren, 
Widerstände schon als Modell hinterlegt sind?

Kann jemand den Grund erkennen, wieso die OVs bei bestücktem R16 so heiß 
werden?

Vielen Dank!!

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Wenn ich nun meinen uC an diese Stufe anschließe (R16 bestückt), wird
> der doppelte OV sehr sehr heiß und die Schaltung zieht 50mA mehr Strom.
Was ist am Ausgang angeschlossen?

> Ich würde die Schaltung sehr gerne Simulieren, nur leider fehlt mir das
> passende Tool dazu, gibt es da etwas einfaches und schnelles, wo die
> üblichen Bauelemente wie Dioden, Schottkys und Kondensatoren,
> Widerstände schon als Modell hinterlegt sind?
Nimm LTSpice, ein vollwertiger Spice-Simulator für lau...

Autor: Andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Am Ausgang ist aktuell noch ein Steckverbinder, der hängt also noch in 
der Luft. Es ist auch ein optionales Signal, was ich wahrscheinlich 
nicht brauche, dennoch möchte ich gerne, dass ich R16 bestücken kann, 
ohne dass mit mein uC in Flammen aufgeht :)

LTSpice schau ich mir mal an, hoffentlich komme ich damit schnell 
zurecht!

DANKE!!!

Autor: Andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat jemand noch eine Idee, wieso der OV so heiß wird? Über welchen Zweig 
wird er denn in dieser Schaltung dermaßen belastet, dass es soweit 
kommen kann?

Ich habe schon andere Pegelanpassungen dieser Form aufgebaut, allerdings 
mit einem PNP und einen NPN Transistor und dort funktioniert es 
tadellos...

Wäre für weitere Hinwiese wirklich dankbar :)

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Evtl. schwingt der OPAmp wegen der kapazitiven Last am Ausgang?
Mach mal die C81 und C90 raus...
Oder R25 und R39 wesentlich hochohmiger...

Autor: Andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann sollten doch eigentlich die beiden Ausgänge ständig zwischen +15V 
und -15V hin und her schwingen, oder?
Denn das machen sie nicht... die Ausgangsspannungen sind korrekt, wie 
sie sein sollen...

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Dann sollten doch eigentlich die beiden Ausgänge ständig zwischen +15V
> und -15V hin und her schwingen, oder?
Nicht unbedingt...
> Denn das machen sie nicht...
Vielleicht schaffen sie nicht ganz 30Vss, sondern nur z.B. 1Vss oder 
2Vss
> die Ausgangsspannungen sind korrekt, wie sie sein sollen...
Wie gemessen? Mit einem Oszi?

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
50mA? Kann nur sein, wenn R37 fehlt (direkte Verbindung)

Autor: Andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

du meinst wenn R37 fehlt und statt dessen eine Brück drin ist, könntest 
du dir die 50mA erklären?

Das Problem ist nur, dass ich alles unverändert lasse und nur R16 
bestücke oder weglasse und diese Veränderung allein den Unterschied 
macht. Wäre R37 eine Brück sollte das Fehlerbild doch dauerhaft 
auftreten, oder?

Die Ausgangsspannungen der beiden OVs habe ich mit einem Oszi gemessen.

DANKE für die Hilfe, ich werde wohl weiter forschen müssen, wo nun genau 
das Problem liegt.

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>macht. Wäre R37 eine Brück sollte das Fehlerbild doch dauerhaft
>auftreten, oder?

nee - dazu muß noch der Transistor durchschalten.

Überlege mal logisch: wenn man sich die Schaltung so anschaut, dann 
gibt's keinen legalen Strompfad, der 50mA erlauben würde (wenn Ausgang 
frei). Also gibt's nur zwei Möglichkeiten:

- die OPV's schwingen - wie hast Du das geprüft (Oszi wäre nötig, um das 
sicher feststellen zu können, und zwar direkt an den Ausgängen der 
OPV's)
- oder Du hast irgendwo eine Fehlbstückung, Brücke, oder sonst was

Übrigens schreibst Du:

>-9V, auf die das Signal umgesetzt werden soll. Dabei scheint es ersten
>Messungen nach egal zu sein, auf welchem Potential sich der EIngang
>befindet.

Aha - es ist egal, auf welchem Potential der Eingang ist, aber der R16 
bewirkt bewundernswerterweise etwas. Wie paßt das zusammen ???? R16 raus 
oder rein bewirkt doch auch eine Potentialänderung am Eingang, wenn der 
Eingangspin auf einem bestimmten Pegel hängt. Das sieht mir nach Pfusch 
am Bauaus.

Wenn Du statt R16 einen Strommesser reinhängst, fließt da ein 
signifikanter Strom?
Wenn Du über R25 bzw. R39 ein Voltmesser drüber hängst, siehts Du da 
eine signifikante Spannung.
(mit signifikant meine ich unerwartet hoch).

R37 trotzdem mal prüfen - hat der wirklich 100Ohm?

Übrigens - in der gezeigten Schaltung kannst Du bei -9V am Eingang 
lässig um die 30mA ziehen:
einmals über den Eingang, der nur 1k als R hat, und fast 14V Differenz 
sieht
Und andererseits zw. den OPV-Ausgängen, die ebenfalls 14V über 1k 
liefern, wenn der Q7 durchschaltet.
Und dazu noch Eigenstromverbrauch der OPV's und der Pannungsteiler 
machen zusätzlich run 5mA aus
Im ganzen könnte man also schonmal 35mA grob gerechnet erwarten, wenn Q7 
durchschaltet - nicht mehr weit von den 50mA

Autor: Andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für deine Hinweise.
Ich hab mir die Schaltung mit LTSpice mal angeschaut.
Wenn man das Ergebnis dann vor Augen hat, ist es ganz einfach, dass der 
R37 als Einziger den Strom über 14V begrenzt.

Ich habe es mal durchsimuliert und in jetztiger Konstellation bricht der 
Ausgang sogar auf 4,5V ein, weil der OV anscheinend nicht mehr genug 
Strom liefern kann und dadurch heiß wird. Ist zwar in der Realität noch 
nicht so, aber vielleicht isser nah dran.

Sobald als EIngangssignal -9V ins Spiel kommt, zieht die Schaltung 
erheblich mehr Strom. Also werde ich mein Eingangssignal wohl aus 0V und 
+9V zusammen setzen. Dazu vergrößere ich noch den R37 von 1K auf 10K um 
den Strom durch Q7 weiter zu begrenzen. In der Simulation sieht der 
Ausgang dann auch sauberer aus.

Morgen werde ich es dann umlöten und auch in der Realität testen und 
messen, ich hoffe das ist dann die richtige Lösung :)

Ich melde mich dann noch einmal mit dem finalen Ergebnis oder mit 
weiteren Fragen :)

DANKE !!!!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.