mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik quarz beim pic32 schwingt komisch


Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,

ich hab mal eine frage... ich habe eine platine mit dem pic 32 gemacht 
und diese funktioniert leider nicht...
wenn ich spannung anlege kann sich das pic kit 3 nicht connecten... 
daraufhin hab ich mal die spannungnen geprueft sieht gut aus an den pin 
3,3 v usw...
anschliessend hab ich mal mit nem osc den quarz geprueft... und dieser 
schwingt nicht richtig... eigentlich sollte es ja ein sinus sein... nur 
was ich zu sehen bekomme sieht aus wie entladekurve eines 
kondensators...
als quarz hab ich einen 8 mhz mit 22pf (33pf hab auch schon probiert)... 
quarz hab ich auch schon getauscht... sind auch keine kurzschluesse 
unter der lupe seh ich nichts... hab auch mal mit den durchgangspruefer 
gecheckt ob die pins verbunden sind...

hat jemand ne idee was das sein koennte ?... das layout bin ich mir 
sicher das das richtig ist... ich hab genau diese platine schon mal 
gebaut und da ging es... zudem ist das layout mein grund layout fuer den 
pic welches ich immer verwende... nur finde ich den fehler nicht...

bin fuer jeden tip dankbar ...

viele gruesse ;)

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> nur was ich zu sehen bekomme sieht aus wie entladekurve eines
> kondensators...
Welche Frequenz, das dürfte doch auch ein wenig interessieren?

> 22pf (33pf)
sind schon ziemlich an der oberen Grenze. Probiers doch mal ohne.

BTW:
Kontrollier mal deine Punkt-Taste. Die hängt offenbar  :-o

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
moin,

danke fuer die schnelle antwort...

ohne kondensatoren... keine änderung... die periode ist bei 0,2 ms genau 
ein strich breit auf dem osc... sprich das muesste 5khz ? hm ich hoffe 
hab richtig gemessen... ist noch recht frueh fuer mich... hab lang noch 
an der platine gesessen...

ja die punkte kommen von der muedigkeit... ;)

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du arbeitest nicht zufällig mit einem DSO?
Falls ja, dreht man an der Zeitbasis, du verletzt gerade das 
Samplingtheorem weshalb das dargestellte Bild merkwürdig aussieht.

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ne ist nen ganz "normales" und einfaches osc... kein dso..

so muss mal zur arbeit... arf ;)

Autor: Dieter Werner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und bitte unbedingt einen 10:1 Tastkopf benutzen, sonst kann der Quarz 
bis zum Abreissen der Schwinig bedämpft werden.

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok... momentan ist der tastkopf auf 1:1 gestellt. was ihn bei der 
anderen platine jedoch wenig beeindruckt hat. aber ich probiers spaeter 
in der mittagspause mal.

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
auch ein 1:10 tastkopf aendert nichts... mist...

noch jemand ne idee ?

Autor: .... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> ein 1:10 tastkopf ...

Der wäre noch schlechter geeignet als ein 1:1 Tastkopf....

Versuchs mal mit einem 10:1 Tastkopf..... ;) , aber bitte vorher 
abgleichen.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wie groß ist die Amplitude des Signals? (Teilerverhältnis des Tastkopfes 
berücksichtigen) und welche Frequenz hat das Signal?

Autor: Soeren A. (abraxa)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist der PIC in SMD-Bauform? Vielleicht ist an einem der Oszillator-Pins 
eine Bruecke. (Kann auch unter dem IC sein, was du mit Lupe nicht sehen 
kannst)

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
der durchgangspruefer meinte da waere nichts. ich hab gestern aufgegeben 
und den fehler nicht mehr gefunden.

ich hab gestern die gleiche platine nochmal gebaut. und weils mit 
interessiert hat gleichen quarz und kondensatoren (sprich abgeloetet) 
und auf die neue drauf... und ?

nun geht es.

ohne das ich am layout was geaendert habe. ist zwar etwas unberuehigend 
das ich nicht weiss was es war. vielleicht war doch irgendwo ne bruecke. 
ist ja manchmal nicht so einfach zu erkennen wenn alles smd ist... oder 
der pic32 hatte macke.

aber egal. alles ist schoen. danke nochmal fuer die anregungen.

lg ;)

Autor: Der verrückte Professor (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Deine '.'-Taste Prellt ja immernoch!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.