mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik dem Notebook einen Akku vorgaukeln


Autor: Hermy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe hier ein älteres HP Omnibook 4150B für Steuerungszwecke 
(stationär).

Problem: der Akku (HP F1466A) ist kaputt.
Und leider startet das Book nicht ohne funktionierenden Akku.

Habe den Akku also zerlegt, Erbebnis: die Zellen sind so weit ok, die 
Kontakte auch, es liegt wohl an der akku-internen Elektronik.

Frage: kann man ohne größeren Aufwand dem Notebook vorgaukeln, es wäre 
ein Akku angeschlossen? Vom Akku zum Book führen übrigens 7 Kontakte, 
ohne dass ich momentan näheres dazu sagen könnte. Vermute aber, dass da 
Daten per Mikrocontroller ausgetauscht werden.

Autor: Hermy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ps:
hier noch ein bild zur ansicht:

Ebay-Artikel Nr. 360190282357

Autor: Omega G. (omega) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kannst du ein Foto der Elektronik machen, da sieht man vielleicht mehr.

Bei meinem Samsung ist es nötig eine Leitung des Akkus mit GND über 
einen 30 kOhm Widerstand zu verbinden.

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>  kann man ohne größeren Aufwand dem Notebook vorgaukeln,
> es wäre ein Akku angeschlossen?

Nur, indem man die Funktion der Elektronik im Akkupaket nachbildet, was 
dadurch erschwert wird, daß die nicht dokumentiert ist.

Autor: Frank Esselbach (Firma: Q3) (qualidat)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ohne Unterlagen und ohne funktionierenden Akku zum Vergleich wird das 
schwierig. Kannst du evtl. ein Servicehandbuch zum Notebook beschaffen? 
Dort sollten sich evtl. aus der Benennung der Akku-Anschlüsse 
Rückschlüsse auf ihre Funktion ziehen lassen.

- Wenn es dir gelingt, die stromführenden Kontakte auszuklammern, würde 
ich es zunächst mit Brücken (Widerstand 1k?) nach Masse bzw 5V an den 
anderen Anschlüssen versuchen - vielleicht lässt sich das Interface im 
Notebook austricksen.

- wenn du herausbekommst, welcher Chip/Prozessor für die Kommunikation 
mit der Akku-Elektronik zu ständig ist, hilft das sicher auch

- theoretisch sollte sich das System auch per Software aushebeln lassen 
(BIOS?)

- Akkuzellen lasen sich durch Elkos ersetzen, aber die Elektronik ... ?

Frank

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Notebook sollte auch ohne Akku starten. Meine tun dies jedenfalls...

Autor: Michael X. (Firma: vyuxc) (der-michl)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Smart Battery Spec anschauen. So ein Ding hat mehrere Anschlüsse: Power, 
Ground, Smbus und Thermistor. Wenn Beispielsweise der Thermistor nicht 
will dann startet eben nix, weil das NB denkt es sei zu heiß. Forsch mal 
in die Richtung.

Autor: Hermy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
schon mal danke für die antworten!
hier habe ich noch was zum thema "eprom und omnibook" gefunden:
http://www.progforum.com/showthread.php?t=7609

dort steht unten:
<Bei meinem HP-Omnibook reicht es nicht die Akkus zu wechseln (habe es 
mal <probiert).
<Die Daten im EEPROM (auf der Akku-Platine) sorgen dafür,
<das der µC (auf der Akku-Platine) den Akku nicht aktiviert.
<
<Man kann (teuere) Software (aus Russland) kaufen, mit der man die Daten 
im <EEPROM manipulieren kann.


ein service-manual mit der bezeichnung OB4100-4150_sm.pdf kann man 
irgendwo runterladen, habe grade nicht die quelle zur hand.

fotos folgen...

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Früüüher hätte man die Sprungadresse geändert....
Heute fragt man eine SuchTmaschine nach einem Ersatzteil.

Autor: Mike J. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mach den Akku doch einfach auf, entferne die Zellen und leg die richtige 
Spannung (~12V) an die Drähte.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Mike, die 12V ersetzen wohl nicht die Antwort des Chips vom Akku-Pack.

Deshalb sollte man mit einigen Tricks und Drähten die Zellen so 
tauschen, daß der Chip es NICHT merkt. Ein neuer Akku wird aber bei 
Dauerbetrieb am Netz leider kein ewiges Leben haben.

Autor: Hermy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Mach den Akku doch einfach auf, entferne die Zellen und leg die richtige
>Spannung (~12V) an die Drähte.

hab ich schon, das bringt nix... schätze wirklich, dass die arbeitszeit 
im eeprom abgelaufen ist...

bin aber einen schritt weiter, dass das gerät nicht mehr funktioniert, 
muss eine andere ursache haben.

kurz gesagt, wenn man den stecker vom netzteil einschiebt, blinkt kurz 
die kontrolllampe (ca. 0,5s). vorher brannte sie ununterbrochen oder 
blinkte periodisch je nach akkuladung.
wenn sie in angeschlossenem zustand aus ist, heißt das, wie ich im 
handbuch gesehen habe "kein akku onboard" oder "akku defekt". daher 
meine erste vermutung.

hat noch jemand eine idee zum thema, woran das mit dem kurzen aufblinken 
liegen könnte???

ansonsten muß ich mich wohl mal nach einem neuen schleppi zum steuern 
umgucken...

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Manchmal macht ein kaputter Akku auch das Netzteil mit kaputt.
Es gibt aber noch viele andere Möglichkeiten. Geruch ? Bios? Elkos ...

Autor: Mike J. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> schätze wirklich, dass die arbeitszeit
> im eeprom abgelaufen ist...

Kann doch nicht sein dass man den Akku nach 500 mal aufladen wegwerfen 
muss, das ist ja wie bei diesen Druckerpatronen mit den Seitenzähl-chip.

Meinen Laptop betreibe ich immer ohne Akku.

Autor: Hermy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Kann doch nicht sein dass man den Akku nach 500 mal aufladen wegwerfen
>muss, das ist ja wie bei diesen Druckerpatronen mit den Seitenzähl-chip.
sieht wohl doch so aus...


>Manchmal macht ein kaputter Akku auch das Netzteil mit kaputt.
>Es gibt aber noch viele andere Möglichkeiten. Geruch ? Bios? Elkos ...

netzteil soll 19V und liefert angeschlossen 18,75V, schätze, das ist im 
rahmen.

geruch ist unauffällig, bios glaub ich eher nicht bei dem symptom, elkos 
in eingangsbuchsennähe sehen ok aus, aufgelötete sicherung ist ok...

Autor: Hermy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
weitere ideen, woran es liegen könnte, dass die betriebs-LED beim 
einstecken des netzteils kurz aufleuchtet und ansonsten keine weitere 
reaktion hervorgerufen wird?

Autor: Omega G. (omega) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Typischer Fehler bei Notebooks sind ausgebrannte MOSFETS in der 
stromversorgung.

Autor: Klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Lehrmann Michael (ubimbo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
lustiges spielchen - nur was hat das mit einer zerschossenen 
stromversorgung eines notebooks zu tun ? eine anregung zum neukauf ? xD

schönen abend

Autor: Hermy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Typischer Fehler bei Notebooks sind ausgebrannte MOSFETS in der
>stromversorgung.

hab das ding jetzt mal zerlegt. das mainboard ist ein wahrer 
irrgarten...

Autor: Hermy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
so, hab jetzt das mainboard auch von der unterseite her extrahiert ;)

da ist ein recht grosses, transistorähnliches gebilde in der nähe der 
netzteilbuchse, könnte ein mos-fet sein.

die aufschrift lautet:

N       OF
60QC04

(das Q könnte auch eine 0 oder eine 9 sein)


es ist quadratisch, mit der rückseite auf der platine festgelötet und 
hat drei anschlüsse.
Der mittlere anschluss ist mit der rückseitigen metallfläche verbunden.


Als anschluss-schema für dieses teil soll mal folgende skizze dienen:

------------
I          I
I          I
I          I
------------
A    B     C


beim ohmmässigen durchmessen fällt auf, dass die anschlüsse A und C in 
eingelötetem zustand einen kurzschluss (ca. 0,1 ohm ?!) haben, der 
widerstand zwischen A und B beträgt ca. 2,1 Kohm, aber nur in eine 
richtung (bei “diodenmessung” werden ca. 166mV vom multimeter 
angezeigt).

Was haltet ihr davon? könnte das teil durchgebrannt sein?

Autor: Hermy (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
so, noch mal gegoogelt, dieses 60QC04-Teil ist wohl eine Doppeldiode, 
bei der  die beiden Anoden verbunden sind, das erklärt wohl auch den 
gemessenen "Kurzschluss"...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.