mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Antenne RFM12


Autor: Bart (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe diese Frage schon in einem alten Thread gestellt, aber 
anscheinend werde so alte Threads nicht wieder hochgeholt dadurch, 
deswegen hier noch einmal die Frage: Ich habe die Funkbrücke von 
Benedikt K. nachgebaut, die hier im Forum zu finden ist. Die Übertragung 
funktioniert, leider aber nur auf recht kurze Entfernung, so ca. 2m, 
aber dann kann es schon dadruch gestärt werden wenn ich zwischen den 
beiden Platinen stehe.
Meine Antennen sind Koax-Kabel,
insgesamt 34cm lang, Isolierung aber bis zur Hälfte abgemacht, d.h.17cm
-> lambda/4. Der Innenleiter ist an das Funkmodul angeschlossen, die
Isolierung mit GND verbunden, passt das so? Baudrate ist übrigens glaube
20kBaud. Warum ist die Reichweite hier so gering??
Viele Grüße
Bart

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Versuchs mal mit einem 17cm Draht. Ich würde darauf tippen, dass dann 
die Reichweite auch nicht viel größer ist. Falls ja, dann liegt der 
Fehler wo anders.
Bei mir hat diese Antenne so wie du sie beschreibst eine Reichweite von 
ein paar 100m. Die Anpassung ist nicht ganz 100%ig ok, aber die 
automatische Anpassung der RFM12 scheint das gut zu kompensieren.

Autor: Bart (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Benedikt,
es ist mit dem 17cm Draht ungefähr gleich :( D.h. der Fehler muss 
woanders liegen. Ich lade im Anhang mal meinen Schaltplan hoch, aber da 
die Übertragung ja prinzipiell funktioniert dürfte das nicht der Fehler 
sein.

Autor: Bart (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Und das Layout.

Autor: Bart (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Das erstr .sch war die veraltete Version. Entschuldige bitte!

Autor: Pet (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du das BRD aus dem SCH gebaut?

Irgendwie stimmt da einiges nicht...

in der SCH fehlen massenweise Junctions.

Lasse mal den ERC laufen und beseitige erstmal die Fehler.

PS
man kann auch mehrere Dateien in ein Beitag anhängen...
Und Schaltpläne/Board nur als png.
Nicht jeder hat Eagle und somit kann nicht jeder helfen.

Autor: Bart (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gleichzeitiger Post... hab die richtige noch hochgeladen.

Autor: Bart (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lösung des Rätsels: Ich hatte beim Löten des Moduls einen von den 
kleinen SMD Widerständen erwischt und etwas verschoben, jetzt gehts!!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.