mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik BTM-222 Probleme bei niedriger Temperatur


Autor: Steve Bennet (stevensen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

seit 2 Monaten läuft meine Wetterstation (Versuchsaufbau auf 
Steckbrett)testweise mit einem BTM-222. Bisher gabs auch kaum Probleme 
(außer beim verdammten Luftdrucksensor). NAchdem die Temperaturen nun 
nachts um den 0 Grad schwanken krieg ich keine Verbindung mehr hin. 
Connecten kann ich von meinem Pc aus, wenn ich Daten vom Mega16 
anfordere schickt er auch was, allerdings alles in falschen Zeichen. Im 
laufe des Tages (bei Sonnenschein)funktioniert die Übertragung 
irgendwann. Die Daten schreibt der Mega16 in der Nacht in einen EEProm 
und sind ok. Also hat wohl der BTM-222 ein Temperaturproblem oder? Im 
Datenblatt steht was von -10 Grad C. Wie kann ich den BTM-222 quasi 
WInterfest kriegen? Muß ich tatsächlich einbeheiztes Gehäuse basteln? 
Ist das bei anderen Wetterstationen auch so?

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du hast doch sicher einen Baudratenquarz am ATMega, oder?!

Autor: Steve Bennet (stevensen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Travel Rec,

nee kannte ich so direkt nicht. Hab es sicher überlesen da ich noch 
keinen Bedarf hatte. Bisher liefen die mega auch so, hatte immer einen 
anderen Funk. "Krumme" Werte hatte ich bisher wegen besserer Teilungen 
für Timer-Interrupts. Welchen Wert bräuchte ich bei 19200 Baud? Der Mega 
läuft momentan mit glatt 8 Mhz. Nehm' ich da  7,372800MHz oder 
9,216000MHz oder ganz was anderes? Ein Problem vielleicht auch noch das 
ich Bascom benutzte.

Autor: Peter Roth (gelb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Steve Bennet (stevensen)

8MHz - Quarz ist ok. Laut Datenblatt 0,2% Fehler bei 19200 Baud.

Kannst du aussschließen, dass Betauung aufgetreten ist?

Ich muss mal meine BTM-222 - Kamera ins Freie stellen und schauen was 
passiert... aber erst noch abdichten.

Grüße, Peter

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Okay, der Quarz war´s nicht. Ich denke jedenfalls nicht, daß das BTM-222 
das Problem darstellt. Was hast Du denn sonst noch so in der Schaltung 
verbaut? Betauung ist natürlich eine Möglichkeit. In der Region um den 
Quarz herum kann ein Feuchtigkeitsfilm arg stören. Ist das BTM-222 
dauehaft in Betrieb oder nur sporadisch? Falls dauerhaft, kannst Du Dir 
die Heizung in der Wetterstation sparen ;-)

Autor: Steve Bennet (stevensen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey danke für die Antworten,

die Schaltung ist auf einem Steckbrett und in einem unbeheizten Raum 
hinter der Garage. Es gibt einen Mpx4100 Luftdrucksensor, einen SHT11, 2 
78er für 5 V und 3,3 V. Und ne RefernzSPannungs-Chip und einen OP. Der 
Sht11 hängt an einer kleinen Leitung ausm Fenster.
Ich habe auch zur Sicherheit den u2x auf 0 und den UDRR auf 25 gestellt, 
hat sich nicht geändert.
Heute waren es 10 C im Raum und keine Feuchtigkeit auf der Schaltung ( 
kein Tau z.B. auf dem BTM-222) und der Fehler war da.
Wenn ich Befehle über den BTM sende reagiert eigentlich richtig. Ich 
kann mir alle Daten schicken lassen aber anstatt:

*
016
010
009
021
015
010
123
035
222
003
101
000
000
000
000
... etc

kommt eine reihe ?CCCCCCCCCCCCCCCC?

Muß ich bei der Schaltung was verbessern pullup- oder pulldown- 
Widerständer an Rx und Tx oder mehr Kondensatorn?
Und wenn die Sonne in den Raum scheint gehts.

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Steckbrett temperatursensibel? Hast Du mal ´nen Plan von der ganzen 
Schaltung?

Autor: Steve Bennet (stevensen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es ist wohl das Steckbrett. Die Sonne scheint, es geht ... die Sonne ist 
weg schon gibts Probleme. Hab die drähte mal nachgedrückt dann gings ne 
Zeit. Werde wohl das ganze auf Lochkarte basteln, wollte es zwar erstmal 
vermeiden aber es hilft nix. Erstmal Danke ich melde mich wieder.

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aus dem Grund bin ich auch nie richtig warm geworden mit Bread Boards. 
Nach dem ersten ähnlichen Vorfall, der mich Tage Fehlersuche (als 
Anfänger wohlgemerkt) gekostet hat, habe ich die Dinger sofort verbannt.

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nur eine Lötstelle ist eine Lötstelle ;-)

Autor: Lexon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat jemand den bascom  code
für das BTM 222  Module.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.