mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Atmega8 LED-Grundschaltung


Autor: Martin M. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo ich bin absoluter Anfänger auf dem gebiet der MC´s und wollte eine 
simple LED-Schaltung bauen. Ich komme aber momentan nicht weiter, da ich 
glaube das meine Beschaltung für den Atmega8 nicht richtig ist.
Die Aufgabe sollte sein das die LED´s and Pin PD5 und PD6 leuchten. Mein 
aufgespieltes Programm funktioniert, ich hab es mit den Led´s des  Atmel 
Evalutionsboards getestet und hab deshalb auch die Pins PD5 und PD6 
beibehalten. Die Stpannungszufuhr liefert ein 12V Netzteil das dann auf 
5v runtet geregelt wird.
Da ich keine Beschaltung von einem Atmega8 bei Mc.net fand, googlete ich 
und entdeckte diese Seite 
http://www.kreatives-chaos.com/artikel/avr-grundschaltungen und diese 
Beschaltung http://www.kreatives-chaos.com/images/36.png
Es wäre echt super wenn mir jemand helfen könnte.

M.F.G. Martin

P.S. Entschuldigung falls die Skizze nicht so gut sein sollte, ist mein 
erster versuch gewesen

Autor: olol (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die LEDs müssen umgedreht werden, du verwendest diese in Sperrichtung...
Und der 100nF Kondensator muss dann Physikalisch direkt neben dem IC 
sein, falls du das aufgebaut hast.

Autor: Marcus Kunze (marcusk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du auch den Reset auf +5V gelegt, ich seh ihn irgendwie nicht?

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
die LEDs sind verkehrt

Autor: Stefan_KM (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Soweit ich das richtig sehe, sind deine LED in Sperrichtung gepolt und 
können nicht leuchten.

Willst du LED aktiv mit dem µC treiben oder willst du den Strom in den 
PORT PIN rein fließen lassen?

Autor: Vlad Tepesch (vlad_tepesch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1kOhm sind auch ein bisschen viel vor den LEDs. sehr hell werden sie 
dann nicht sein.
nimm da 220 oder so.
10k am reset sind auch ein bisschen wenig, oder?
laut Datasheet: 30kOhm <= R_{RST} <= 80kOhm

Autor: Stefan_KM (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Am Reset reichen 10 k und 10n nach GND.

Der Vorwidersatnd sollte auf keine Fall zu klein sein, nur um die LED 
heller leuchten zu lassen. Ein PORT PIN des ATMEGA 8 kann nur 20mA. Bei 
5V solltest du auf keinen Fall kleiner werden als 250Ohm. Da der Strom 
aber nicht ausgereitzt werden sollte, nimm lieber Low Current LED die 
brauchen nur 4mA und dann bist du mit 1k auf der sicheren Seite.

Autor: Vlad Tepesch (vlad_tepesch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
die ports des mega8 können 40mA in beide Richtungen. (absolute Maximum 
Ratings - 20 sind also voll ok)

Autor: Martin M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist die Schaltung abgesehen von der Richtung der LED´s soweit richtig?

Autor: olol (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wirst du damit auch Layouten? Denn die schwarzen Punkte kann ich nicht 
nachvollziehen, sind das Verbindungen? Bei +5V sieht es so aus als wäre 
nicht alles verbunden und beim linken GND Pin des Atmega fehlt der Punkt 
bei der Leitungsverbundungen.

Autor: Martin M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein, das sollte nur zur Übersicht dienen und die schwarzen Punkte 
sollten die Pole sein und die Spannungen darstellen und die beiden GND´s 
sind auch auf Masse gelegt hab nur in der Skizze vergessen einen 
Verbindungspunkt zu setzen.
Ich hab die Led´s nochmal richtig rum eingebaut, aber sie leuchten noch 
immer nicht, zudem ist mein Multimeter kaputt gegangen und kann mir 
übers Wochenende kein neues besorgen. Könnte vllt. wo anderes ein Fehler 
sein.

Um noch mal auf "olol´s" Beitrag einzugehen, welcher Kondensator muss 
direkt neben welchem IC sein?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.