mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LED leuchtet nicht nach


Autor: V.H. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
habe beigefügte Schaltung erstellt mit dem Ziel eine LED ausgangsseitig 
nachleuchten zu lassen. Lasse aus diesem Grund eingangsseitig eine Diode 
an einen Elko und Widerstand schalten, nach schalten des npn-Transistors 
wollte ich sicherheitshalber noch einen Inverter an die 24V 
Versorgungsspannung anhängen.
Was bei Messversuchen nun passiert ist, dass die LED erstmal 
Anlaufschwierigkeiten hat bis sie aufleuchtet und leuchtet dann nach 
trennen der Spannungsversorgung nur für sehr kurze Zeit nach, obwohl 
laut meinen Berechnungen ca. 22s rauskommen sollten.
Danke im vorraus für schnelle Antworten.

Mfg
V.H.

Autor: V.H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
entschuldigt für den doppelten Post des Bildes...

Autor: Martin S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also der Elko speist den Transistor, aber nicht die LED. Wenn du die 
Versorgungsspannung abtrennst bleibt der linke Transistor leitend, kann 
aber keinen Strom durchlassen weil dieser ja abgeschaltet wurde. 
Irgendwie ist die Schaltung falsch. Oder liegen hier zwei getrennte 
Versorgungsspannungen an und du schaltest nur eine ab?

Autor: V.H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Muss mich korrigieren in meiner Schreibweise:
Ich trenne nicht die Spannungsversorgung (wär ja auch irgendwie 
bescheuert)
sondern eine Impulsspannung, die ich über "IN" einspeise...
Spannungsversorgung bleibt natürlich permanent!

Autor: yalu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Woher kommt die Eingangsspannung an IN und wie hoch ist sie?

Autor: Nachleuchter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So etwa um die 12 Volt ? und 20 Millisekunde lang, das reicht nicht 
lange.
Und niederohmig muß er sein, damit der Elko auch energetisch voll wird.

Autor: V.H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist ne Impulsspannung mit 5V.
hatte mir schon überlegt ob nicht vielleicht der 47k R4-Widerstand zu 
gering ist. vielleicht sollte ich den ver10fachen...
und den an der LED (R6) vielleicht auch etwas erhöhen... damit ich 
sicher sein kann, dass die LED auch nicht zerbrutzelt wird... (ist mir 
beim Messen schonmal passiert bei meinem 1. Messversuch, da hatte ich 
aber auch nur einen 470R Vorwiderstand)

Autor: V.H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Nachleuchter:
12 Volt sagst du... gleich mal messen...

Autor: V.H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab jetzt einen 12 V Impuls eingespeist, der war etwas zu stark, habe 
dadurch 2 LED's geschrottet.
Hab aber dann den Widerstand an R2 erhöht auf 1M und voíla, habe eine 
Nachleuchtzeit von ca. 25s erhalten!
Danke für die raschen Antworten!

Greetz
V.H.

Autor: Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
>Hab aber dann den Widerstand an R2 erhöht auf 1M und voíla, habe eine
>Nachleuchtzeit von ca. 25s erhalten!
Das kommt mir etwas komisch vor.
Du hast nicht zufällig R4 auf 1M gebracht?
100µ*47K(R4) hat ein Tau von 4,7s, von 12 auf 0,7V (Ube) könnten da fast
passen.
100µ*1M = 100s, die 680K dazu, da könnte ich mir 25s vorstellen,
aber mit R2 = 1M ????

Oder ich habe heute einen totalen Aussetzer.

Viel Erfolg, Uwe

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.