mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ModellServo2FahrtreglerSignal


Autor: Jens K. (hagendasz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!
Hoffe in das richtige Forum zu posten ;-)
Vielleicht kann mir ja hier jemand helfen...

Ich brauche eine "kleine" Schaltung als Übersetzer, der ein PCM 
Servosignal in ein PWM Fahrtreglersignal umwandelt. also

rein      raus
Servo-    Speed
signal    signal
PCM       PWM
    -----
B - | A | - B
R - | V | - R
W - | R | - Y
    -----

Servosignal kommt aus nem phidget 1061
Speedsignal soll in ein Tamiya TEU-101BK

Vor Jahren habe ich mich ein wenig mit Atmel beschäftigt,
aber man sollte dazu stehen, wenn man es nicht kapiert!-)
Ausserdem habe ich keine Entwicklungsumgebung...

Hat jemand so was schon gebaut?

Danke für Anregungen und ideen!

hagendasz

Autor: Thomas Decker (t0mmy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Signale sind doch vollkommen identisch, oder etwa nicht? Man kann an 
einen Modellbauempfänger den Servo und den Fahrregler ja an jeden Kanal 
anschließen, und es tut (mal von der exotischen Steuerung abgesehen).

Du kannst die 3 Kabel also genau so verbinden, wie du es dargestellt 
hast. Nur eben der AVR brauchst du nicht.

Der Fahrtregler erwartet die gleichen PWM-Timings wie ein Servo...

Autor: Jens K. (hagendasz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das habe ich auch gedacht und mich voller vorfreunde auf die 
Programmierung gestürtzt....
leider ist dem nicht so.
Aus dem Phidget 1061 kommt ein PCM das mit allen normalen Servos läuft,
(siehe technik sektion in
http://www.phidgets.com/documentation/Phidgets/1061.pdf)

Leider bekomme ich den Fahrtregler bei allen per API übergebenen 
gegebenen Werten von -22 bis 233 nur dazu, entweder nichts zu tun oder 
Vollgas nach hinten zu geben... der Fahrtregler ist dieser
http://tamico.de/Tamiya-Fahrtenregler-TEU-101BK-45029
da steht nur Pulse System mit hoher Frequenz( 1KhZ)

Danke für die schnelle Response!!!

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Einfaches Einstellen/Setup durch Ein-Tasten-Bedienung.

Hast du den Fahrregler auch korrekt eingestellt?

Autor: Jens K. (hagendasz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hoffe,
Am RC Empfänger arbeitet der Regler jedenfalls einwandfrei
vor und nach Test am Phidget...
Ich such mal nach doku zum einstellen...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.