mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik MEGA8-P = ATMEGA8-16PU?


Autor: icke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe ein Problem beim bauen von dem USB-Parametriergerät.
http://www.ulrichradig.de/home/index.php/avr/usb-avr-prog

Wenn ich es mit Ponyprog über LPT programmiere und die Fusel setzte 
macht der Chip nix mehr. (der Quarz schwingt)

kann es daran Ligen das das ich ein:

ATMEL 0822G
ATMEGA8-16PU

habe oder programmiere ich das Ding falsch?

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welchen Fusel benutzt Du?

Autor: icke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich hatte es fertig aufgebaut und dann wie im bild geschriben (nur 
BODLEVEL, BODEN, SPIEN)

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich fragte nach Fusel :-)

12Mhz Quarz verbaut ?

Autor: icke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das sind doch die Fuses oder bring ich jetzt alles durcheinander?

Ja es war ein 12MHz Quarz daran der auch laut Ozi richtig schwung.

Autor: Patrick B. (p51d)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
icke schrieb:
> Ich habe ein Problem beim bauen von dem USB-Parametriergerät.
> http://www.ulrichradig.de/home/index.php/avr/usb-avr-prog
>
> Wenn ich es mit Ponyprog über LPT programmiere und die Fusel setzte
> macht der Chip nix mehr. (der Quarz schwingt)

was meinst du mit macht nichts mehr?? hast du versucht ihn an den PC 
anzuschliessen und dann solltest du wahrscheindlich aufgefordert werden, 
einen Treiber zu installieren, oder ein Firmewareuptdate zu machen.

Habe mir mal selber so ein Ding zusammengebaut von www.ullihome.de

> kann es daran Ligen das das ich ein:
>
> ATMEL 0822G
> ATMEGA8-16PU
>
> habe oder programmiere ich das Ding falsch?

Das du einen PU-Typ verwendest, sollte keinen Unterschied in der 
Ausführung der Programme machen, da das 'P' lediglich für picopower 
steht.

Autor: avr (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Patrick

Das "PU" sagt lediglich was über das Gehäuse; hier ein PDIP.

Passend "AU" für TQFP und "MU" für MLF.

Mega8 mit Picopower gibt es nicht!

avr

Autor: icke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich es an den USB Port anschließe kommt zwar Hardware gefunden aber 
nach kurzer zeit kommt "Hardware nicht erkannt" (kommt auch wenn ich nur 
die Datenleitungen auf 3V ziehe).

Ich kann ihn auch nicht mehr über SIP ansprechen.

Autor: Brigitte (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
War es nicht bei PonyProg so, dass alle Fuses invertiert angezeigt 
werden ?

B.

Autor: Patrick B. (p51d)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
icke schrieb:
> Wenn ich es an den USB Port anschließe kommt zwar Hardware gefunden aber
> nach kurzer zeit kommt "Hardware nicht erkannt" (kommt auch wenn ich nur
> die Datenleitungen auf 3V ziehe).

kling sehr nach einem programmier-proglem: entweder ist die software 
nicht richtig gebrannt worden, oder es liegt auf dem pc ein 
treiberproblem vor.

> Ich kann ihn auch nicht mehr über SIP ansprechen.
klingt na verfused.

wie schon Brigitte gesagt hat, bei Ponyprog sind die Fuses gesetzt, wenn 
sie 0 sind

Autor: icke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich weiß

auf den beiliegenden Bild ist auch [v] = Programmed (bit=0)

Autor: ptlbahn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hole es doch noch einmal hoch!
Ich habe ein ähnliches Problem, eine schaltung mit ATMega8L8. Bei der 
bestückung mit einen ATMega8L8MI ist mit dem Ponyprogramm das 
programieren des AVR problemlos möglich. Ist die selbe Schaltung aber 
mit einem ATMega8L8MU bestückt, meldet Pony immer das er den Prozessor 
nicht findet!
alle MI sind IO und alle MU streicken beharlich! Eigendlich unmöglich, 
ich weiß, aber hat da einer eine Idee zur Problemlösung?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.