mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Sprut Brenner 8.rev5 -> Quarz schwingt nicht an


Autor: Johannes Schneider (schneijo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo allerseits,

Ich habe den Sprut Brenner8 in der Rev.5 in einem Format das dem 
Brenner8 mini nahe kommt als zweiseites PCB nachgebaut. Sieht echt 
schnike aus das Teil nur der Quarz läuft nicht.

Ich habe schon einiges ausprobiert, Quarz getauscht, Kapazitäten 
getauscht und variiert, mit drei verschiedenen SteuerPICs probiert, er 
läuft nicht an.

Für den SteuerPIC nehme ich den 18F2550 im SOIC-Gehäuse. Der hat doch 
hoffentlich keine anderen Konfigurationseinstellungen nötig. Den 
SOIC-PIC brenne ich mit meinem guten alten Parallel-Port-Brenner5. Dabei 
übernimmt die Brenner-Software die Config-Einstellungen aus dem Hex-File 
(boot_0_20mhz.hex). Der Pic wird auch korrekt gebrannt. Ich habe das 
Prozedere mehrmals wiederholt, Configuration stimmt mit dem Hex-File 
über ein. Danach wird der PIC in die Schaltung eingelötet und der Quarz 
läuft nicht. Habs auch schon mit mehreren PICs versucht, nix.

Dabei sollte das Löten nichts ausmachen, ich hab wirklich auf extrem 
kurze Lötzeiten geachtet ... oder ist das generell ein großes Problem?

Um die Sache weiter einzugrenzen habe ich auf einem Steckbrett den 
gleichen SteuerPIC im DIL-Gehäuse mit Quarz, USB-Stecker und nur den 
LED´s aufgebaut.
Da läuft die ganze Sache ... der Oszillator schwingt, der nicht wirklich 
Brenner wird als Sprut-Brenner im Windows-Gerätemanager erkannt, USBurn 
erkennt den Brenner und ich kann die LED´s der Programmierspannungen an 
und ausschalten ... verrückt ... und das auf nem Steckbrett ... ich fass 
es nicht.

Naja wie auch immer, mein so mühevoll designter Brenner8 läuft nicht 
wegen dem Quarz-Problem, was läuft hier falsch?

viele Grüße

Juppy

Autor: Ben ___ (burning_silicon)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bleibt ja nur ein fehler an der platine.

Autor: Johannes Schneider (schneijo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja, die Schaltung ist nicht wirklich kompiziert ...
Es gibt dort einen PIC, Quarz und zwei Kapazitäten für den Resonator.
Dann den USB-Stecker ... that´s it!

Die gleiche Schaltung funktioniert schließlich auf dem Steckbrett.

Was kann da noch falsch laufen?

Hat jemand schon mal PICs gebrand und anschließend eingelötet? Läuft das 
dann auch in der Schaltung?

viele Grüße

Juppy

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Was kann da noch falsch laufen?

Kurzschluß auf der Quarzleitung, die Kondis nicht mit Masse
verbunden.

>Hat jemand schon mal PICs gebrand und anschließend eingelötet? Läuft das
>dann auch in der Schaltung?

No Problems.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mess mal die Spannung an MCLR. Wenn der gegen Masse kurzgeschlossen ist, 
geht auch nichts.

Autor: Johannes Schneider (schneijo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die super Ideen, aber nochmal zu den Gegebenheiten ...

Der MCLR Pin ist high -> no reset state

die Quarzleitungen sind nicht kurzgeschlossen

die Kapazitäten liegen einseitig auf Masse  ...


... das ist ein Sch... ich glaub ich bau das Ding nochmal neu auf.

Es sei denn euch fällt noch was ein ...

Danke soweit - Juppy

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Naja, die Schaltung ist nicht wirklich kompiziert ...
>Es gibt dort einen PIC, Quarz und zwei Kapazitäten für den Resonator.
>Dann den USB-Stecker ... that´s it!

Abblockkondensator VCC-GND ist auch vorhanden?
Wichtig ist auch der Kondensator an VUSB.
Ohne den läuft USB nicht, und dort gehört NICHT
die 5V vom USB Port dran.

Autor: Johannes Schneider (schneijo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
100nF Abblockkondensator vorhanden.
220nF Stütze für die 3.3V des VUSB pins vorhanden.

Die beiden Spannungen stimmen auch vom Wert her ...
was soll ich sagen ... ich weiß nicht woran es liegt ... es sollte 
wirklich laufen.

mfg Juppy

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Die beiden Spannungen stimmen auch vom Wert her ...
>was soll ich sagen ... ich weiß nicht woran es liegt ... es sollte
>wirklich laufen.

Ja, das sollte es. Also entweder die Kondensatoren
am Quarz sind zu groß, zu klein, der Quarz ist nicht
am PIC angeschlossen oder die Configuration wurde
nicht richtig programmiert.

Autor: Peter R. (pnu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mir fällt nur noch die Frage ein :

Was steht denn auf den Kondensatoren, vielleicht sind es 220 pF anstatt 
22pF ?

Autor: Andreas T. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Johannes,

konntest Du das Problem lösen? Ich habe mit dem Brenner8p jetzt genau 
das selbe Problem.

Liegt meiner Meinung nach an dem Quarz. Die Stückliste liefert unter der 
Bezeichnung "20,0000-HC49U-S" bei Reichelt einen Quarz, der eine 
Lastkapazität von 32pF hat. Das ist ziemlich viel.

Ich werde mal probieren, die beiden Kondensatoren C2, C3 gegen 50-60pF 
zu tauschen. Alternativ ein Quarz bei Conrad hat nur 17pF C(L).

MfG,
--Andreas.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.