mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LCD YL162-90 Pollin Initialisierung und Timing (16x2)


Autor: Andy M. (medix)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Ich habe das LCD von Pollin YL162-90 
http://www.pollin.de/shop/dt/OTM5OTc4OTk-/Baueleme... 
an EXT vom Pollin AVR NET IO angeschlossen. Kontrastspannung zape ich 
vom MAX232 mit Trimmpoti ab. Funzt soweit ganz gut, Display geht also 
an, Zeile 1 und 2 füllen sich flink mit schwarzen Kästchen.

Beim anmachen des Boards passiert also folgendes:

1. Zeile 1 schwarze Kästchen sofort beim einstecken des Stroms
2. kurzes flackern
3. Hintergrundbeleuchtung geht an, beide Zeilen füllen sich mit 
schwarzen Kästchen
4. nach ca, 4 Sekunden flackert es nochmal kurz, dannach bleiben die 
schwarzen Kästchen.

Ich nehme an, dass das LCD nicht richtig initialisiert. Leider ist das 
Datenblatt sehr sehr dürftig. Kann man sich bei Pollin ansehen.

Ich bräuchte sowohl Daten zum Timing als auch die "sicherheit", dass der 
Initialisierungsstring 100% HD44780 - kompatibel ist. Ob nämlich 
tatsächlich der HD44780-Controller verbaut ist kann ich nicht sagen, da 
dort ein fetter Aufkleber drauf ist.

Kann mir da jemand mit Daten oder Tipps helfen? Anbei noch die lcd.c mit 
der ichs versuche.

Andy

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>Kontrastspannung zape ich
>vom MAX232 mit Trimmpoti ab. Funzt soweit ganz gut, Display geht also
>an, Zeile 1 und 2 füllen sich flink mit schwarzen Kästchen.

Sieht eher nach falscher Kontrastspannung aus.

MfG Spess

Autor: Andy M. (medix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kontrastspannung beträgt genau -2,52V. Durch den Trimmi kann ich die ja 
auch höher bzw. niedriger drehen. Unter -1,5V ist nur noch die 
Hindergrundbeleuchtung zu sehen. Über -2,5V gibts keine Änderung. Ich 
schließe eine falsche Kontrastspannung aus. (Wie geschrieben: Vom MAX232 
Pin6 über nen Trimmi)

Autor: Icke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab das Teil auch. Bis auf die negative Kontrastspannung gibts 
keinen Unterschied zu anderen 44780-kompatiblen. Kann ich mit Sicherheit 
sagen, da ich auf dem Steckbrett nacheinander verschiedene LCDs mit ein 
und demselben Programm ausprobiert habe.

Autor: Andy M. (medix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aber ich habe 2,5V- anliegen. Ich check nochmal die Zuleitungen...

Autor: Icke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Könnte auch defekt sein. So ähnlich verhielt sich ein Display, bei dem 
ich auf dem Steckbrett versehentlich den GND-Pin an Vcc angeschlossen 
hatte. Danach kamen noch die schwarzen Balken, angezeigt wurde aber nix 
mehr.

Autor: Andy M. (medix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hatte - wie in 99% der "LCD-geht-nicht-Threads" was falsch angeschlossen 
(R/W und RS vertauscht). Nu funzt es. Danke

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.