mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit Anschluss-LCD Controller


Autor: Dierter Meiser (kabn)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Erstmal ein HALLO, an alle User im Forum. Habe mich heute hier 
angemeldet und hoffe, dass das Unterforum was ich gewählt habe richtig 
ist.

Wie man dem Text mit Sicherheit entnehmen kann, sind meine Technik 
Kentnisse, nicht gerade die Besten. Ich hoffe deshalb, dass ihr Profis 
mir weiterhelfen könnt.
Ich habe ein Controller-Board für ein LCD mit der Bezeichnung PW106, der 
Hersteller ist Pixelworks.
Verkauft wurde dieses Board unter den Angaben, dass es mit 12V laufen 
soll.
Als Netzteil steht mir ein ATX Netzteil zur Verfügung

Anschlüsse gibt es folgende:
GND
GND
+12
+12

ON/OFF
+STB
VS_ON
+5
+5
GND
GND

Laut Verkäufer läuft alles nur über 12V. Wenn ich es jetzt nur 12V 
verbinde (und GND natürlich) und das Netzteil starte, ist das Board im 
Standbymodus, zu erkennen an einer roten LED am Keyboard. Versuche ich 
es jetzt über die Ferbedienung, einzuschalten, gibt es irgendwo einen 
Kurzschluss, und der Controller geht inkl. Netzteil aus.

Nach ein wenig rumgeteste, kriege ich ihn nur zum laufenb, wenn ich +12V 
und 5V auf VS_ON anschließe. Dann geht der COntroller direkt an, jedoch 
habe ich keinen Standby Modus.
Das Problem an der ganzen Sache ist, dass ich mit diesem Anschluss weder 
1:1 Mapping am LCD zur Verfügung habe, noch kann HDCP (Kopierschutz für 
Blu-Rays) aktiviert werden..

Daraufhin habe ich mit jemandem in China Kontakt aufgenommen, der die 
Teile dort verkauft, und sich zumindestsens mehr auskennt als ich.
Der nette Herr meinte nun zu mir, dass es ein Muss ist, den Controller 
auch an 5V anzuschließen, da erst hierdurch viele Funktionen aktiviert 
werden.
Also habe ich es nach seiner Anleitung angeschlossen.

GND - GND
GND - GND
+12V - +12V
+12V - +12V

ON/OFF - -
+STB - +5V
VS_ON - -
+5V - +5V
+5V - +5V
GND - GND
GND - GND

Schließe ich es so an, kriege ich den Kurzschluss schon wenn ich das 
Netzteil einschalte.
Ich schreibe die ganze Zeit von einem Kurzschluss, da es in meinen Augen 
die einzigste Erklärung, dafür ist, warum sich in den Situationen das 
Netzteil abschaltet.

Noch als Info:
Wenn ich nur 12V und GND anschließe, habe ich bereits gemessene 12V auf 
dem 5V Kontakt.
Ist das richtig so?

Schon jetzt einmal VIELEN DANK.


Gruß
KABN

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.