mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Sch*** ISP


Autor: Barti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tach auch!

Also ich bin stinksauer, denn ich hab ein ISP-Adapter mit einem 74HC244 
aufgebaut. Ausprobiert - geht nicht. Nächster Schritt, ein Adapter mit 
einem 74LS244 - geht nicht. Dann fand ich eine Schaltung mit einem 
74HC14, was passierte? NICHTS! Ist doch nicht drin. Hab auch schon 
gedacht, der AVR ist kaputt (war ein 4433). Habe es dann mit einem 2313 
versucht - es passiert das gleiche, also nichts. Kann mir mal einer eine 
funktionierende Schaltung geben? Ach noch was: hab es mit AVR-Studio, 
AVR-ISP und Pony-Prog versucht! Ich dreh noch durch.

MFG Barti

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Barti,
du bist nicht der einzige mit diesem Problem. Ich bin gerade dabei ein 
Platine mit einem 8535 aufzubauen und werde sowohl den PonyProg (seriell 
und parallel) und den Progger von µC-Projekt mal testen.
In zwei bis drei Tagen habe ich denke ich ein Ergebniss

Gruß
Markus

http://www.elektronik-projekt.de

Autor: Meiserl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jungs

probiert mal den hier.

http://users.skynet.be/jiwan/Electronique/English/...

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke, mal schauen ob der funktioniert. Jetzt brauch ich nur noch ein 
paar 5V1 Z-Dioden.
Hast Du den schon mal getestet?
Wie gesagt, ich werde das diese Woche mal testen. Dann nehm ich den 
einfach auch dazu :)

Gruß
Markus

http://www.elektronik-projekt.de

Autor: Holger Barske (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute!
Versteh' ich nicht so ganz, das Problem. Habe mich mit dem ISP-Adapter 
vom STK-200 unter AVR-ISP bislang völlig ohne Probleme durch 1200, 2313, 
4414, 8515, 8535 programmiert.
Das Schaltblid dazu ist im Anhang. Ich hab' auch mal ne Platine dazu 
gemacht (ohne SMDs), wenn's von Interesse ist, kann ich das Layout ja 
mal hier posten.
P.S. Ich baue immer einen ISP-Header in die Anwendungen mit ein, das STK 
200 slbst ist somit natürlich nicht erforderlich.

Grüße: Holger

Autor: Holger Buss (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Folks!

Probiert mal das ISP-Tool von meiner Seite:
http://www.mikrocontroller.com
(Download)

oder
http://www.freenet.de/buss

Das funzt 100% !
Und einfach nur 5 Leitungen ohne sonstige Schaltung.
Folgendes noch: ein Kondensator über der Versotgung des Chips direkt am 
Bauteil ist umbedingt erforderlich (mind. 100nF)

Gruss,
Holger

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jan klar, den Programmer vom STK200 hab ich auch. Ich habe aber jetzt 
schon von mehreren gehört, die Probleme mit den "Freewareproggern" 
haben. Ob die jetzt von den Proggern kommen oder an den Leuten Liegt 
weiß ich nicht.
Ich werde mich zumindest mal damit beschäftigen und mal ein paar 
austesten.

Gruß
Markus

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.