mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVRISP MKII zeigt Target Voltage falsch an


Autor: Ferd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zamme,


wie der titel schon sagt liest mein Atmel AVRISP MKII die Target Voltage 
falsch aus. am Board messe ich 5,2V aber im Avr- Studio zeigt es nur 
2,2V an. zu Programmieren geht es aber trotzdem. hatte mich anfangs 
darauf verlassen uns so Vacc vom Board auf ca 7V(!) hochgedreht. Der 
Programmer scheint es aber überlebt zu haben (wieso eigentlich?? kennt 
jemand den Schltplan?)

Kann mir jemand sagen, ob dieses falsche Auslesen normal ist, oder ob 
ich da was einsstelen muss (der Regler Vtarget im AVR-Studio lässt sich 
allerdings nicht verschieben)???

Ach ja Target ist ein Attiny26 interner Oszillator, Grundschaltung

Danke schon mal

Ferd

Autor: wt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich würde sagen, ca. 2V ist die Dif. zwischen deiner Vcc 5,2V und 7V, 
die Du angelegt hast. Wenn dein Programmer bei Vcc unter 5V immer noch 
falsch anzeigt, ist er hin. So etwas passiert. Für gewönlich 
funktioniert die Messung gut, ohne daß man was drehen muß.

Autor: ferd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wenn ich die spannung auf 5V drehe, zeigt mir das AVR- Studio 2,2V an, 
wenn ich 7V habe, dann zeigt es mir 4V an... immer ca 3V versatz. 
Programmieren und so tut er aber noch einwandfrei, das habe ich schon 
ausprobiert.

Autor: Ben ___ (burning_silicon)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> hatte mich anfangs darauf verlassen uns so Vacc vom Board auf ca 7V(!)
> hochgedreht.
glückwunsch! wieso sollte man der anzeige seines multimeters oder 
labornetzteil auch mehr glauben schenken als einem kleinen gag seines 
programmers...? naja, zum glück wars diesmal kein atomkraftwerk.

Autor: Ferd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ben _ schrieb:
> glückwunsch! wieso sollte man der anzeige seines multimeters oder
>
> labornetzteil auch mehr glauben schenken als einem kleinen gag seines
>
> programmers...?

desswegen könnt ich mich selber orfeigen, dafür muss ich eigentlich 
nicht in einem Forum posten..... aber du hast recht.

@ alle anderen, die weiterhelfen wollen: der Programmer ist neu und hat 
dieses Verhalten schon von anfang an gezeit. könnte es ein 
Bestückungsfehler auf der Platine vom AVRISP sein??

danke schon mal

Grüsse

Ferd

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Miß mal direkt am VCC-Pin des Programmiersteckers.
Das ist nur ein Eingang, d.h. Einstellversuche per AVRStudio sind 
Unsinn.

Ist die Batterie von Deinem Voltmeter auch frisch?


Peter

Autor: Ferd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ peda

Am VCC Pin des Programmiersteckers wird z.B. 5V gemessen, und AVR- 
Studio zeigt 2,2V an.

Denke auch nicht, dass der Programmer durch die Überspannung gehimmelt 
werden kann, zumindest nicht wegen 7V statt 5V der müsste gegen sowas 
doch abgesichert sein, oder?

Mein Verdacht ist, dass die VCC Spannung intern über einen 
Spannungstelier gemessen wird, und dieser nicht i.O. ist...

Autor: Ben ___ (burning_silicon)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wie teuer ist das ding? wenn man es abschreiben kann und die garantie 
sowieso nie in anspruch nimmt könnte man es öffnen und die spannung 
direkt am µC oder womit der diese misst prüfen. dann braucht man nur 
noch das programm bzw. die einstellungen des ADC um rauszufinden welche 
spannung anliegen müßte damit 5V angezeigt werden.

Autor: Ferd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja das könnte ich machen. Das Teil kostet ca 35 € also nicht die Welt. 
Und funktionieren tut es ja noch, zumindest bis jetzt.... . Es würde 
mich aber schon interessieren, warum die spannung falsch gemessen wird. 
werde das heute abend mal prüfen.

Danke allen inzwischen für die Hilfe

Grüsse

Ferd

Autor: wt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ca 40,- €

mess mal nicht nur Vcc, sondern auch die restlichen Leitungen durch, was 
haben die für Pegel?

Autor: David (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du mal ein Update der FW gemacht?

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ferd schrieb:
> Und funktionieren tut es ja noch, zumindest bis jetzt.... .

Das ist doch die Hauptsache.

Ich hab bisher noch nichtmal gewußt, daß man die Spannung anzeigen kann.
Ich habs einfach nicht gebraucht.


Peter

Autor: Ferd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
David schrieb:
> Hast du mal ein Update der FW gemacht?

leider nicht, wenn ich das über AVR Studio machen will kommt eine 
Meldung dass man den Programmer in den "Update Modus" versetzen muss, um 
das tun zu können ("flashing orange LED" oder so)

In den unterlagen (CD), die ich mit dem Programmer bekommen habe steht 
aber nicht wie man das macht.

Grüsse

Ferd

Ps.: weil wir schon dabei sind: AVR-Studio gibts nicht zufällig auf 
deutsch auch?? wäre manchmal eine grosse Hilfe.....

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>In den unterlagen (CD), die ich mit dem Programmer bekommen habe steht
>aber nicht wie man das macht.

Aber in der AVR-Studio-Hilfe zum  AVRISP MKII -> 4.2 Manual Firmware 
Upgrade

MfG Spess

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.