mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVRSTUDIO + IAR C


Autor: Hans Fanic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich möchte ein mit dem IAR C Compiler erzeugtes Programm mit dem AVR 
Studio debuggen.

Dazu habe ich in den IAR Projekt Optionen als Debug Format ubrof-8 
angegeben. Wenn ich aber das Debug File mit dem AVR Studio lade erhalte 
ich die Meldung:

AVR Simulator: Uninitialized stack pointer used at 0x0034

Das sieht für mich so aus wie wenn der Startup Code nicht dazugelinkt 
wird. Mit dem C-Spy Debugger kann ich aber die Simulation sauber 
starten.

Was muss ich noch einstellen?

CU Hans

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.