mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LUFA Demo's implemetieren


Autor: burnout2000 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Frohe Weihnachten :-)

Hat jemand bereits Erfahrungen mit LUFA gesammelt?
Ist es möglich eine LUFA - Demo z.B. VirtualSerial in ein bestehendes 
(fertiges) Projekt zu integrieren??
Bin schon fast am verzweifeln.....

Danke für Eure Hilfe

Gruß

Autor: Einhart Pape (einhart)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn du deine Fragen englisch artikulieren kannst, solltest du 'mal im 
AVRfreaks.net Forum nachfragen. Dort ist Dean Camera, der Author von 
LUFA, recht aktiv und er ist sehr hilfsbereit.

Autor: burnout2000 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
danke für deine Antwort.

Werde mal dort posten!

Autor: Thomas Burkhart (escamoteur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Würde mich interessieren, wie Du voran kommst, werde demnächst auch 
damit arbeiten.

Gruß
Tom

Autor: burnout2000 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So,
habs jetzt endlich hingekriegt nen Virtuellen COM Port über die USB 
Schnittstelle im AT90USB1287 zu erzeugen.
Funktioniert einwandfrei und war im nachhinein gar nicht so übel wie ich 
dachte :-)

Autor: David H. (batboy)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi !

Ich habe auch Startprobleme:
Wenn ich die VirtualSerial aus den Demos kompiliere und aufspiele sgat 
WinXP nur "Gerät nicht erkannt". Den im Verzeichnis liegenden Treiber 
.inf akzeptiert WinXp nicht dafür.
Alles was ich verändert habe (LUFA111009) ist in der makefile:
MCU = at90usb1287
BOARD = NONE
F_CPU = 16000000

Ich verwende ein eigenes Board (s. Schaltplan), daher das "NONE". Aber 
als serielle Schnittstelle müsste es doch dennoch von XP erkannt werden, 
oder?

Was war bei Dir der Trick?

Zusatz: Als ich das Board das erste mal per usb einsteckte wurde es als 
Gerät erkannt und XP wollte einen Treiber suchen, atmel hat da wohl 
einen bootloader drauf. Der war leider nach dem ersten programmieren per 
SPI weg....

Danke, David

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.